summaryrefslogtreecommitdiff
blob: 02d4da4d79252fea4ba55f21628224c245fddcfe (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">

<glsa id="200807-01">
  <title>Python: Multiple integer overflows</title>
  <synopsis>
    Multiple integer overflows may allow for Denial of Service.
  </synopsis>
  <product type="ebuild">python</product>
  <announced>July 01, 2008</announced>
  <revised>July 01, 2008: 01</revised>
  <bug>216673</bug>
  <bug>217221</bug>
  <access>remote</access>
  <affected>
    <package name="dev-lang/python" auto="yes" arch="*">
      <unaffected range="rge">2.3.6-r6</unaffected>
      <unaffected range="ge">2.4.4-r13</unaffected>
      <vulnerable range="lt">2.4.4-r13</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    Python is an interpreted, interactive, object-oriented programming
    language.
    </p>
  </background>
  <description>
    <p>
    Multiple vulnerabilities were discovered in Python:
    </p>
    <ul>
    <li>David
    Remahl reported multiple integer overflows in the file imageop.c,
    leading to a heap-based buffer overflow (CVE-2008-1679). This issue is
    due to an incomplete fix for CVE-2007-4965.</li>
    <li>Justin Ferguson
    discovered that an integer signedness error in the zlib extension
    module might trigger insufficient memory allocation and a buffer
    overflow via a negative signed integer (CVE-2008-1721).</li>
    <li>Justin
    Ferguson discovered that insufficient input validation in the
    PyString_FromStringAndSize() function might lead to a buffer overflow
    (CVE-2008-1887).</li>
    </ul>
  </description>
  <impact type="normal">
    <p>
    A remote attacker could exploit these vulnerabilities to cause a Denial
    of Service or possibly the remote execution of arbitrary code with the
    privileges of the user running Python.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    The imageop module is no longer built in the unaffected versions.
    </p>
    <p>
    All Python 2.3 users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose &quot;&gt;=dev-lang/python-2.3.6-r6&quot;</code>
    <p>
    All Python 2.4 users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose &quot;&gt;=dev-lang/python-2.4.4-r13&quot;</code>
  </resolution>
  <references>
    <uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1679">CVE-2008-1679</uri>
    <uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1721">CVE-2008-1721</uri>
    <uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1887">CVE-2008-1887</uri>
  </references>
  <metadata tag="submitter" timestamp="Fri, 27 Jun 2008 08:54:25 +0000">
    keytoaster
  </metadata>
  <metadata tag="bugReady" timestamp="Tue, 01 Jul 2008 11:46:03 +0000">
    keytoaster
  </metadata>
</glsa>