summaryrefslogtreecommitdiff
blob: 7dace426b1f6108b2001656fddd55503e79ed786 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200907-02">
  <title>ModSecurity: Denial of Service</title>
  <synopsis>
    Two vulnerabilities in ModSecurity might lead to a Denial of Service.
  </synopsis>
  <product type="ebuild">mod_security</product>
  <announced>2009-07-02</announced>
  <revised>2009-07-02: 01</revised>
  <bug>262302</bug>
  <access>remote</access>
  <affected>
    <package name="www-apache/mod_security" auto="yes" arch="*">
      <unaffected range="ge">2.5.9</unaffected>
      <vulnerable range="lt">2.5.9</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    ModSecurity is a popular web application firewall for the Apache HTTP
    server.
    </p>
  </background>
  <description>
    <p>
    Multiple vulnerabilities were discovered in ModSecurity:
    </p>
    <ul>
    <li>Juan Galiana Lara of ISecAuditors discovered a NULL pointer
    dereference when processing multipart requests without a part header
    name (CVE-2009-1902).</li>
    <li>Steve Grubb of Red Hat reported that the
    "PDF XSS protection" feature does not properly handle HTTP requests to
    a PDF file that do not use the GET method (CVE-2009-1903).</li>
    </ul>
  </description>
  <impact type="normal">
    <p>
    A remote attacker might send requests containing specially crafted
    multipart data or send certain requests to access a PDF file, possibly
    resulting in a Denial of Service (crash) of the Apache HTTP daemon.
    NOTE: The PDF XSS protection is not enabled by default.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    All ModSecurity users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=www-apache/mod_security-2.5.9"</code>
  </resolution>
  <references>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1902">CVE-2009-1902</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1903">CVE-2009-1903</uri>
  </references>
  <metadata tag="requester" timestamp="2009-06-12T22:17:27Z">
    craig
  </metadata>
  <metadata tag="submitter" timestamp="2009-06-27T20:29:14Z">
    a3li
  </metadata>
  <metadata tag="bugReady" timestamp="2009-07-02T11:54:37Z">
    a3li
  </metadata>
</glsa>