summaryrefslogtreecommitdiff
blob: 4d5d3aec7c3e58d6152f8801e6f3c597bd0fd050 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200907-10">
  <title>Syslog-ng: Chroot escape</title>
  <synopsis>
    Syslog-ng does not properly initialize its chroot jail allowing for an
    escape if a separate vulnerability in Syslog-ng is exploited.
  </synopsis>
  <product type="ebuild">syslog-ng</product>
  <announced>2009-07-12</announced>
  <revised>2009-07-12: 01</revised>
  <bug>247278</bug>
  <access>local</access>
  <affected>
    <package name="app-admin/syslog-ng" auto="yes" arch="*">
      <unaffected range="rge">2.0.10</unaffected>
      <unaffected range="ge">2.1.3</unaffected>
      <vulnerable range="lt">2.1.3</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    Syslog-ng is a flexible and scalable system logger.
    </p>
  </background>
  <description>
    <p>
    Florian Grandel reported that Syslog-ng does not call chdir() before
    chroot() which leads to an inherited file descriptor to the current
    working directory.
    </p>
  </description>
  <impact type="low">
    <p>
    A local attacker might exploit a separate vulnerability in Syslog-ng
    and use this vulnerability to escape the chroot jail.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    All Syslog-ng 2.0 users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=app-admin/syslog-ng-2.0.10"</code>
    <p>
    All Syslog-ng 2.1 users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=app-admin/syslog-ng-2.1.3"</code>
  </resolution>
  <references>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5110">CVE-2008-5110</uri>
  </references>
  <metadata tag="requester" timestamp="2009-07-10T11:11:22Z">
    rbu
  </metadata>
  <metadata tag="submitter" timestamp="2009-07-10T11:21:31Z">
    rbu
  </metadata>
  <metadata tag="bugReady" timestamp="2009-07-10T11:21:44Z">
    rbu
  </metadata>
</glsa>