summaryrefslogtreecommitdiff
blob: a8c43777a9f332204dc209ecaeaed67a94cb8598 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201110-15">
  <title>GnuPG: User-assisted execution of arbitrary code</title>
  <synopsis>The GPGSM utility included in GnuPG contains a use-after-free
    vulnerability that may allow an unauthenticated remote attacker to execute
    arbitrary code.
  </synopsis>
  <product type="ebuild">GnuPG</product>
  <announced>2011-10-22</announced>
  <revised>2011-10-22: 1</revised>
  <bug>329583</bug>
  <access>remote</access>
  <affected>
    <package name="app-crypt/gnupg" auto="yes" arch="*">
      <unaffected range="ge">2.0.16-r1</unaffected>
      <unaffected range="lt">2.0</unaffected>
      <vulnerable range="lt">2.0.16-r1</vulnerable>
    </package>
  </affected>
  <background>
    <p>The GNU Privacy Guard, GnuPG, is a free replacement for the PGP suite of
      cryptographic software. The GPGSM utility in GnuPG is responsible for
      processing X.509 certificates, signatures and encryption as well as
      S/MIME messages. 
    </p>
  </background>
  <description>
    <p>The GPGSM utility in GnuPG contains a use-after-free vulnerability that
      may be exploited when importing a crafted X.509 certificate explicitly or
      during the signature verification process. 
    </p>
  </description>
  <impact type="normal">
    <p>An unauthenticated remote attacker may execute arbitrary code with the
      privileges of the user running GnuPG by enticing them to import a crafted
      certificate.
    </p>
  </impact>
  <workaround>
    <p>There is no known workaround at this time.</p>
  </workaround>
  <resolution>
    <p>All GnuPG 2.x users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=app-crypt/gnupg-2.0.16-r1"
    </code>
    
  </resolution>
  <references>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-2547">CVE-2010-2547</uri>
  </references>
  <metadata timestamp="2011-10-07T23:38:19Z" tag="requester">system</metadata>
  <metadata timestamp="2011-10-22T04:24:43Z" tag="submitter">
    underling
  </metadata>
</glsa>