summaryrefslogtreecommitdiff
blob: a83e517156d4141f67316cd3ab8b0c4af50f9b81 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201308-05">
  <title>Wireshark: Multiple vulnerabilities</title>
  <synopsis>Multiple vulnerabilities have been found in Wireshark, allowing
    remote attackers to execute arbitrary code or cause Denial of Service.
  </synopsis>
  <product type="ebuild">wireshark</product>
  <announced>2013-08-28</announced>
  <revised>2013-08-30: 2</revised>
  <bug>398549</bug>
  <bug>427964</bug>
  <bug>431572</bug>
  <bug>433990</bug>
  <bug>470262</bug>
  <bug>472762</bug>
  <bug>478694</bug>
  <access>remote</access>
  <affected>
    <package name="net-analyzer/wireshark" auto="yes" arch="*">
      <unaffected range="ge">1.10.1</unaffected>
      <unaffected range="rge">1.8.9</unaffected>
      <vulnerable range="lt">1.10.1</vulnerable>
    </package>
  </affected>
  <background>
    <p>Wireshark is a versatile network protocol analyzer.</p>
  </background>
  <description>
    <p>Multiple vulnerabilities have been discovered in Wireshark. Please
      review the CVE identifiers referenced below for details.
    </p>
  </description>
  <impact type="high">
    <p>A remote attacker could possibly execute arbitrary code with the
      privileges of the process or cause a Denial of Service condition.
    </p>
  </impact>
  <workaround>
    <p>There is no known workaround at this time.</p>
  </workaround>
  <resolution>
    <p>All Wireshark 1.10 users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=net-analyzer/wireshark-1.10.1"
    </code>
    
    <p>All Wireshark 1.8 users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=net-analyzer/wireshark-1.8.9"
    </code>
  </resolution>
  <references>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0041">CVE-2012-0041</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0042">CVE-2012-0042</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0043">CVE-2012-0043</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0066">CVE-2012-0066</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0067">CVE-2012-0067</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0068">CVE-2012-0068</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-3548">CVE-2012-3548</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4048">CVE-2012-4048</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4049">CVE-2012-4049</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4285">CVE-2012-4285</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4286">CVE-2012-4286</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4287">CVE-2012-4287</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4288">CVE-2012-4288</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4289">CVE-2012-4289</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4290">CVE-2012-4290</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4291">CVE-2012-4291</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4292">CVE-2012-4292</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4293">CVE-2012-4293</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4294">CVE-2012-4294</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4295">CVE-2012-4295</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4296">CVE-2012-4296</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4297">CVE-2012-4297</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4298">CVE-2012-4298</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-3555">CVE-2013-3555</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-3556">CVE-2013-3556</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-3557">CVE-2013-3557</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-3558">CVE-2013-3558</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-3559">CVE-2013-3559</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-3560">CVE-2013-3560</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-3561">CVE-2013-3561</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-3562">CVE-2013-3562</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4074">CVE-2013-4074</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4075">CVE-2013-4075</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4076">CVE-2013-4076</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4077">CVE-2013-4077</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4078">CVE-2013-4078</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4079">CVE-2013-4079</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4080">CVE-2013-4080</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4081">CVE-2013-4081</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4082">CVE-2013-4082</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4083">CVE-2013-4083</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4920">CVE-2013-4920</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4921">CVE-2013-4921</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4922">CVE-2013-4922</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4923">CVE-2013-4923</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4924">CVE-2013-4924</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4925">CVE-2013-4925</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4926">CVE-2013-4926</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4927">CVE-2013-4927</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4928">CVE-2013-4928</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4929">CVE-2013-4929</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4930">CVE-2013-4930</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4931">CVE-2013-4931</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4932">CVE-2013-4932</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4933">CVE-2013-4933</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4934">CVE-2013-4934</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4935">CVE-2013-4935</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4936">CVE-2013-4936</uri>
  </references>
  <metadata tag="requester" timestamp="2012-05-10T22:02:05Z">
    underling
  </metadata>
  <metadata tag="submitter" timestamp="2013-08-30T07:20:47Z">ackle</metadata>
</glsa>