summaryrefslogtreecommitdiff
blob: 4ef2503ae19bb7934163fe12655d6c273d59635a (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201312-13">
  <title>Wireshark: Multiple vulnerabilities</title>
  <synopsis>Multiple vulnerabilities have been found in Wireshark, allowing
    remote attackers to execute arbitrary code or cause Denial of Service.
  </synopsis>
  <product type="ebuild">wireshark</product>
  <announced>2013-12-16</announced>
  <revised>2013-12-16: 1</revised>
  <bug>484582</bug>
  <bug>490434</bug>
  <access>remote</access>
  <affected>
    <package name="net-analyzer/wireshark" auto="yes" arch="*">
      <unaffected range="ge">1.10.3</unaffected>
      <unaffected range="rge">1.8.11</unaffected>
      <vulnerable range="lt">1.10.3</vulnerable>
    </package>
  </affected>
  <background>
    <p>Wireshark is a versatile network protocol analyzer.</p>
  </background>
  <description>
    <p>Multiple vulnerabilities have been discovered in Wireshark. Please
      review the CVE identifiers referenced below for details.
    </p>
  </description>
  <impact type="normal">
    <p>A remote attacker could possibly execute arbitrary code with the
      privileges of the process or cause a Denial of Service condition.
    </p>
  </impact>
  <workaround>
    <p>There is no known workaround at this time.</p>
  </workaround>
  <resolution>
    <p>All Wireshark 1.10 users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=net-analyzer/wireshark-1.10.3"
    </code>
    
    <p>All Wireshark 1.8 users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=net-analyzer/wireshark-1.8.11"
    </code>
  </resolution>
  <references>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-5717">CVE-2013-5717</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-5718">CVE-2013-5718</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-5719">CVE-2013-5719</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-5720">CVE-2013-5720</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-5721">CVE-2013-5721</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-5722">CVE-2013-5722</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-6336">CVE-2013-6336</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-6337">CVE-2013-6337</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-6338">CVE-2013-6338</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-6339">CVE-2013-6339</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-6340">CVE-2013-6340</uri>
  </references>
  <metadata tag="requester" timestamp="2013-09-30T23:34:56Z">ackle</metadata>
  <metadata tag="submitter" timestamp="2013-12-16T18:13:16Z">ackle</metadata>
</glsa>