summaryrefslogtreecommitdiff
blob: 41eccabc631e1744b48c1232a24beab12bc675cd (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201406-05">
  <title>Mutt: Arbitrary code execution</title>
  <synopsis>A vulnerability in Mutt could allow remote attackers to execute
    arbitrary code or cause a Denial of Service condition.
  </synopsis>
  <product type="ebuild">mutt</product>
  <announced>2014-06-05</announced>
  <revised>2014-06-05: 1</revised>
  <bug>504462</bug>
  <access>remote</access>
  <affected>
    <package name="mail-client/mutt" auto="yes" arch="*">
      <unaffected range="ge">1.5.22-r3</unaffected>
      <vulnerable range="lt">1.5.22-r3</vulnerable>
    </package>
  </affected>
  <background>
    <p>Mutt is a small but powerful text-based mail client. </p>
  </background>
  <description>
    <p>A heap-based buffer overflow has been discovered in the mutt_copy_hdr
      function.
    </p>
  </description>
  <impact type="high">
    <p>A remote attacker could send a specially crafted message, possibly
      resulting in execution of arbitrary code with the privileges of the user
      running Mutt or a Denial of Service condition.
    </p>
  </impact>
  <workaround>
    <p>There is no known workaround at this time.</p>
  </workaround>
  <resolution>
    <p>All Mutt users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=mail-client/mutt-1.5.22-r3"
    </code>
    
  </resolution>
  <references>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0467">CVE-2014-0467</uri>
  </references>
  <metadata tag="requester" timestamp="2014-05-20T03:40:42Z">
    BlueKnight
  </metadata>
  <metadata tag="submitter" timestamp="2014-06-05T00:18:36Z">
    creffett
  </metadata>
</glsa>