summaryrefslogtreecommitdiff
blob: 6647cb576ca5823d01235be247f96f22eb81d888 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201406-33">
  <title>Wireshark: Multiple vulnerabilities </title>
  <synopsis>Multiple vulnerabilities have been found in Wireshark, the worst of
    which allows remote attackers to execute arbitrary code.
  </synopsis>
  <product type="ebuild">wireshark</product>
  <announced>2014-06-29</announced>
  <revised>2014-06-29: 1</revised>
  <bug>503792</bug>
  <bug>507298</bug>
  <bug>508506</bug>
  <bug>513094</bug>
  <access>remote</access>
  <affected>
    <package name="net-analyzer/wireshark" auto="yes" arch="*">
      <unaffected range="rge">1.8.15</unaffected>
      <unaffected range="ge">1.10.8</unaffected>
      <vulnerable range="lt">1.10.8</vulnerable>
    </package>
  </affected>
  <background>
    <p>Wireshark is a network protocol analyzer formerly known as ethereal.</p>
  </background>
  <description>
    <p>Multiple vulnerabilities have been discovered in Wireshark. Please
      review the CVE identifiers referenced below for details.
    </p>
  </description>
  <impact type="normal">
    <p>A remote attacker can cause arbitrary code execution or a Denial of
      Service condition via a specially crafted packet.
    </p>
  </impact>
  <workaround>
    <p>There is no known workaround at this time.</p>
  </workaround>
  <resolution>
    <p>All Wireshark 1.8.x users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=net-analyzer/wireshark-1.8.15"
    </code>
    
    <p>All Wireshark 1.10.x users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=net-analyzer/wireshark-1.10.8"
    </code>
    
  </resolution>
  <references>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2281">CVE-2014-2281</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2282">CVE-2014-2282</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2283">CVE-2014-2283</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2299">CVE-2014-2299</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2907">CVE-2014-2907</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-4020">CVE-2014-4020</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-4174">CVE-2014-4174</uri>
  </references>
  <metadata tag="requester" timestamp="2014-03-24T22:48:06Z">
    BlueKnight
  </metadata>
  <metadata tag="submitter" timestamp="2014-06-29T15:53:26Z">
    BlueKnight
  </metadata>
</glsa>