summaryrefslogtreecommitdiff
blob: 680ff6ca7187ecda13fbd60faa92640fa610970a (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201509-06">
  <title>Git: Arbitrary command execution </title>
  <synopsis>An attacker could execute arbitrary commands via Git repositories
    in a case-insensitive or case-normalizing filesystem.
  </synopsis>
  <product type="ebuild">git</product>
  <announced>2015-09-24</announced>
  <revised>2015-09-24: 1</revised>
  <bug>532984</bug>
  <access>remote</access>
  <affected>
    <package name="dev-vcs/git" auto="yes" arch="*">
      <unaffected range="rge">1.8.5.6</unaffected>
      <unaffected range="rge">1.9.5</unaffected>
      <unaffected range="ge">2.0.5</unaffected>
      <vulnerable range="lt">2.0.5</vulnerable>
    </package>
  </affected>
  <background>
    <p>Git is a free and open source distributed version control system
      designed to handle everything from small to very large projects with
      speed and efficiency.
    </p>
  </background>
  <description>
    <p>A vulnerability in Git causing Git-compatible clients that access
      case-insensitive or case-normalizing filesystems to overwrite the
      .git/config when cloning or checking out a repository, leading to
      execution of arbitrary commands.
    </p>
  </description>
  <impact type="normal">
    <p>An attacker can execute arbitrary commands on a client machine that
      clones a crafted malicious Git tree.
    </p>
  </impact>
  <workaround>
    <p>There is no known workaround at this time.</p>
  </workaround>
  <resolution>
    <p>All Git 1.8.x users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=dev-vcs/git-1.8.5.6"
    </code>
    
    <p>All Git 1.9.x users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=dev-vcs/git-1.9.5"
    </code>
    
    <p>All Git 2.0.x users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=dev-vcs/git-2.0.5"
    </code>
    
  </resolution>
  <references>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9390">CVE-2014-9390</uri>
  </references>
  <metadata tag="requester" timestamp="2014-12-29T01:59:41Z">
    BlueKnight
  </metadata>
  <metadata tag="submitter" timestamp="2015-09-24T17:01:53Z">mrueg</metadata>
</glsa>