summaryrefslogtreecommitdiff
blob: 0c61a70b85ba78b6d63a04f97cb7c25a556f0a1b (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201604-04">
  <title>libksba: Multiple vulnerabilities</title>
  <synopsis>Multiple vulnerabilities have been found in libksba, allowing a
    possible Denial of Service and unspecified other vectors through integer
    overflows.
  </synopsis>
  <product type="ebuild">libksba</product>
  <announced>April 26, 2016</announced>
  <revised>April 26, 2016: 1</revised>
  <bug>546464</bug>
  <access>remote</access>
  <affected>
    <package name="dev-libs/libksba" auto="yes" arch="*">
      <unaffected range="ge">1.3.3</unaffected>
      <vulnerable range="lt">1.3.3</vulnerable>
    </package>
  </affected>
  <background>
    <p>Libksba is a X.509 and CMS (PKCS#7) library.</p>
  </background>
  <description>
    <p>libksba is vulnerable to two integer overflows and a Denial of Service
      vulnerability.  Please read the references for additional details.
    </p>
  </description>
  <impact type="normal">
    <p>Remote attackers could cause Denial of Service or unspecified other
      vectors through various integer overflows.
    </p>
  </impact>
  <workaround>
    <p>There is no known workaround at this time.</p>
  </workaround>
  <resolution>
    <p>All libksba users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=dev-libs/libksba-1.3.3"
    </code>
    
  </resolution>
  <references>
    <uri link="http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libksba.git;a=commit;h=07116a314f4dcd4d96990bbd74db95a03a9f650a">
      Denial of Service due to stack overflow in src/ber-decoder.c
    </uri>
    <uri link="http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libksba.git;a=commit;h=aea7b6032865740478ca4b706850a5217f1c3887">
      Integer overflow in the BER decoder src/ber-decoder.c
    </uri>
    <uri link="http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libksba.git;a=commit;h=243d12fdec66a4360fbb3e307a046b39b5b4ffc3">
      Integer overflow in the DN decoder src/dn.c
    </uri>
  </references>
  <metadata tag="requester" timestamp="Mon, 06 Jul 2015 04:35:16 +0000">
    BlueKnight
  </metadata>
  <metadata tag="submitter" timestamp="Tue, 26 Apr 2016 21:22:11 +0000">b-man</metadata>
</glsa>