summaryrefslogtreecommitdiff
blob: 635491a7b34d6ec5848bc0377832374b356f290e (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201607-08">
  <title>Dropbear: Privilege escalation</title>
  <synopsis>A vulnerability has been found in Dropbear, which allows remote
    authenticated users to bypass intended shell-command restrictions.
  </synopsis>
  <product type="ebuild"/>
  <announced>2016-07-20</announced>
  <revised>2016-07-20: 1</revised>
  <bug>577050</bug>
  <access>remote</access>
  <affected>
    <package name="net-misc/dropbear" auto="yes" arch="*">
      <unaffected range="ge">2016.73</unaffected>
      <vulnerable range="lt">2016.73</vulnerable>
    </package>
  </affected>
  <background>
    <p>Dropbear is a relatively small SSH server and client.</p>
  </background>
  <description>
    <p>A CRLF injection vulnerability in Dropbear SSH allows remote
      authenticated users to bypass intended shell-command restrictions via
      crafted X11 forwarding data.
    </p>
  </description>
  <impact type="normal">
    <p>A remote authenticated user could execute arbitrary code with the
      privileges of the process.
    </p>
  </impact>
  <workaround>
    <p>There is no known workaround at this time.</p>
  </workaround>
  <resolution>
    <p>All Dropbear users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=net-misc/dropbear-2016.73"
    </code>
  </resolution>
  <references>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-3116">CVE-2016-3116</uri>
  </references>
  <metadata tag="requester" timestamp="2016-06-21T05:13:38Z">b-man</metadata>
  <metadata tag="submitter" timestamp="2016-07-20T08:45:10Z">b-man</metadata>
</glsa>