summaryrefslogtreecommitdiff
blob: 316bef1e78d2014d429d8b34f6811fabc2a39f4e (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201611-07">
  <title>polkit: Heap-corruption on duplicate IDs </title>
  <synopsis>polkit is vulnerable to local privilege escalation.</synopsis>
  <product type="ebuild">polkit</product>
  <announced>2016-11-15</announced>
  <revised>2016-11-15: 1</revised>
  <bug>555666</bug>
  <access>local</access>
  <affected>
    <package name="sys-auth/polkit" auto="yes" arch="*">
      <unaffected range="ge">0.113</unaffected>
      <vulnerable range="lt">0.113</vulnerable>
    </package>
  </affected>
  <background>
    <p>polkit is a toolkit for managing policies relating to unprivileged
      processes communicating with privileged processes.
    </p>
  </background>
  <description>
    <p>A vulnerability was discovered in polkit’s
      polkit_backend_action_pool_init function due to duplicate action IDs in
      action descriptions.
    </p>
  </description>
  <impact type="normal">
    <p>Local attackers are able to gain unauthorized privileges on the system.</p>
  </impact>
  <workaround>
    <p>There is no known workaround at this time.</p>
  </workaround>
  <resolution>
    <p>All polkit users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=sys-auth/polkit-0.113"
    </code>
  </resolution>
  <references>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-3255">CVE-2015-3255</uri>
  </references>
  <metadata tag="requester" timestamp="2015-12-25T00:47:50Z">
    BlueKnight
  </metadata>
  <metadata tag="submitter" timestamp="2016-11-15T07:23:23Z">b-man</metadata>
</glsa>