summaryrefslogtreecommitdiff
blob: 5755d0b22759ac06afb1d1dcf9029346ecdee1ee (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201612-26">
  <title>OpenJPEG: Multiple vulnerabilities</title>
  <synopsis>Multiple vulnerabilities have been found in OpenJPEG, the worst of
    which may allow execution of arbitrary code.
  </synopsis>
  <product type="ebuild">openjpeg</product>
  <announced>2016-12-08</announced>
  <revised>2016-12-08: 1</revised>
  <bug>560632</bug>
  <bug>572430</bug>
  <bug>577608</bug>
  <bug>594740</bug>
  <access>remote</access>
  <affected>
    <package name="media-libs/openjpeg" auto="yes" arch="*">
      <unaffected range="ge">2.1.1_p20160922</unaffected>
      <unaffected range="rge">1.5.2</unaffected>
      <vulnerable range="lt">2.1.1_p20160922</vulnerable>
    </package>
  </affected>
  <background>
    <p>OpenJPEG is an open-source JPEG 2000 library.</p>
  </background>
  <description>
    <p>Multiple vulnerabilities have been discovered in OpenJPEG. Please review
      the CVE identifiers referenced below for details.
    </p>
  </description>
  <impact type="normal">
    <p>A remote attacker could entice a user to open a specially crafted JPEG
      file, possibly resulting in execution of arbitrary code or a Denial of
      Service condition. Furthermore, a remote attacker may be able to obtain
      sensitive information.
    </p>
  </impact>
  <workaround>
    <p>There is no known workaround at this time.</p>
  </workaround>
  <resolution>
    <p>All OpenJPEG 2 users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose
      "&gt;=media-libs/openjpeg-2.1.1_p20160922:2"
    </code>
  </resolution>
  <references>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-8871">CVE-2015-8871</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-1923">CVE-2016-1923</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-1924">CVE-2016-1924</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-3181">CVE-2016-3181</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-3182">CVE-2016-3182</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-3183">CVE-2016-3183</uri>
    <uri link="https://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-7445">CVE-2016-7445</uri>
  </references>
  <metadata tag="requester" timestamp="2016-12-07T23:52:17Z">whissi</metadata>
  <metadata tag="submitter" timestamp="2016-12-08T13:55:57Z">whissi</metadata>
</glsa>