summaryrefslogtreecommitdiff
blob: bb1b9944d5b638e70cfdf133e232d4d84906dfd1 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201612-37">
  <title>Pixman: Buffer overflow</title>
  <synopsis>A buffer overflow in Pixman might allow remote attackers to execute
    arbitrary code.
  </synopsis>
  <product type="ebuild">pixman</product>
  <announced>December 13, 2016</announced>
  <revised>December 13, 2016: 2</revised>
  <bug>561526</bug>
  <access>remote</access>
  <affected>
    <package name="x11-libs/pixman" auto="yes" arch="*">
      <unaffected range="ge">0.32.8</unaffected>
      <vulnerable range="lt">0.32.8</vulnerable>
    </package>
  </affected>
  <background>
    <p>Pixman is a pixel manipulation library.</p>
  </background>
  <description>
    <p>In pixman-general, careless computations done with the ‘dest_buffer’
      pointer may overflow, failing the buffer upper limit check.
    </p>
  </description>
  <impact type="normal">
    <p>A remote attacker could possibly cause a Denial of Service condition, or
      execute arbitrary code with the privileges of the process.
    </p>
  </impact>
  <workaround>
    <p>There is no known workaround at this time.</p>
  </workaround>
  <resolution>
    <p>All Pixman users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=x11-libs/pixman-0.32.8"
    </code>
  </resolution>
  <references>
    <uri link="http://lists.x.org/archives/xorg-announce/2015-September/002637.html">
      Pixman 0.32.8 Release Notes
    </uri>
  </references>
  <metadata tag="requester" timestamp="Thu, 25 Feb 2016 08:11:30 +0000">
    BlueKnight
  </metadata>
  <metadata tag="submitter" timestamp="Tue, 13 Dec 2016 06:59:37 +0000">whissi</metadata>
</glsa>