summaryrefslogtreecommitdiff
blob: 604624ab6f4d6f474109ac4ade6306cf6bb9145b (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201701-27">
  <title>7-Zip: Multiple vulnerabilities</title>
  <synopsis>Multiple vulnerabilities have been found in 7-Zip, the worst of
    which may allow execution of arbitrary code. 
  </synopsis>
  <product type="ebuild">7zip</product>
  <announced>January 11, 2017</announced>
  <revised>January 11, 2017: 1</revised>
  <bug>582832</bug>
  <access>remote</access>
  <affected>
    <package name="app-arch/p7zip" auto="yes" arch="*">
      <unaffected range="ge">16.02-r1</unaffected>
      <vulnerable range="lt">16.02-r1</vulnerable>
    </package>
  </affected>
  <background>
    <p>7-Zip is an open-source file archiver, an application used primarily to
      compress files. 7-Zip uses its own 7z archive format, but can read and
      write several other archive formats.
    </p>
  </background>
  <description>
    <p>Multiple vulnerabilities have been discovered in 7-Zip. Please review
      the CVE identifiers referenced below for details.
    </p>
  </description>
  <impact type="normal">
    <p>A remote attacker could entice a user to open a specially crafted
      archive file possibly resulting in execution of arbitrary code with the
      privileges of the process or a Denial of Service condition.
    </p>
  </impact>
  <workaround>
    <p>There is no known workaround at this time.</p>
  </workaround>
  <resolution>
    <p>All 7-Zip users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=app-arch/p7zip-16.02-r1"
    </code>
  </resolution>
  <references>
    <uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-2334">CVE-2016-2334</uri>
    <uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-2335">CVE-2016-2335</uri>
  </references>
  <metadata tag="requester" timestamp="Mon, 09 Jan 2017 17:11:43 +0000">whissi</metadata>
  <metadata tag="submitter" timestamp="Wed, 11 Jan 2017 12:28:26 +0000">whissi</metadata>
</glsa>