summaryrefslogtreecommitdiff
blob: 6a1c4c21cc2147fa7d2b70f9d4deec848c78f3e5 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201701-54">
  <title>DCRaw: Buffer overflow</title>
  <synopsis>A buffer overflow in DCRaw might allow remote attackers to cause a
    Denial of Service condition.
  </synopsis>
  <product type="ebuild">dcraw</product>
  <announced>2017-01-23</announced>
  <revised>2017-01-23: 1</revised>
  <bug>549336</bug>
  <access>remote</access>
  <affected>
    <package name="media-gfx/dcraw" auto="yes" arch="*">
      <unaffected range="ge">9.26.0</unaffected>
      <vulnerable range="lt">9.26.0</vulnerable>
    </package>
  </affected>
  <background>
    <p>Command-line decoder for raw digital photos.</p>
  </background>
  <description>
    <p>An integer overflow was discovered in the ljpeg_start function in DCRaw.</p>
  </description>
  <impact type="normal">
    <p>Remote attackers, by enticing a user to open a specially crafted image,
      could cause a Denial of Service condition.
    </p>
  </impact>
  <workaround>
    <p>There is no known workaround at this time.</p>
  </workaround>
  <resolution>
    <p>All DCRaw users should upgrade to the latest version:</p>
    
    <code>
      # emerge --sync
      # emerge --ask --oneshot --verbose "&gt;=media-gfx/dcraw-9.26.0"
    </code>
  </resolution>
  <references>
    <uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-3885">CVE-2015-3885</uri>
  </references>
  <metadata tag="requester" timestamp="2017-01-18T08:16:14Z">b-man</metadata>
  <metadata tag="submitter" timestamp="2017-01-23T03:34:47Z">b-man</metadata>
</glsa>