summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2017-10-09 16:36:13 +0200
committerAgostino Sarubbo <ago@gentoo.org>2017-10-09 16:36:13 +0200
commitf73cb1d63f074a40de0e86ed385717c548081ca6 (patch)
tree7b4dbb81bf7fcc0e545367651198b691dfd1962c /sys-kernel/grsecurity-sources/grsecurity-sources-4.9.54.ebuild
parentsys-kernel/grsecurity-sources: Automated version bump to 4.9.53 (diff)
downloadago-f73cb1d63f074a40de0e86ed385717c548081ca6.tar.gz
ago-f73cb1d63f074a40de0e86ed385717c548081ca6.tar.bz2
ago-f73cb1d63f074a40de0e86ed385717c548081ca6.zip
sys-kernel/grsecurity-sources: Automated version bump to 4.9.54
Package-Manager: Portage-2.3.8, Repoman-2.3.3 Manifest-Sign-Key: 7194459F Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'sys-kernel/grsecurity-sources/grsecurity-sources-4.9.54.ebuild')
-rw-r--r--sys-kernel/grsecurity-sources/grsecurity-sources-4.9.54.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-kernel/grsecurity-sources/grsecurity-sources-4.9.54.ebuild b/sys-kernel/grsecurity-sources/grsecurity-sources-4.9.54.ebuild
new file mode 100644
index 0000000..aa63e28
--- /dev/null
+++ b/sys-kernel/grsecurity-sources/grsecurity-sources-4.9.54.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# See https://blogs.gentoo.org/ago/2017/08/21/sys-kernel-grsecurity-sources-available
+
+EAPI="6"
+
+ETYPE="sources"
+K_GENPATCHES_VER="not-empty" # Set to not-empty to avoid the useless download of patch-*.xz
+
+inherit kernel-2
+detect_version
+detect_arch
+
+GRSECURITY_URI="https://dev.gentoo.org/~ago/distfiles/${PN}/${PN}-extras-${PV}.tar.xz"
+SRC_URI="${KERNEL_URI} ${GRSECURITY_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/${PN}-extras-${PV}.tar.xz"
+
+DESCRIPTION="Unofficial port of the last public grsecurity patch plus Gentoo patchset"
+HOMEPAGE="https://github.com/minipli/linux-unofficial_grsec"
+IUSE="deblob"
+KEYWORDS="-* ~amd64"
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-3.1*"
+
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}