summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-03-21 17:17:14 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2012-03-21 17:17:14 +0400
commit555dceadd35a808d28d4630aab83afb9c4e62b0c (patch)
tree45eb11b80e13c76fa67dadb94154c7496b444809
parentFix deps for lio (diff)
parentDrop old stuff (diff)
downloadalexxy-555dcead.tar.gz
alexxy-555dcead.tar.bz2
alexxy-555dcead.zip
Merge branch 'master' of git.overlays.gentoo.org:dev/alexxy
-rw-r--r--dev-libs/clover/clover-9999.ebuild34
-rw-r--r--dev-python/rtslib/rtslib-9999.ebuild7
-rw-r--r--metadata/layout.conf1
-rw-r--r--net-libs/libtorrent/libtorrent-9999.ebuild50
-rw-r--r--net-p2p/rtorrent/files/rtorrentd.conf1
-rw-r--r--net-p2p/rtorrent/files/rtorrentd.init34
-rw-r--r--net-p2p/rtorrent/metadata.xml15
-rw-r--r--net-p2p/rtorrent/rtorrent-9999.ebuild61
-rw-r--r--sys-block/targetcli/metadata.xml (renamed from net-libs/libtorrent/metadata.xml)7
-rw-r--r--sys-block/targetcli/targetcli-9999.ebuild29
10 files changed, 43 insertions, 196 deletions
diff --git a/dev-libs/clover/clover-9999.ebuild b/dev-libs/clover/clover-9999.ebuild
deleted file mode 100644
index 0825b1e..0000000
--- a/dev-libs/clover/clover-9999.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit git-2 cmake-utils
-
-DESCRIPTION="Mesa OpenCL implementation (software and Gallium-based)"
-HOMEPAGE="http://cgit.freedesktop.org/~steckdenis/clover/"
-EGIT_REPO_URI="git://anongit.freedesktop.org/~steckdenis/clover"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="
- media-libs/mesa[llvm,gallium]
- sys-devel/clang
- sys-devel/llvm
-"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- default
- [[ $PV = 9999* ]] && git-2_src_unpack
-}
-
-src_install() {
- cmake-utils_src_install
- insinto /usr/include
- doins -r "${S}/include/CL"
-}
diff --git a/dev-python/rtslib/rtslib-9999.ebuild b/dev-python/rtslib/rtslib-9999.ebuild
index bd9f824..b4d7949 100644
--- a/dev-python/rtslib/rtslib-9999.ebuild
+++ b/dev-python/rtslib/rtslib-9999.ebuild
@@ -26,3 +26,10 @@ DEPEND="
dev-python/netifaces
"
RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils_src_install
+ keepdir /var/target/fabric
+ insinto /var/target/fabric
+ doins specs/*.spec
+}
diff --git a/metadata/layout.conf b/metadata/layout.conf
index ce368fa..2f3c3d3 100644
--- a/metadata/layout.conf
+++ b/metadata/layout.conf
@@ -1,3 +1,4 @@
sign-manifests = false
+sign-commits = true
thin-manifests = true
manifest-hashes = SHA256 SHA512 WHIRLPOOL
diff --git a/net-libs/libtorrent/libtorrent-9999.ebuild b/net-libs/libtorrent/libtorrent-9999.ebuild
deleted file mode 100644
index 0ce13f4..0000000
--- a/net-libs/libtorrent/libtorrent-9999.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.7.ebuild,v 1.3 2011/04/13 21:30:46 sochotnicky Exp $
-
-EAPI=4
-inherit autotools eutils subversion toolchain-funcs
-
-DESCRIPTION="BitTorrent library written in C++ for *nix"
-HOMEPAGE="http://libtorrent.rakshasa.no/"
-ESVN_REPO_URI="svn://rakshasa.no/libtorrent/trunk/libtorrent"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="debug ipv6 ssl"
-
-RDEPEND=">=dev-libs/libsigc++-2.2.2:2
- ssl? ( dev-libs/openssl )"
-DEPEND="${RDEPEND}
- dev-util/cppunit
- dev-util/pkgconfig"
-
-src_prepare() {
- eautoreconf
-}
-
-src_configure() {
- # the configure check for posix_fallocate is wrong.
- # reported upstream as Ticket 2416.
- local myconf
- echo "int main(){return posix_fallocate();}" > "${T}"/posix_fallocate.c
- if $(tc-getCC) ${CFLAGS} ${LDFLAGS} "${T}"/posix_fallocate.c -o /dev/null 2>/dev/null ; then
- myconf="--with-posix-fallocate"
- else
- myconf="--without-posix-fallocate"
- fi
-
- econf \
- --disable-dependency-tracking \
- --enable-aligned \
- $(use_enable debug) \
- $(use_enable ipv6) \
- $(use_enable ssl openssl) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS NEWS README
-}
diff --git a/net-p2p/rtorrent/files/rtorrentd.conf b/net-p2p/rtorrent/files/rtorrentd.conf
deleted file mode 100644
index 5ff2328..0000000
--- a/net-p2p/rtorrent/files/rtorrentd.conf
+++ /dev/null
@@ -1 +0,0 @@
-USER="$USER"
diff --git a/net-p2p/rtorrent/files/rtorrentd.init b/net-p2p/rtorrent/files/rtorrentd.init
deleted file mode 100644
index e160b99..0000000
--- a/net-p2p/rtorrent/files/rtorrentd.init
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/files/rtorrentd.init,v 1.7 2011/05/09 21:34:21 sochotnicky Exp $
-
-depend() {
- use net ypbind nis
- after slapd mysqld postgresql
-}
-
-start() {
- PWHOME="$(getent passwd $USER | awk -F: '{ print $6 }')"
-
- ebegin "Starting rtorrent"
- env TERM="xterm" \
- start-stop-daemon \
- --start \
- --make-pidfile \
- --pidfile /var/run/rtorrentd.pid \
- --background \
- --user $USER \
- --chuid $USER \
- --env HOME="${PWHOME:-/home/$USER}" \
- --name rtorrent \
- --exec /usr/bin/screen -- -D -m -S rtorrentd /usr/bin/rtorrent
- eend $?
-}
-
-stop() {
- ebegin "Stopping rtorrent"
- start-stop-daemon --stop --signal 15 \
- --pidfile /var/run/rtorrentd.pid
- eend $?
-}
diff --git a/net-p2p/rtorrent/metadata.xml b/net-p2p/rtorrent/metadata.xml
deleted file mode 100644
index dd9423d..0000000
--- a/net-p2p/rtorrent/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>net-p2p</herd>
-<longdescription lang="en">
- Console BitTorrent client using ncurses based on libtorrent written in C++.
-</longdescription>
-<use>
- <flag name='daemon'>Uses <pkg>app-misc/screen</pkg> to daemonize this
- application
- </flag>
- <flag name='color'>Add custom color support for torrent list</flag>
-</use>
-
-</pkgmetadata>
diff --git a/net-p2p/rtorrent/rtorrent-9999.ebuild b/net-p2p/rtorrent/rtorrent-9999.ebuild
deleted file mode 100644
index 2d07376..0000000
--- a/net-p2p/rtorrent/rtorrent-9999.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.7-r3.ebuild,v 1.1 2011/05/09 21:34:21 sochotnicky Exp $
-
-EAPI=4
-
-inherit autotools eutils subversion
-
-DESCRIPTION="BitTorrent Client using libtorrent"
-HOMEPAGE="http://libtorrent.rakshasa.no/"
-ESVN_REPO_URI="svn://rakshasa.no/libtorrent/trunk/rtorrent"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="color daemon debug ipv6 test xmlrpc"
-
-COMMON_DEPEND=">=net-libs/libtorrent-0.12.${PV##*.}
- >=dev-libs/libsigc++-2.2.2:2
- >=net-misc/curl-7.19.1
- sys-libs/ncurses
- xmlrpc? ( dev-libs/xmlrpc-c )"
-RDEPEND="${COMMON_DEPEND}
- daemon? ( app-misc/screen )"
-DEPEND="${COMMON_DEPEND}
- test? ( dev-util/cppunit )
- dev-util/pkgconfig"
-
-src_prepare() {
- use color && EPATCH_OPTS="-p1" epatch "${FILESDIR}"/${P}-canvas-fix.patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-dependency-tracking \
- $(use_enable debug) \
- $(use_enable ipv6) \
- $(use_with xmlrpc xmlrpc-c)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS README TODO doc/rtorrent.rc
-
- if use daemon; then
- newinitd "${FILESDIR}/rtorrentd.init" rtorrentd || die "newinitd failed"
- newconfd "${FILESDIR}/rtorrentd.conf" rtorrentd || die "newconfd failed"
- fi
-}
-
-pkg_postinst() {
- if use color; then
- elog "rtorrent colors patch"
- elog "Set colors using the options below in .rtorrent.rc:"
- elog "Options: done_fg_color, done_bg_color, active_fg_color, active_bg_color"
- elog "Colors: 0 = black, 1 = red, 2 = green, 3 = yellow, 4 = blue,"
- elog "5 = magenta, 6 = cyan and 7 = white"
- elog "Example: done_fg_color = 1"
- fi
-}
diff --git a/net-libs/libtorrent/metadata.xml b/sys-block/targetcli/metadata.xml
index aa0f366..59fc80b 100644
--- a/net-libs/libtorrent/metadata.xml
+++ b/sys-block/targetcli/metadata.xml
@@ -1,5 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>net-p2p</herd>
+ <herd>python</herd>
+ <herd>cluster</herd>
+ <maintainer>
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
</pkgmetadata>
diff --git a/sys-block/targetcli/targetcli-9999.ebuild b/sys-block/targetcli/targetcli-9999.ebuild
new file mode 100644
index 0000000..0eadfc8
--- /dev/null
+++ b/sys-block/targetcli/targetcli-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+EGIT_REPO_URI="git://linux-iscsi.org/${PN}.git"
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils distutils git-2 python linux-info
+
+DESCRIPTION="The targetcli administration shell"
+HOMEPAGE="http://linux-iscsi.org/"
+SRC_URI=""
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ dev-python/configshell
+ dev-python/rtslib
+ "
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~TARGET_CORE"