summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-07-22 02:59:09 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2013-07-22 02:59:09 +0400
commitb7c009f3b45f571e4aac6b303ca66e7d9708fe72 (patch)
treeb938e79f2aa92754fc839d7a999b783bc55f4c90 /dev-tex
parentAdd bot constructor (diff)
downloadalexxy-b7c009f3b45f571e4aac6b303ca66e7d9708fe72.tar.gz
alexxy-b7c009f3b45f571e4aac6b303ca66e7d9708fe72.tar.bz2
alexxy-b7c009f3b45f571e4aac6b303ca66e7d9708fe72.zip
Add bibber and its deps
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/biblatex-biber/Manifest1
-rw-r--r--dev-tex/biblatex-biber/biblatex-biber-1.7.ebuild57
-rw-r--r--dev-tex/biblatex-biber/files/biber-1.6-remove-mozilla-ca.patch175
-rw-r--r--dev-tex/biblatex-biber/metadata.xml8
4 files changed, 241 insertions, 0 deletions
diff --git a/dev-tex/biblatex-biber/Manifest b/dev-tex/biblatex-biber/Manifest
new file mode 100644
index 0000000..2d16135
--- /dev/null
+++ b/dev-tex/biblatex-biber/Manifest
@@ -0,0 +1 @@
+DIST biblatex-biber-1.7.tar.gz 2063730 SHA256 baefc64442b6b0f4810712a3d48346b9f08ab6a39af828fca5df97a0430fec1c SHA512 caa77968b2912ea25727ae48f818aa74e289e4f2ff481f85c25e1e4660549ef36c4a2af40bbbbc623dd145038c4e9b07dc2a735384d1ffe54c06cc32199bb7c2 WHIRLPOOL f50439e38dddfd7e3a395640553e7e50fe764b209a15c6ad182c1b39246bad916e41cd51171feee48eede33e4b376ea298a98a644da7c9c38db7113f6ecb9a4f
diff --git a/dev-tex/biblatex-biber/biblatex-biber-1.7.ebuild b/dev-tex/biblatex-biber/biblatex-biber-1.7.ebuild
new file mode 100644
index 0000000..ec670da
--- /dev/null
+++ b/dev-tex/biblatex-biber/biblatex-biber-1.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit eutils perl-app
+
+DESCRIPTION="Biber is a BibTeX replacement for users of biblatex"
+HOMEPAGE="http://biblatex-biber.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${PN}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Artistic-2 GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RESTRICT="mirror"
+
+RDEPEND=">=dev-lang/perl-5.16
+ dev-perl/Business-ISBN
+ dev-perl/Business-ISSN
+ dev-perl/Business-ISMN
+ dev-perl/Data-Compare
+ dev-perl/Data-Diver
+ dev-perl/Data-Dump
+ dev-perl/Date-Simple
+ dev-perl/File-Slurp-Unicode
+ dev-perl/IPC-Run3
+ dev-perl/libwww-perl[ssl]
+ dev-perl/List-AllUtils
+ dev-perl/Log-Log4perl
+ dev-perl/regexp-common
+ dev-perl/Readonly
+ dev-perl/Readonly-XS
+ >=dev-perl/Text-BibTeX-0.66
+ dev-perl/Unicode-LineBreak
+ dev-perl/URI
+ dev-perl/XML-LibXML-Simple
+ dev-perl/XML-LibXSLT
+ =dev-tex/biblatex-2.6
+ virtual/perl-IPC-Cmd"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/File-Which )
+ virtual/perl-Module-Build"
+
+# Encode::EUCJPASCII - not used
+# Encode::HanExtra - not used
+# Encode::JIS2K - not used
+# Unicode::Collate - part of perl itself, lower version number seems to be ok
+# List::MoreUtils - not used
+# ExtUtils::LibBuilder - not used
+# Config::AutoConf - not used
+
+SRC_TEST="parallel"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6-remove-mozilla-ca.patch )
diff --git a/dev-tex/biblatex-biber/files/biber-1.6-remove-mozilla-ca.patch b/dev-tex/biblatex-biber/files/biber-1.6-remove-mozilla-ca.patch
new file mode 100644
index 0000000..9fd2a9e
--- /dev/null
+++ b/dev-tex/biblatex-biber/files/biber-1.6-remove-mozilla-ca.patch
@@ -0,0 +1,175 @@
+--- bin/biber.orig 2013-05-03 05:59:40.000000000 +0000
++++ bin/biber 2013-05-03 05:59:56.549653262 +0000
+@@ -65,7 +65,6 @@
+ 'sortfirstinits=s',
+ 'sortlocale|l=s',
+ 'sortupper=s',
+- 'ssl-nointernalca',
+ 'ssl-noverify-host',
+ 'tool',
+ 'tool_align',
+@@ -552,12 +551,6 @@
+ using B<--fastsort|-f>, your OS collation locale determines
+ this and this option is ignored (default is true).
+
+-=item B<--ssl-nointernalca>
+-
+-Don't try to use the default Mozilla CA certificates when using HTTPS to fetch remote data.
+-This assumes that the user will set one of the perl LWP::UserAgent module environment variables
+-to find the CA certs.
+-
+ =item B<--ssl-noverify-host>
+
+ Turn off host verification when using HTTPS to fetch remote data sources.
+--- data/schemata/config.rnc.orig 2013-05-03 05:59:17.000000000 +0000
++++ data/schemata/config.rnc 2013-05-03 06:02:24.454651117 +0000
+@@ -52,7 +52,6 @@
+ map+
+ }+
+ }? &
+- element ssl-nointernalca { "0" | "1" }? &
+ element ssl-noverify-host { "0" | "1" }? &
+ element tool { "0" | "1" }? &
+ element tool_align { "0" | "1" }? &
+--- data/schemata/config.rng.orig 2013-05-03 05:59:11.000000000 +0000
++++ data/schemata/config.rng 2013-05-03 06:02:38.506650914 +0000
+@@ -254,14 +254,6 @@
+ </element>
+ </optional>
+ <optional>
+- <element name="ssl-nointernalca">
+- <choice>
+- <value>0</value>
+- <value>1</value>
+- </choice>
+- </element>
+- </optional>
+- <optional>
+ <element name="ssl-noverify-host">
+ <choice>
+ <value>0</value>
+--- lib/Biber/Input/file/biblatexml.pm.orig 2013-05-03 05:48:56.000000000 +0000
++++ lib/Biber/Input/file/biblatexml.pm 2013-05-03 05:57:23.039655487 +0000
+@@ -84,16 +84,6 @@
+ $logger->info("Data source '$filename' is a remote .xml - fetching ...");
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug4); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca'))) {
+- require Mozilla::CA; # Have to explicitly require this here to get it into %INC below
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+ if (defined(Biber::Config->getoption('ssl-noverify-host'))) {
+ $ENV{PERL_LWP_SSL_VERIFY_HOSTNAME} = 0;
+ }
+--- lib/Biber/Input/file/bibtex.pm.orig 2013-05-02 10:39:19.000000000 +0000
++++ lib/Biber/Input/file/bibtex.pm 2013-05-03 05:49:52.637662018 +0000
+@@ -125,16 +125,6 @@
+ $logger->info("Data source '$source' is a remote BibTeX data source - fetching ...");
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca'))) {
+- require Mozilla::CA; # Have to explicitly require this here to get it into %INC below
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+ if (defined(Biber::Config->getoption('ssl-noverify-host'))) {
+ $ENV{PERL_LWP_SSL_VERIFY_HOSTNAME} = 0;
+ }
+--- lib/Biber/Input/file/endnotexml.pm.orig 2013-05-02 10:39:20.000000000 +0000
++++ lib/Biber/Input/file/endnotexml.pm 2013-05-03 05:50:10.607661757 +0000
+@@ -102,16 +102,6 @@
+ $logger->info("Data source '$source' is a remote EndNote XML datasource - fetching ...");
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug4); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca'))) {
+- require Mozilla::CA; # Have to explicitly require this here to get it into %INC below
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+ if (defined(Biber::Config->getoption('ssl-noverify-host'))) {
+ $ENV{PERL_LWP_SSL_VERIFY_HOSTNAME} = 0;
+ }
+--- lib/Biber/Input/file/ris.pm.orig 2013-05-02 10:39:20.000000000 +0000
++++ lib/Biber/Input/file/ris.pm 2013-05-03 05:50:29.344661485 +0000
+@@ -97,16 +97,6 @@
+ $logger->info("Data source '$source' is a remote RIS data source - fetching ...");
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug4); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca'))) {
+- require Mozilla::CA; # Have to explicitly require this here to get it into %INC below
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+ if (defined(Biber::Config->getoption('ssl-noverify-host'))) {
+ $ENV{PERL_LWP_SSL_VERIFY_HOSTNAME} = 0;
+ }
+--- lib/Biber/Input/file/zoterordfxml.pm.orig 2013-05-02 10:39:20.000000000 +0000
++++ lib/Biber/Input/file/zoterordfxml.pm 2013-05-03 05:50:42.166661300 +0000
+@@ -114,16 +114,6 @@
+ $logger->info("Data source '$source' is a remote Zotero RDF/XML data source - fetching ...");
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug4); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca'))) {
+- require Mozilla::CA; # Have to explicitly require this here to get it into %INC below
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+ if (defined(Biber::Config->getoption('ssl-noverify-host'))) {
+ $ENV{PERL_LWP_SSL_VERIFY_HOSTNAME} = 0;
+ }
+--- Build.PL.orig 2013-05-02 10:39:20.000000000 +0000
++++ Build.PL 2013-05-03 05:47:37.416663978 +0000
+@@ -65,7 +65,6 @@
+ 'Business::ISBN' => 0,
+ 'Business::ISSN' => 0,
+ 'Business::ISMN' => 0,
+- 'Mozilla::CA' => 0,
+ 'perl' => '5.16.0'
+ },
+ recommends => {
+--- META.json.orig 2013-05-02 10:39:20.000000000 +0000
++++ META.json 2013-05-03 05:51:59.858660173 +0000
+@@ -48,7 +48,6 @@
+ "List::AllUtils" : "0",
+ "List::MoreUtils" : "0",
+ "Log::Log4perl" : "0",
+- "Mozilla::CA" : "0",
+ "Regexp::Common" : "0",
+ "Text::BibTeX" : "0.66",
+ "URI" : "0",
+--- META.yml.orig 2013-05-03 06:08:19.000000000 +0000
++++ META.yml 2013-05-03 06:08:36.176645728 +0000
+@@ -83,7 +83,6 @@
+ List::AllUtils: 0
+ List::MoreUtils: 0
+ Log::Log4perl: 0
+- Mozilla::CA: 0
+ Regexp::Common: 0
+ Text::BibTeX: 0.66
+ URI: 0
diff --git a/dev-tex/biblatex-biber/metadata.xml b/dev-tex/biblatex-biber/metadata.xml
new file mode 100644
index 0000000..247f458
--- /dev/null
+++ b/dev-tex/biblatex-biber/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+</pkgmetadata>