summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-embedded/platformio/Manifest1
-rw-r--r--dev-embedded/platformio/metadata.xml8
-rw-r--r--dev-embedded/platformio/platformio-3.5.1.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-embedded/platformio/Manifest b/dev-embedded/platformio/Manifest
new file mode 100644
index 0000000..b66fb93
--- /dev/null
+++ b/dev-embedded/platformio/Manifest
@@ -0,0 +1 @@
+DIST platformio-3.5.1.tar.gz 92895 SHA256 76f427e59be50f8ea8ab1cee97b721e9fb807ea3fd4a70e3f431dc037f2d8131 SHA512 b406bd0b2172070eb4feb705cd09dbf85abeeae8e310a02a2b948a11f7c5bd960a580cee0b4597207d48f1c12d553692e1f348320949131dc5a24b451cbd9dd5 WHIRLPOOL 2530b4bf2b9c9e4d7816a910322901f79484b701e9655135cc56975aabaae39d7e4d937064d13ecf81f5a69d82ccb472a212ad7489079e2330f8860122abe117
diff --git a/dev-embedded/platformio/metadata.xml b/dev-embedded/platformio/metadata.xml
new file mode 100644
index 0000000..086586c
--- /dev/null
+++ b/dev-embedded/platformio/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-embedded/platformio/platformio-3.5.1.ebuild b/dev-embedded/platformio/platformio-3.5.1.ebuild
new file mode 100644
index 0000000..4aa6907
--- /dev/null
+++ b/dev-embedded/platformio/platformio-3.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="An open source ecosystem for IoT development"
+HOMEPAGE="http://platformio.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/semantic_version-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pyserial-3[${PYTHON_USEDEP}]
+ <dev-python/pyserial-4[${PYTHON_USEDEP}]
+ >=dev-python/lockfile-0.9.1[${PYTHON_USEDEP}]
+ <dev-python/lockfile-0.13[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/click-5[${PYTHON_USEDEP}]
+ <dev-python/click-6[${PYTHON_USEDEP}]
+ <dev-python/bottle-0.13[${PYTHON_USEDEP}]
+ <dev-python/arrow-1[${PYTHON_USEDEP}]"