summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ross <aross@gentoo.org>2007-10-12 23:20:26 +0000
committerAndrew Ross <aross@gentoo.org>2007-10-12 23:20:26 +0000
commit1239307ab3fd0d8a02e0082af41ec1002a2ec9f9 (patch)
tree7fa464214eb00ee310669c7b4d327acc05e0594c
parentInitial commit of ebuild for l2tpns v2.1.21 (diff)
downloadaross-1239307ab3fd0d8a02e0082af41ec1002a2ec9f9.tar.gz
aross-1239307ab3fd0d8a02e0082af41ec1002a2ec9f9.tar.bz2
aross-1239307ab3fd0d8a02e0082af41ec1002a2ec9f9.zip
Require the TUN/TAP kernel driver. Install user manual and other docs (THANKS, Changelog).HEADmaster
svn path=/; revision=54
-rw-r--r--net-dialup/l2tpns/Manifest8
-rw-r--r--net-dialup/l2tpns/l2tpns-2.1.21.ebuild7
2 files changed, 11 insertions, 4 deletions
diff --git a/net-dialup/l2tpns/Manifest b/net-dialup/l2tpns/Manifest
index 1a80934..c755e13 100644
--- a/net-dialup/l2tpns/Manifest
+++ b/net-dialup/l2tpns/Manifest
@@ -3,10 +3,10 @@ MD5 fbf39d54e4681dd72808cf5735a83fc0 files/l2tpns-trust-localhost.patch 1918
RMD160 ec7318eda45cc77a8fd995ba92231479da37d329 files/l2tpns-trust-localhost.patch 1918
SHA256 1aa5f196c3269d56bdd5be05c2a152d15d786001a71a73fbe58d07fec8df9b58 files/l2tpns-trust-localhost.patch 1918
DIST l2tpns-2.1.21.tar.gz 180802 RMD160 8c060345e02c0e5604fef0d3cc2327637ad94123 SHA1 4b4a0f8cbd820fca9dd3448bc0f873596e031943 SHA256 0f8cde15181429e580691e994941492307efca0affe26bf7b4db7ab9477106de
-EBUILD l2tpns-2.1.21.ebuild 967 RMD160 06a43fe267d36492082744a2f0ac1f2c2d46ac30 SHA1 1749ba9d2001e4d23a68b19935e704e39741369c SHA256 24cf08f7bf3f9dcceca7caed2ea4af1e7b3fcc705e0e77969be69bc7b9f596ea
-MD5 b9f363b4247c4bb6baf3554fc3f0f3cb l2tpns-2.1.21.ebuild 967
-RMD160 06a43fe267d36492082744a2f0ac1f2c2d46ac30 l2tpns-2.1.21.ebuild 967
-SHA256 24cf08f7bf3f9dcceca7caed2ea4af1e7b3fcc705e0e77969be69bc7b9f596ea l2tpns-2.1.21.ebuild 967
+EBUILD l2tpns-2.1.21.ebuild 1150 RMD160 0e35fe244ca61e0c1c7f529349fb260e695b4ce1 SHA1 3c9e2b643a5db8d0b8a7ff384dbd9d60c554cc9c SHA256 341c31ebe02cef20fa2a56d5c8d66422343f06678da1384792cbedaaf3ad8847
+MD5 ecd1bd2a66fb46e7a4bb1b4c331736da l2tpns-2.1.21.ebuild 1150
+RMD160 0e35fe244ca61e0c1c7f529349fb260e695b4ce1 l2tpns-2.1.21.ebuild 1150
+SHA256 341c31ebe02cef20fa2a56d5c8d66422343f06678da1384792cbedaaf3ad8847 l2tpns-2.1.21.ebuild 1150
MISC metadata.xml 285 RMD160 46ce88e9982547a3f97f428a8e1af1926cbe7cf8 SHA1 c313b8ed2fce7bfeedef78fc5f1031af273a97c3 SHA256 1ae5f306e2e0889080c8cc7e2aa5198df7413a33f46e6f4b288a8e4a0e50caa9
MD5 c65ee45954d0cfd9522cd02c777af48a metadata.xml 285
RMD160 46ce88e9982547a3f97f428a8e1af1926cbe7cf8 metadata.xml 285
diff --git a/net-dialup/l2tpns/l2tpns-2.1.21.ebuild b/net-dialup/l2tpns/l2tpns-2.1.21.ebuild
index 08f4737..c368183 100644
--- a/net-dialup/l2tpns/l2tpns-2.1.21.ebuild
+++ b/net-dialup/l2tpns/l2tpns-2.1.21.ebuild
@@ -16,12 +16,16 @@ IUSE=""
DEPEND=">=dev-libs/libcli-1.8.5"
RDEPEND="${DEPEND}"
+CONFIG_CHECK="TUN"
+
src_unpack() {
unpack ${A}
pushd "${S}"
epatch "${FILESDIR}/${PN}-trust-localhost.patch"
+ # Without "#include <linux/types.h>", compilation fails with:
+ # l2tpns.c:509: error: syntax error before "__u32"
sed -i \
-e '/^#include <libcli.h>$/ a #include <linux/types.h>' \
"${S}"/l2tpns.c || die "sed on l2tpns.c failed"
@@ -42,4 +46,7 @@ src_install() {
DESTDIR="${D}" \
libdir="/usr/$(get_libdir)/${PN}" \
|| die "emake install failed"
+
+ dodoc THANKS Changes
+ dohtml Docs/manual.html
}