summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-08-12 15:49:58 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-08-12 15:49:58 +0300
commit9762b8c700ecb5e909eca2e300193d21f2c7295c (patch)
treec51a417861d122d17057975aa340c6b4bb439373
parentsys-cluster/maui: several fixes (diff)
downloadbircoph-9762b8c700ecb5e909eca2e300193d21f2c7295c.tar.gz
bircoph-9762b8c700ecb5e909eca2e300193d21f2c7295c.tar.bz2
bircoph-9762b8c700ecb5e909eca2e300193d21f2c7295c.zip
sys-cluster/netpipe: multiple fixes
- GLEP 67 update - EAPI 6 version bump - USE flags cleanup
-rw-r--r--sys-cluster/netpipe/metadata.xml3
-rw-r--r--sys-cluster/netpipe/netpipe-3.7.2.ebuild21
2 files changed, 9 insertions, 15 deletions
diff --git a/sys-cluster/netpipe/metadata.xml b/sys-cluster/netpipe/metadata.xml
index d1b4d28..55d625b 100644
--- a/sys-cluster/netpipe/metadata.xml
+++ b/sys-cluster/netpipe/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
+<maintainer type="person">
<email>bircoph@gentoo.org</email>
<name>Andrew Savchenko</name>
</maintainer>
@@ -13,7 +13,6 @@
</longdescription>
<use>
<flag name='memcpy'>Build memory testing tool (using memcpy)</flag>
- <flag name='sctp'>Build SCTP testing tool</flag>
<flag name='tcp'>Build TCP testing tool</flag>
<flag name='utils'>Install helper scripts</flag>
</use>
diff --git a/sys-cluster/netpipe/netpipe-3.7.2.ebuild b/sys-cluster/netpipe/netpipe-3.7.2.ebuild
index 75b43a7..a22f728 100644
--- a/sys-cluster/netpipe/netpipe-3.7.2.ebuild
+++ b/sys-cluster/netpipe/netpipe-3.7.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
EAPI=5
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_PN="NetPIPE"
MY_P="${MY_PN}-${PV}"
@@ -19,7 +19,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc examples infiniband ipv6 +memcpy mpi sctp +tcp utils"
DEPEND="
- infiniband? ( sys-infiniband/ofed )
+ infiniband? ( sys-fabric/ofed )
mpi? ( virtual/mpi )
"
RDEPEND="${DEPEND}
@@ -38,15 +38,10 @@ REQUIRED_USE="
|| ( memcpy infiniband mpi sctp tcp )
"
-src_prepare() {
- # fix build with ipv6
- epatch "${FILESDIR}/${P}-ipv6.patch"
- # use gv instead of ghostscript program (not in tree anymore)
- epatch "${FILESDIR}/${PN}-3.7.1-gv.patch"
- # fix makefile to respect system CC, CFLAGS, LDFLAGS
- # use standard system infiniband headers and libs
- epatch "${FILESDIR}/${PN}-3.7.1-makefile.patch"
-}
+PATCHES=(
+ "${FILESDIR}/${P}-ipv6.patch"
+ "${FILESDIR}/${PN}-3.7.1-gv.patch"
+ "${FILESDIR}/${PN}-3.7.1-makefile.patch" )
src_configure() {
# no configure script, create list of make targets