summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@c1pher.net>2014-12-12 19:19:04 -0500
committerDane Smith <c1pher@c1pher.net>2014-12-12 19:19:04 -0500
commit63c7bfdb84648a2c41da5febcb1c008dfd597a33 (patch)
treefc8b7410590a42daf1cf35b2567ca744b9fb3851 /www-apps/indefero/indefero-1.2.ebuild
parentLive ebuild for webscarab (diff)
downloadc1pher-63c7bfdb84648a2c41da5febcb1c008dfd597a33.tar.gz
c1pher-63c7bfdb84648a2c41da5febcb1c008dfd597a33.tar.bz2
c1pher-63c7bfdb84648a2c41da5febcb1c008dfd597a33.zip
Drop ancient stuff
Diffstat (limited to 'www-apps/indefero/indefero-1.2.ebuild')
-rw-r--r--www-apps/indefero/indefero-1.2.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/www-apps/indefero/indefero-1.2.ebuild b/www-apps/indefero/indefero-1.2.ebuild
deleted file mode 100644
index efbd7d9..0000000
--- a/www-apps/indefero/indefero-1.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-inherit eutils webapp
-
-DESCRIPTION="An open source Google Code clone"
-HOMEPAGE="http://www.indefero.net/"
-SRC_URI="http://projects.ceondo.com/p/${PN}/downloads/get/${P}.zip"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND="app-arch/unzip"
-RDEPEND="${DEPEND}
- dev-lang/php[gd]
- dev-php/pluf
- "
-S="${WORKDIR}/${PN}"
-
-src_prepare(){
- #Expect pluf to be installed in the normal location and adjust the index.php
- #to be where we want it.
- epatch "${FILESDIR}/${PN}-gentoo.diff"
- cp "${FILESDIR}/dbsetup.sh" src/ || die
- cp "${FILESDIR}/bootstrap.php" . || die
- mv www/* . || die
- rmdir www || die
-}
-
-src_compile(){ :; }
-
-src_install(){
- webapp_src_preinst
- rm COPYING INSTALL.mdtext release-script run-tests .gitignore \
- .gitattributes Makefile phpunit.xml || die
- dodoc doc/* NEWS.mdtext AUTHORS CONTRIBUTE.mdtext
- rm -rf test doc NEWS.mdtext AUTHORS CONTRIBUTE.mdtext || die
-
- mv src/IDF/conf/idf.php-dist src/IDF/conf/idf.php || die
- mv src/IDF/conf/path.php-dist src/IDF/conf/path.php || die
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- webapp_configfile "${MY_HTDOCSDIR}/src/IDF/conf/idf.php"
- webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
- webapp_src_install
-}
-
-pkg_postinst(){
- elog "The postinstall document contains all of the information"
- elog "needed to get ${PN} running."
- webapp_pkg_postinst
-}