summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/indefero/indefero-1.2.ebuild')
-rw-r--r--www-apps/indefero/indefero-1.2.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/www-apps/indefero/indefero-1.2.ebuild b/www-apps/indefero/indefero-1.2.ebuild
index 71e058d..fd21fe9 100644
--- a/www-apps/indefero/indefero-1.2.ebuild
+++ b/www-apps/indefero/indefero-1.2.ebuild
@@ -21,31 +21,36 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${PN}"
src_prepare(){
- #Expect pluf to be installed in the normal location.
- epatch "${FILESDIR}/${PN}-gentoo-pluf.diff"
- cp "${FILESDIR}/dbsetup.sh" src/
- cp "${FILESDIR}/bootstrap.php" www/
+ #Expect pluf to be installed in the normal location and adjust the index.php
+ #to be where we want it.
+ epatch "${FILESDIR}/${PN}-gentoo.diff"
+ cp "${FILESDIR}/dbsetup.sh" src/ || die
+ cp "${FILESDIR}/bootstrap.php" . || die
+ mv www/* . || die
}
src_compile(){ :; }
src_install(){
webapp_src_preinst
- rm COPYING INSTALL.mdtext release-script run-tests .gitignore .gitattributes
+ rm COPYING INSTALL.mdtext release-script run-tests .gitignore \
+ .gitattributes Makefile || die
dodoc doc/* NEWS.mdtext AUTHORS CONTRIBUTE.mdtext
- rm -rf doc NEWS.mdtext AUTHORS CONTRIBUTE.mdtext
+ rm -rf test doc NEWS.mdtext AUTHORS CONTRIBUTE.mdtext || die
- mv src/IDF/conf/idf.php-dist src/IDF/conf/idf.php
- mv src/IDF/conf/path.php-dist src/IDF/conf/path.php
+ mv src/IDF/conf/idf.php-dist src/IDF/conf/idf.php || die
+ mv src/IDF/conf/path.php-dist src/IDF/conf/path.php || die
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -R .
- cp -R . "${D}/${MY_HTDOCSDIR}"
webapp_configfile "${MY_HTDOCSDIR}/src/IDF/conf/idf.php"
webapp_postinst_txt en "${FILESDIR}/postinstall-en-${PV}.txt"
webapp_src_install
}
pkg_postinst(){
- webapp_pkg_postinst
elog "The postinstall document contains all of the information"
elog "needed to get ${PN} running."
+ webapp_pkg_postinst
}