summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--apps/dev-libs/dnmalloc/Manifest2
-rw-r--r--apps/dev-libs/dnmalloc/dnmalloc-1.0.ebuild2
-rw-r--r--apps/net-print/brother-cups/Manifest3
-rw-r--r--apps/net-print/brother-cups/brother-cups-2.0.1.ebuild38
4 files changed, 43 insertions, 2 deletions
diff --git a/apps/dev-libs/dnmalloc/Manifest b/apps/dev-libs/dnmalloc/Manifest
index 16150ae..d09eeaf 100644
--- a/apps/dev-libs/dnmalloc/Manifest
+++ b/apps/dev-libs/dnmalloc/Manifest
@@ -1,2 +1,2 @@
DIST dnmalloc-1.0.tar.gz 65395 RMD160 99722cca8b042491837602adaacb750904edc4fd SHA1 0de27d8c1f7c39f9294e2d199fcfca1ebda97ff7 SHA256 6cd120675a488eb23c50989ebf56f50cba42ab50539daebfc4b8d50a3cb287aa
-EBUILD dnmalloc-1.0.ebuild 408 RMD160 17d237452b1591112cb751d2c88b207bb51d06cd SHA1 c91a519441f7261e1c59f86ea60eba3da0dfffa6 SHA256 16ac615d1e8753a6f0f6d4e1930b2c03bf57b7b19afa8de06d3cf9d9cc1dbd76
+EBUILD dnmalloc-1.0.ebuild 410 RMD160 7c1a8d990837ba2bb9782a8209ed1f5b48caab88 SHA1 4e643d4c79f9cfd336ef70a89d001591be2283e3 SHA256 5bd5f016008230f03dff9e34067049756f312d31e999ff3eb670798550ee2a47
diff --git a/apps/dev-libs/dnmalloc/dnmalloc-1.0.ebuild b/apps/dev-libs/dnmalloc/dnmalloc-1.0.ebuild
index 5098605..119e0b1 100644
--- a/apps/dev-libs/dnmalloc/dnmalloc-1.0.ebuild
+++ b/apps/dev-libs/dnmalloc/dnmalloc-1.0.ebuild
@@ -7,7 +7,7 @@ KEYWORDS="~amd64 ~x86"
DESCRIPTION="Safer memory allocator."
HOMEPAGE="http://fort-knox.org/"
SRC_URI="http://fort-knox.org/files/${P}.tar.gz"
-LICENSE="LGPL"
+LICENSE="LGPL-2"
SLOT="0"
IUSE=""
diff --git a/apps/net-print/brother-cups/Manifest b/apps/net-print/brother-cups/Manifest
new file mode 100644
index 0000000..8f33a8f
--- /dev/null
+++ b/apps/net-print/brother-cups/Manifest
@@ -0,0 +1,3 @@
+DIST brmfc8860dnlpr-2.0.1-1.i386.rpm 35766 RMD160 a2c434756515374b934b1068b6babbe321975232 SHA1 d0aa0baab117033085707e42df0f8aa58b321a37 SHA256 d5292900d9a9c657af15b7e6766e4562d8d22cde6a9e405924163d85c008f16d
+DIST cupswrapperMFC8860DN-2.0.1-1.i386.rpm 13339 RMD160 7a874d0ebe7d69563df3c2330eebc53180108f3a SHA1 7542bc787fd074a136d5f903a087383132ff6318 SHA256 a6fd12076a50e3dfe0b4720319c4f49600d00ab9d61c115a902bcd2dffea610e
+EBUILD brother-cups-2.0.1.ebuild 1042 RMD160 c56fa2d4d1805cc6ebdf3de55d6b5a93e439e743 SHA1 8fb96a595b7f8ec2639517673901710ea31d0b1a SHA256 e7602bbb333af357b6da1f2ff1f7a736b5889ab72ef0b6b311965287f0460a1c
diff --git a/apps/net-print/brother-cups/brother-cups-2.0.1.ebuild b/apps/net-print/brother-cups/brother-cups-2.0.1.ebuild
new file mode 100644
index 0000000..9a8167d
--- /dev/null
+++ b/apps/net-print/brother-cups/brother-cups-2.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+LPR_BASEURI="http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/lpr_others"
+CUPS_BASEURI="http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/cups_wrapper"
+
+inherit rpm
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Brother MFC-8860DN CUPS printer driver."
+HOMEPAGE="http://solutions.brother.com/linux/en_us/index.html"
+SRC_URI="${LPR_BASEURI}/brmfc8860dnlpr-${PV}-1.i386.rpm
+ ${CUPS_BASEURI}/cupswrapperMFC8860DN-${PV}-1.i386.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=net-print/cups-1.3"
+
+src_unpack() {
+ rpm_src_unpack
+}
+
+src_compile() {
+ sed -e "s|/usr/lib/cups/|/usr/libexec/cups/|g" -i usr/local/Brother/cupswrapper/cupswrapperMFC8860DN-${PV}
+ sed -e "s|/usr/lib64/cups/|/usr/libexec/cups/|g" -i usr/local/Brother/cupswrapper/cupswrapperMFC8860DN-${PV}
+}
+
+src_install() {
+ cp -Rf "./" "${D}/"
+}
+
+pkg_postinst() {
+ ${ROOT}usr/local/Brother/cupswrapper/cupswrapperMFC8860DN-${PV}
+}