summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-06-04 12:27:10 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-06-04 12:27:10 +0000
commita7fb5258172a6bf8b60fd53ec8e03b6a0cee6bd9 (patch)
tree65b27bb8a5ecb6e1243caae9ae577414549657b0
parentWIP (diff)
downloaddrizzt-a7fb5258172a6bf8b60fd53ec8e03b6a0cee6bd9.tar.gz
drizzt-a7fb5258172a6bf8b60fd53ec8e03b6a0cee6bd9.tar.bz2
drizzt-a7fb5258172a6bf8b60fd53ec8e03b6a0cee6bd9.zip
Add amarok with xine amd gstreamer use flag.
svn path=/; revision=122
-rw-r--r--media-sound/amarok/ChangeLog7
-rw-r--r--media-sound/amarok/Manifest14
-rw-r--r--media-sound/amarok/amarok-1.4.5-r1.ebuild91
-rw-r--r--media-sound/amarok/files/amarok-1.4.5-magnatune.patch14
-rw-r--r--media-sound/yauap/Manifest3
-rw-r--r--media-sound/yauap/files/yauap-0.2_pre1-as-needed.patch29
-rw-r--r--media-sound/yauap/yauap-0.2_pre1.ebuild39
7 files changed, 197 insertions, 0 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
new file mode 100644
index 0000000..a63c1d2
--- /dev/null
+++ b/media-sound/amarok/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for media-sound/amarok
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 04 Jun 2007; Timothy Redaelli <drizzt@gentoo.org> ChangeLog:
+ Add amarok with xine amd gstreamer use flag.
+
diff --git a/media-sound/amarok/Manifest b/media-sound/amarok/Manifest
new file mode 100644
index 0000000..e3453c1
--- /dev/null
+++ b/media-sound/amarok/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX amarok-1.4.5-magnatune.patch 873 RMD160 f9d68fce79b228c8eb894442a95447dbaec0179b SHA1 aacd742d79b91d19ab68edd5a38d1dd08459c7b9 SHA256 96848937bffca80b2e9eb338e4581b7600ee2957f26a32291b5337fffb04cfb9
+DIST amarok-1.4.5.tar.bz2 18034110 RMD160 c2bbfe06f3e613dfc7d3926d086024073390c712 SHA1 882dec8d30c10f609a1f5e21d2e91342e78304c5 SHA256 45aa7cafe2a46dd988cd5034ae19da988926eecb2ac90d3e6912c57e558108c8
+EBUILD amarok-1.4.5-r1.ebuild 2733 RMD160 36f59c7f05f4068244830dce16df11078d3f1851 SHA1 1fe1250efb98666385d3762843e3c22ef5b13c08 SHA256 cf86c39532722cca24d76f8b1c4f5f507f2c200388d2166cabb474e7324c5582
+MISC ChangeLog 230 RMD160 70b1dcc2d0175e5a56e440ab5319f5d4b171d9a0 SHA1 21a677811447e50b58562da4a9352574747b74c9 SHA256 2a979eaed9accbc4ba26cb74ba71085f0a4aea0641b3783ed0a3bfecc3040cdd
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.4 (GNU/Linux)
+
+iD8DBQFGZAVJjJyKLBkBVroRAhKLAJ9BeqoVccnCP/dp1DEHG7Rfy7p9qQCghsxz
+5TnlxWoDNWrye/xH40E3+2k=
+=XTl7
+-----END PGP SIGNATURE-----
diff --git a/media-sound/amarok/amarok-1.4.5-r1.ebuild b/media-sound/amarok/amarok-1.4.5-r1.ebuild
new file mode 100644
index 0000000..796bb9e
--- /dev/null
+++ b/media-sound/amarok/amarok-1.4.5-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.5-r1.ebuild,v 1.7 2007/02/24 10:20:51 corsair Exp $
+
+LANGS="af ar az bg br ca cs cy da de el en_GB es et fa fi fr ga gl he
+hi hu is it ja ka km ko lt ms nb nl nn pa pl pt pt_BR ro ru rw se sk
+sl sq sr sr@Latn sv ta tg th tr uk uz zh_CN zh_TW"
+LANGS_DOC="da de es et fr it nl pl pt pt_BR ru sv"
+
+USE_KEG_PACKAGING=1
+
+inherit kde eutils flag-o-matic
+
+PKG_SUFFIX=""
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${P/_/-}"
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+SRC_URI="mirror://kde/stable/amarok/${PV}/src/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="aac kde mysql noamazon opengl postgres
+visualization ipod ifp real njb mtp musicbrainz daap xine gstreamer"
+# kde: enables compilation of the konqueror sidebar plugin
+
+RDEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
+ xine? ( >=media-libs/xine-lib-1.1.2_pre20060328-r8 )
+ >=media-libs/taglib-1.4
+ mysql? ( >=virtual/mysql-4.0 )
+ postgres? ( dev-db/libpq )
+ opengl? ( virtual/opengl )
+ visualization? ( media-libs/libsdl
+ =media-plugins/libvisual-plugins-0.4* )
+ ipod? ( >=media-libs/libgpod-0.4.2 )
+ aac? ( media-libs/libmp4v2 )
+ ifp? ( media-libs/libifp )
+ real? ( media-video/realplayer )
+ njb? ( >=media-libs/libnjb-2.2.4 )
+ mtp? ( >=media-libs/libmtp-0.1.1 )
+ musicbrainz? ( media-libs/tunepimp )
+ =dev-lang/ruby-1.8*"
+
+DEPEND="${RDEPEND}"
+
+RDEPEND="${RDEPEND}
+ app-arch/unzip
+ gstreamer? ( media-sound/yauap )
+ daap? ( www-servers/mongrel )"
+
+PATCHES="${FILESDIR}/${P}-magnatune.patch"
+
+need-kde 3.3
+
+src_compile() {
+ # Extra, unsupported engines are forcefully disabled.
+ local myconf="$(use_enable mysql) $(use_enable postgres postgresql)
+ $(use_with opengl) --without-xmms
+ $(use_with visualization libvisual)
+ $(use_enable !noamazon amazon)
+ $(use_with ipod libgpod)
+ $(use_with aac mp4v2)
+ $(use_with ifp)
+ $(use_with real helix)
+ $(use_with njb libnjb)
+ $(use_with mtp libmtp)
+ $(use_with musicbrainz)
+ $(use_with daap)
+ $(use_with xine)
+ $(use_with gstreamer yauap)
+ --without-mas
+ --without-nmm"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ # As much as I respect Ian, I'd rather leave Amarok to use mongrel
+ # from Portage, for security and policy reasons.
+ rm -rf "${D}"/usr/share/apps/amarok/ruby_lib/rbconfig \
+ "${D}"/usr/share/apps/amarok/ruby_lib/mongrel* \
+ "${D}"/usr/share/apps/amarok/ruby_lib/rubygems* \
+ "${D}"/usr/share/apps/amarok/ruby_lib/gem* \
+ "${D}"/usr/$(get_libdir)/ruby_lib
+}
diff --git a/media-sound/amarok/files/amarok-1.4.5-magnatune.patch b/media-sound/amarok/files/amarok-1.4.5-magnatune.patch
new file mode 100644
index 0000000..3716fa8
--- /dev/null
+++ b/media-sound/amarok/files/amarok-1.4.5-magnatune.patch
@@ -0,0 +1,14 @@
+Index: amarok-1.4.5/amarok/src/magnatunebrowser/magnatunealbumdownloader.cpp
+===================================================================
+--- amarok-1.4.5/amarok/src/magnatunebrowser/magnatunealbumdownloader.cpp (revision 633568)
++++ amarok-1.4.5/amarok/src/magnatunebrowser/magnatunealbumdownloader.cpp (revision 633677)
+@@ -89,8 +89,8 @@
+
+ //ok, now we have the .zip file downloaded. All we need is to unpack it to the desired location and add it to the collection.
+
+- QString unzipString = "unzip \""+m_tempDir.name() + m_currentAlbumFileName + "\" -d \"" + m_currentAlbumUnpackLocation + "\" &";
++ QString unzipString = "unzip "+ KProcess::quote( m_tempDir.name() + m_currentAlbumFileName) + " -d " +KProcess::quote( m_currentAlbumUnpackLocation ) + " &";
+
+ debug() << "unpacking: " << unzipString << endl;
+
+ system( unzipString.ascii() );
diff --git a/media-sound/yauap/Manifest b/media-sound/yauap/Manifest
new file mode 100644
index 0000000..833b173
--- /dev/null
+++ b/media-sound/yauap/Manifest
@@ -0,0 +1,3 @@
+AUX yauap-0.2_pre1-as-needed.patch 815 RMD160 41b25dd3da1586a98ac4a57094ca30cfc2337cb9 SHA1 a4b09e349f5e62a016a496c3111f8c8a5144e15c SHA256 ad598d4c3f2366a1939c4228c3d96a12790f82332fd1ab7985f679f32e1a5396
+DIST yauap-0.2pre1.tar.gz 28967 RMD160 5b81da04091adc716be12909e5b62e36deb8623f SHA1 ce8f929e75ee01e015efb3db1c35147a9c1fe365 SHA256 d83022a61898fdd43bd32f525924f3152721811a02ab891996de7b50a4ac7e89
+EBUILD yauap-0.2_pre1.ebuild 814 RMD160 36b1fa690ea76a1386edcc733c9b7918b88c2231 SHA1 91363c6e93da1b52eed9e28c4267aef67f365edb SHA256 3d7ddfcb2a85f7c67d8695131111b4ba8616a7278b7283e9b4bda6aa467ff171
diff --git a/media-sound/yauap/files/yauap-0.2_pre1-as-needed.patch b/media-sound/yauap/files/yauap-0.2_pre1-as-needed.patch
new file mode 100644
index 0000000..e1511fd
--- /dev/null
+++ b/media-sound/yauap/files/yauap-0.2_pre1-as-needed.patch
@@ -0,0 +1,29 @@
+diff -ru yauap-0.2pre1.old/Makefile yauap-0.2pre1/Makefile
+--- yauap-0.2pre1.old/Makefile 2007-06-02 20:43:51.000000000 +0200
++++ yauap-0.2pre1/Makefile 2007-06-02 20:45:01.000000000 +0200
+@@ -7,13 +7,13 @@
+ CFLAGS += -g3 -Wall
+ #glib 2
+ CFLAGS += `pkg-config --cflags glib-2.0`
+-LDFLAGS += `pkg-config --libs glib-2.0`
++LIBS = `pkg-config --libs glib-2.0`
+ #gstreamer
+ CFLAGS += `pkg-config --cflags gstreamer-0.10`
+-LDFLAGS += `pkg-config --libs gstreamer-0.10`
++LIBS += `pkg-config --libs gstreamer-0.10`
+ #dbus
+ CFLAGS += `pkg-config --cflags dbus-1`
+-LDFLAGS += `pkg-config --libs dbus-1` -ldbus-glib-1
++LIBS += `pkg-config --libs dbus-1` -ldbus-glib-1
+
+
+
+@@ -35,7 +35,7 @@
+
+
+ yauap: yauap-service-glue.h $(OBJS)
+- $(CC) $(LDFLAGS) -o $@ $(OBJS)
++ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
+
+ clean:
diff --git a/media-sound/yauap/yauap-0.2_pre1.ebuild b/media-sound/yauap/yauap-0.2_pre1.ebuild
new file mode 100644
index 0000000..282725d
--- /dev/null
+++ b/media-sound/yauap/yauap-0.2_pre1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Simple commandline audio player that is using the GStreamer multimedia framework."
+HOMEPAGE="http://www.nongnu.org/yauap/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P/_}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=media-libs/gst-plugins-base-0.10
+ >=sys-apps/dbus-1.0
+ >=dev-libs/glib-2.0"
+
+RDEPEND="${DEPEND}
+ >=media-libs/gst-plugins-good-0.10"
+
+S=${WORKDIR}/"${P/_}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin yauap || die "Cannot install yauap"
+ dodoc ChangeLog README
+}