summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/lensfun/Manifest2
-rw-r--r--media-libs/lensfun/lensfun-9999.ebuild53
-rw-r--r--media-libs/lensfun/metadata.xml14
3 files changed, 69 insertions, 0 deletions
diff --git a/media-libs/lensfun/Manifest b/media-libs/lensfun/Manifest
new file mode 100644
index 000000000..5afe0cce1
--- /dev/null
+++ b/media-libs/lensfun/Manifest
@@ -0,0 +1,2 @@
+EBUILD lensfun-9999.ebuild 1267 BLAKE2B a0404e6fb00bfe2f4ea6484141bf0f29b89d0eef7ba852c5bc6099ed4b9917219f126056134aae80258d4f58767fccb2fa0c8ba5f07602896aa0894c00d2b081 SHA512 a1bcd4e0efcbf09541b7b4f3a03cab36edfd8e29329c82cac67c5c4d6d67bb59e4e65a990ab79363c4e0860537c2ba8cb51e72477bff06db2fef94dce5efc7a5
+MISC metadata.xml 609 BLAKE2B f9ebe22f93c9622961688f478f0f46c111fda47252c57c96aa4f566107705f27b6beb820c0d3c6df6414f7d31dd3d1c89e31a66b064ff96fc7e7e481faf47b7c SHA512 f3c9ae5432aaae9e83dec01dc9d6a4b8d01998183ef1c6ba7731ea9eb92b4960ddfdd0a2395bfb9f137224e83d4c938a7187f01579eb5c9e882e9f4d8008ee39
diff --git a/media-libs/lensfun/lensfun-9999.ebuild b/media-libs/lensfun/lensfun-9999.ebuild
new file mode 100644
index 000000000..665cbc1a2
--- /dev/null
+++ b/media-libs/lensfun/lensfun-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit python-single-r1 cmake-utils git-r3
+
+DESCRIPTION="Library for rectifying and simulating photographic lens distortions"
+HOMEPAGE="http://lensfun.sourceforge.net/"
+EGIT_REPO_URI="https://git.code.sf.net/p/lensfun/code"
+
+LICENSE="LGPL-3 CC-BY-SA-3.0" # See README for reasoning.
+SLOT="0"
+KEYWORDS=""
+IUSE="doc cpu_flags_x86_sse cpu_flags_x86_sse2 test"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.40
+ media-libs/libpng:0=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ dev-python/docutils
+ )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=( README.md docs/mounts.txt ChangeLog )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
+ -DCMAKE_INSTALL_LIBDIR="${EPREFIX}"/usr/$(get_libdir)
+ -DBUILD_LENSTOOL=ON
+ -DBUILD_STATIC=OFF
+ -DBUILD_DOC=$(usex doc)
+ -DBUILD_FOR_SSE=$(usex cpu_flags_x86_sse)
+ -DBUILD_FOR_SSE2=$(usex cpu_flags_x86_sse2)
+ -DBUILD_TESTS=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ mkdir -p "${T}/db/lensfun" || die
+ cp data/db/* "${T}/db/lensfun/" || die
+
+ XDG_DATA_HOME="${T}/db" cmake-utils_src_test
+}
diff --git a/media-libs/lensfun/metadata.xml b/media-libs/lensfun/metadata.xml
new file mode 100644
index 000000000..02bc5f156
--- /dev/null
+++ b/media-libs/lensfun/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>graphics@gentoo.org</email>
+ <name>Gentoo Graphics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+The project provides a database of photographic lenses and a library that allows advanced access to the database including functions to correct images based on intimate knowledge of lens characteristics and calibration data.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">lensfun</remote-id>
+ </upstream>
+</pkgmetadata>