summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/netbeans-extide/netbeans-extide-9999_p20180113.ebuild')
-rw-r--r--dev-java/netbeans-extide/netbeans-extide-9999_p20180113.ebuild94
1 files changed, 0 insertions, 94 deletions
diff --git a/dev-java/netbeans-extide/netbeans-extide-9999_p20180113.ebuild b/dev-java/netbeans-extide/netbeans-extide-9999_p20180113.ebuild
deleted file mode 100644
index 96e0db411..000000000
--- a/dev-java/netbeans-extide/netbeans-extide-9999_p20180113.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-inherit eutils java-pkg-2 java-ant-2
-
-DESCRIPTION="Netbeans ExtIDE Cluster"
-HOMEPAGE="https://netbeans.org/projects/ide"
-SLOT="9999"
-SOURCE_URL="http://bits.netbeans.org/download/trunk/nightly/2018-01-13_00-02-15/zip/netbeans-trunk-nightly-201801130002-src.zip"
-SRC_URI="${SOURCE_URL}
- https://dev.gentoo.org/~fordfrog/distfiles/netbeans-9999-r21-build.xml.patch.bz2
- https://hg.netbeans.org/binaries/0B539A378C2EA52B17BD0326ECE03DF66E3A65E9-ant-libs-1.10.1.zip
- https://hg.netbeans.org/binaries/F6E0317E5F315E395DA47E5B008D01FAA48C91FB-ant-misc-1.10.1.zip"
-LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-S="${WORKDIR}"
-
-CDEPEND="virtual/jdk:1.8
- ~dev-java/netbeans-ide-${PV}
- ~dev-java/netbeans-platform-${PV}"
-DEPEND="${CDEPEND}
- app-arch/unzip
- dev-java/javahelp:0"
-RDEPEND="${CDEPEND}"
-
-INSTALL_DIR="/usr/share/${PN}-${SLOT}"
-
-EANT_BUILD_XML="nbbuild/build.xml"
-EANT_BUILD_TARGET="rebuild-cluster"
-EANT_EXTRA_ARGS="-Drebuild.cluster.name=nb.cluster.extide -Dext.binaries.downloaded=true -Djava.awt.headless=true -Dpermit.jdk8.builds=true"
-EANT_FILTER_COMPILER="ecj-3.3 ecj-3.4 ecj-3.5 ecj-3.6 ecj-3.7"
-JAVA_PKG_BSFIX="off"
-
-src_unpack() {
- unpack $(basename ${SOURCE_URL})
-
- einfo "Deleting bundled jars..."
- find -name "*.jar" -type f -delete
-
- unpack netbeans-9999-r21-build.xml.patch.bz2
-
- pushd "${S}" >/dev/null || die
- ln -s "${DISTDIR}"/0B539A378C2EA52B17BD0326ECE03DF66E3A65E9-ant-libs-1.10.1.zip o.apache.tools.ant.module/external/ant-libs-1.10.1.zip || die
- ln -s "${DISTDIR}"/F6E0317E5F315E395DA47E5B008D01FAA48C91FB-ant-misc-1.10.1.zip o.apache.tools.ant.module/external/ant-misc-1.10.1.zip || die
- popd >/dev/null || die
-}
-
-src_prepare() {
- einfo "Deleting bundled class files..."
- find -name "*.class" -type f | xargs rm -vf
-
- epatch netbeans-9999-r21-build.xml.patch
-
- einfo "Symlinking external libraries..."
- java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
-
- einfo "Linking in other clusters..."
- mkdir "${S}"/nbbuild/netbeans || die
- pushd "${S}"/nbbuild/netbeans >/dev/null || die
-
- ln -s /usr/share/netbeans-ide-${SLOT} ide || die
- cat /usr/share/netbeans-ide-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
- touch nb.cluster.ide.built
-
- ln -s /usr/share/netbeans-platform-${SLOT} platform || die
- cat /usr/share/netbeans-platform-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
- touch nb.cluster.platform.built
-
- popd >/dev/null || die
-
- java-pkg-2_src_prepare
- default
-}
-
-src_compile() {
- unset DISPLAY
- eant -f ${EANT_BUILD_XML} ${EANT_EXTRA_ARGS} ${EANT_BUILD_TARGET} || die "Compilation failed"
-}
-
-src_install() {
- pushd nbbuild/netbeans/extide >/dev/null || die
-
- insinto ${INSTALL_DIR}
-
- grep -E "/extide$" ../moduleCluster.properties > "${D}"/${INSTALL_DIR}/moduleCluster.properties || die
-
- doins -r *
-
- popd >/dev/null || die
-
- dosym ${INSTALL_DIR} /usr/share/netbeans-nb-${SLOT}/extide
-}