summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2022-06-07 07:30:54 +0200
committerHans de Graaff <hans@degraaff.org>2022-06-07 07:30:54 +0200
commitb682bcdd0b60b1769283c5b6933237eeba0b3781 (patch)
tree538ab3e3ad498f115fd24135b4fb20490e09bfc8
parentdev-ruby/rubocop: add 1.30.1 (diff)
downloadgraaff-b682bcdd0b60b1769283c5b6933237eeba0b3781.tar.gz
graaff-b682bcdd0b60b1769283c5b6933237eeba0b3781.tar.bz2
graaff-b682bcdd0b60b1769283c5b6933237eeba0b3781.zip
dev-ruby/rubocop-performance: add 1.14.1
Signed-off-by: Hans de Graaff <hans@degraaff.org>
-rw-r--r--dev-ruby/rubocop-performance/Manifest1
-rw-r--r--dev-ruby/rubocop-performance/rubocop-performance-1.14.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/rubocop-performance/Manifest b/dev-ruby/rubocop-performance/Manifest
index fa1da998..eb27ef99 100644
--- a/dev-ruby/rubocop-performance/Manifest
+++ b/dev-ruby/rubocop-performance/Manifest
@@ -1,2 +1,3 @@
DIST rubocop-performance-1.12.0.tar.gz 96126 BLAKE2B cca1651e6e89e0fadbbf060c599d0903be0e8eea4955bb1800a7519f9c95578063e8802d0d508fb22ecfad8c16739cdd100f161fea6171565cb3e9dc272e1e13 SHA512 f6f3aacc870a488d21c5c5c74b9ff4e4ddaf68ab66f2a22ed3097d43d7ddfa3ee2f24a6a1d68a03bba18e5abbce80e9d0a63d3b1ccd622e11ab9bd9c31ed72b9
DIST rubocop-performance-1.13.3.tar.gz 100015 BLAKE2B 816a9ba92b68a65bf9f575e7b752dc00c550714d21181810f9a1825d9c73afad218de4fb837d306aeb0bb4f698b83882198978d0abc55e1f43685f976752ec1b SHA512 1dd1a8f9fd3f964a8a792bb740c84360e1ed9ea51868c72108b87f6c708d8c204a961898de7f4f842db014f8514e2f221050e1e6f327ddb97d0b1115c3ec8bab
+DIST rubocop-performance-1.14.1.tar.gz 100961 BLAKE2B afdefc15c7fe08121230efed0744ed15fd548436c897e4014123d39bed60a41091d857d06babfad02748697ff56699b0f82ea4f335260fbdc8033d1f97b1e17a SHA512 1cb830d4cd3361bf2c26cab2b756b5e02b7393124e07b18d00c2aebbaf8098e6e63cf90615963c0f50f07adcb7c17e1046a09a84e3001a308780df5d8088f572
diff --git a/dev-ruby/rubocop-performance/rubocop-performance-1.14.1.ebuild b/dev-ruby/rubocop-performance/rubocop-performance-1.14.1.ebuild
new file mode 100644
index 00000000..bb410f63
--- /dev/null
+++ b/dev-ruby/rubocop-performance/rubocop-performance-1.14.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="config"
+
+RUBY_FAKEGEM_GEMSPEC="rubocop-performance.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of RuboCop cops to check for performance optimizations in Ruby code"
+HOMEPAGE="https://github.com/rubocop-hq/rubocop-performance/"
+SRC_URI="https://github.com/rubocop-hq/rubocop-performance/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/rubocop-1.7.0:0
+ >=dev-ruby/rubocop-ast-0.4.0
+"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rubocop-1.13.0 )"