summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-09-10 22:44:19 +0300
committerAli Polatel <hawking@gentoo.org>2008-09-10 22:44:19 +0300
commit5cfca43475caf863e8d45a30ac653d65c46d0d68 (patch)
tree863eae620d420489ecab31cc36407d8426344e7d
parentAdded dev-lua/lua-ex (diff)
downloadhawking-5cfca43475caf863e8d45a30ac653d65c46d0d68.tar.gz
hawking-5cfca43475caf863e8d45a30ac653d65c46d0d68.tar.bz2
hawking-5cfca43475caf863e8d45a30ac653d65c46d0d68.zip
Added dev-lua/lunit
-rw-r--r--dev-lua/lunit/Manifest2
-rw-r--r--dev-lua/lunit/lunit-0.4.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-lua/lunit/Manifest b/dev-lua/lunit/Manifest
new file mode 100644
index 0000000..7c7290a
--- /dev/null
+++ b/dev-lua/lunit/Manifest
@@ -0,0 +1,2 @@
+DIST lunit-0.4.tar.gz 12794 RMD160 23791bddd0e93f43849696fb7c15a4f6ab097cd6 SHA1 2d2352b74ddaa83104f14ff3d20a64b73a1e3ae2 SHA256 09efe9f35132353c6810c57367cba29659afc7348ff593c529cbee1831d66d7a
+EBUILD lunit-0.4.ebuild 637 RMD160 f549f9d16f77eec6ce2175a875b2984f8c45ce16 SHA1 87183db56a4a092645d89c70a9ea03306385e28b SHA256 efad1acf51a130eebf6ddacf79afdbefc2e74459f5709a918c17e95faaad2461
diff --git a/dev-lua/lunit/lunit-0.4.ebuild b/dev-lua/lunit/lunit-0.4.ebuild
new file mode 100644
index 0000000..933fb54
--- /dev/null
+++ b/dev-lua/lunit/lunit-0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit lua
+
+DESCRIPTION="A unit testing framework for Lua"
+HOMEPAGE="http://www.mroth.net/lunit/"
+SRC_URI="http://www.mroth.net/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/lua-5.1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ lua_install_module lunit.lua lunit-console.lua
+ dobin lunit || die "dobin failed"
+ dodoc ANNOUNCE CHANGES DOCUMENTATION README* example.lua || die "dodoc failed"
+}
+
+src_test() {
+ ./lunit lunit-tests.lua || die "tests failed"
+}