summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-10-28 14:52:58 +0200
committerAli Polatel <hawking@gentoo.org>2008-10-28 14:52:58 +0200
commitae14aead743c83efb9050a43970ceadc73806664 (patch)
tree0d23744f26ef6cd7002061c37f9c8c5daa46d5a4
parentAdd dev-lua/luairc. (diff)
downloadhawking-ae14aead743c83efb9050a43970ceadc73806664.tar.gz
hawking-ae14aead743c83efb9050a43970ceadc73806664.tar.bz2
hawking-ae14aead743c83efb9050a43970ceadc73806664.zip
Add games-board/polyglot.HEADmaster
-rw-r--r--games-board/polyglot/Manifest2
-rw-r--r--games-board/polyglot/polyglot-1.4.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/games-board/polyglot/Manifest b/games-board/polyglot/Manifest
new file mode 100644
index 0000000..7e21b61
--- /dev/null
+++ b/games-board/polyglot/Manifest
@@ -0,0 +1,2 @@
+DIST polyglot_14.zip 229546 RMD160 457bbb91c3a40196b496d681e7475379bfa9c7c1 SHA1 47363999135b329302f5565618d1ffa2e8c872d1 SHA256 850af826217023c74e00a3e4333d3693c086ca25e7f34e5cebaebd5597d6697a
+EBUILD polyglot-1.4.ebuild 981 RMD160 db938274d100e07f8fdc81fe28b5df5c6804c652 SHA1 e76a9c570c5e74dc29d3367753e2ddc78ab16220 SHA256 a917c6f82cf518f6082789e791f7cf7ecd82418779434f37e6cf400b792baf8c
diff --git a/games-board/polyglot/polyglot-1.4.ebuild b/games-board/polyglot/polyglot-1.4.ebuild
new file mode 100644
index 0000000..d796e70
--- /dev/null
+++ b/games-board/polyglot/polyglot-1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit games
+
+MY_P="${PN}_${PV/./}"
+
+DESCRIPTION="UCI adapter to connect a UCI chess engine to an xboard interface"
+HOMEPAGE="http://wbec-ridderkerk.nl/html/details1/PolyGlot.html"
+SRC_URI="http://wbec-ridderkerk.nl/html/downloada/fruit/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect {CXX,LD}FLAGS, don't strip
+ sed -i \
+ -e "s:\(CXX\|LD\)FLAGS \+=:\1FLAGS +=:" \
+ -e "/LDFLAGS.*-s/d" \
+ src/Makefile || die "sed in Makefile failed"
+}
+
+src_compile() {
+ cd src
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/${PN} || die "dobin failed"
+ dodoc readme.txt || die "dodoc failed"
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r "${WORKDIR}"/example/* || die "doins failed"
+ fi
+}