aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-06-10 14:05:00 +0200
committerJohannes Huber <johu@gentoo.org>2018-06-10 14:05:00 +0200
commit2851769bdffb43c2dac31472e922249e92753227 (patch)
treeac24c5ed7deab50ec65cfb2fcf2b567baa1868d5
parentBump portage version to 2.3.40 (diff)
downloadjohu-2851769bdffb43c2dac31472e922249e92753227.tar.gz
johu-2851769bdffb43c2dac31472e922249e92753227.tar.bz2
johu-2851769bdffb43c2dac31472e922249e92753227.zip
app-emulation/vagrant-bin: EAPI 7
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--app-emulation/vagrant-bin/vagrant-bin-2.1.1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/app-emulation/vagrant-bin/vagrant-bin-2.1.1.ebuild b/app-emulation/vagrant-bin/vagrant-bin-2.1.1.ebuild
index 20da036..3956aca 100644
--- a/app-emulation/vagrant-bin/vagrant-bin-2.1.1.ebuild
+++ b/app-emulation/vagrant-bin/vagrant-bin-2.1.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
MY_PN=${PN/-bin/}
inherit unpacker eutils
@@ -17,8 +17,7 @@ IUSE=""
S="${WORKDIR}/opt/${MY_PN}"
-DEPEND=""
-RDEPEND="${DEPEND}
+RDEPEND="
app-arch/libarchive
net-misc/curl
!app-emulation/vagrant
@@ -33,7 +32,7 @@ src_unpack() {
src_install() {
local dir="/opt/${MY_PN}"
dodir ${dir}
- cp -ar ./* "${ED}${dir}" || die "copy files failed"
+ cp -ar ./* "${ED%/}${dir}" || die "copy files failed"
make_wrapper "${MY_PN}" "${dir}/bin/${MY_PN}"
}