aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-06-26 22:38:25 +0200
committerJohannes Huber <johu@gentoo.org>2015-06-26 22:38:25 +0200
commita9dd217244b946168dca26c5dceb5e7c4c6d4fe4 (patch)
treebcca924b541517eb9bcfb76c0d231c4cbb4c8072
parent[app-portage/genlop] Remove, changes merged into upstream (diff)
downloadjohu-a9dd217244b946168dca26c5dceb5e7c4c6d4fe4.tar.gz
johu-a9dd217244b946168dca26c5dceb5e7c4c6d4fe4.tar.bz2
johu-a9dd217244b946168dca26c5dceb5e7c4c6d4fe4.zip
[net-irc/quassel] Sync with tree
Package-Manager: portage-2.2.20
-rw-r--r--net-irc/quassel/files/quassel-0.12.2-qt55.patch53
-rw-r--r--net-irc/quassel/quassel-9999.ebuild11
2 files changed, 61 insertions, 3 deletions
diff --git a/net-irc/quassel/files/quassel-0.12.2-qt55.patch b/net-irc/quassel/files/quassel-0.12.2-qt55.patch
new file mode 100644
index 0000000..3bf8989
--- /dev/null
+++ b/net-irc/quassel/files/quassel-0.12.2-qt55.patch
@@ -0,0 +1,53 @@
+From 0df317e85ab3d1d80135995d3b5d7f5341fef6e4 Mon Sep 17 00:00:00 2001
+From: Armin K <krejzi@email.com>
+Date: Sat, 2 May 2015 23:04:53 +0200
+Subject: [PATCH] Fix build with Qt-5.5
+
+http://code.qt.io/cgit/qt/qtbase.git/commit/?id=ebef2ad1360c80ad62de5f4a1c4e7e4051725c1c
+---
+ src/client/treemodel.cpp | 5 ++---
+ src/common/peer.h | 1 +
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/client/treemodel.cpp b/src/client/treemodel.cpp
+index f599803..fd47bc0 100644
+--- a/src/client/treemodel.cpp
++++ b/src/client/treemodel.cpp
+@@ -556,10 +556,9 @@ void TreeModel::endAppendChilds()
+ ChildStatus cs = _childStatus;
+ #ifndef QT_NO_DEBUG
+ QModelIndex parent = indexByItem(parentItem);
+-#endif
+ Q_ASSERT(cs.parent == parent);
+ Q_ASSERT(rowCount(parent) == cs.childCount + cs.end - cs.start + 1);
+-
++#endif
+ _aboutToRemoveOrInsert = false;
+ for (int i = cs.start; i <= cs.end; i++) {
+ connectItem(parentItem->child(i));
+@@ -605,9 +604,9 @@ void TreeModel::endRemoveChilds()
+ #ifndef QT_NO_DEBUG
+ ChildStatus cs = _childStatus;
+ QModelIndex parent = indexByItem(parentItem);
+-#endif
+ Q_ASSERT(cs.parent == parent);
+ Q_ASSERT(rowCount(parent) == cs.childCount - cs.end + cs.start - 1);
++#endif
+ _aboutToRemoveOrInsert = false;
+
+ endRemoveRows();
+diff --git a/src/common/peer.h b/src/common/peer.h
+index 02eb3c0..79204b4 100644
+--- a/src/common/peer.h
++++ b/src/common/peer.h
+@@ -22,6 +22,7 @@
+ #define PEER_H
+
+ #include <QAbstractSocket>
++#include <QDataStream>
+ #include <QPointer>
+
+ #include "authhandler.h"
+--
+2.4.0
+
diff --git a/net-irc/quassel/quassel-9999.ebuild b/net-irc/quassel/quassel-9999.ebuild
index c2029a7..77dd2a2 100644
--- a/net-irc/quassel/quassel-9999.ebuild
+++ b/net-irc/quassel/quassel-9999.ebuild
@@ -11,7 +11,7 @@ EGIT_REPO_URI="git://git.quassel-irc.org/quassel"
DESCRIPTION="Qt/KDE IRC client supporting a remote daemon for 24/7 connectivity"
HOMEPAGE="http://quassel-irc.org/"
-[[ "${PV}" == "9999" ]] || SRC_URI="http://quassel-irc.org/pub/${P/_/-}.tar.bz2"
+[[ "${PV}" == "9999" ]] || SRC_URI="http://quassel-irc.org/pub/${P}.tar.bz2"
LICENSE="GPL-3"
KEYWORDS=""
@@ -97,14 +97,14 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS ChangeLog README )
-S="${WORKDIR}/${P/_/-}"
+PATCHES=( "${FILESDIR}/${PN}-0.12.2-qt55.patch" )
REQUIRED_USE="
|| ( X server monolithic )
ayatana? ( || ( X monolithic ) )
crypt? ( || ( server monolithic ) )
dbus? ( || ( X monolithic ) )
- kde? ( || ( X monolithic ) )
+ kde? ( || ( X monolithic ) phonon )
phonon? ( || ( X monolithic ) )
postgres? ( || ( server monolithic ) )
qt5? ( !ayatana )
@@ -141,6 +141,11 @@ src_configure() {
"-DEMBED_DATA=OFF"
)
+ # Something broke upstream detection since Qt 5.5
+ if use ssl ; then
+ mycmakeargs+=("-DHAVE_SSL=TRUE")
+ fi
+
cmake-utils_src_configure
}