summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2015-02-19 21:00:41 +0200
committerMart Raudsepp <leio@gentoo.org>2015-02-19 21:00:41 +0200
commit04737016b2424d5fce9e420f73db5ce749ecba6f (patch)
tree09c15d87d476a5c02cf71ef47f1a1e3f0028331c
parentAdd a preliminary ebuild for maynard desktop env (diff)
downloadleio-04737016b2424d5fce9e420f73db5ce749ecba6f.tar.gz
leio-04737016b2424d5fce9e420f73db5ce749ecba6f.tar.bz2
leio-04737016b2424d5fce9e420f73db5ce749ecba6f.zip
gtk+:2 - sync with portage
-rw-r--r--x11-libs/gtk+/Manifest2
-rw-r--r--x11-libs/gtk+/gtk+-2.24.26.ebuild (renamed from x11-libs/gtk+/gtk+-2.24.25-r1.ebuild)26
2 files changed, 14 insertions, 14 deletions
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index 5b2910b..311da31 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -1,2 +1,2 @@
-DIST gtk+-2.24.25.tar.xz 13327832 SHA256 38af1020cb8ff3d10dda2c8807f11e92af9d2fa4045de61c62eedb7fbc7ea5b3 SHA512 e102eabbd86e9e697402b4d915172dd3838374b7b8a16b95369ed602228857a013fdba7b6b8d742f925ff8d340b63a90b56c1ddbd4405d8dc454144c705ac08d WHIRLPOOL b4bcf058bcc582627be35bb8ba45a933c3814f007599df59172e537fc99003f51edac7011cf36783caad4e191c622f6fa044a6ff6e0ae3f4de7635c3815807a3
+DIST gtk+-2.24.26.tar.xz 13328708 SHA256 d84fc0f1e3cd99e8b9ec756e754f42653940638579a8f28d0eabffc37018d133 SHA512 2a3a366c41214fcacbc2a69719d5b20060e0efbb0576a1fc4f4123f97ea1f5ff1b06296302806655b32c06901629f5d23b91d65de9a01143053f63607d94498d WHIRLPOOL b0cf44be24dd1999f2f4aeb6ed779e536cb00c7d1b42cb1a4c8fc9a807093a1b8f26f4f750bb52533ca6a18e6a9ce481f7d879e0c186d7d11add6c793090c244
DIST gtk+-3.14.8.tar.xz 15689624 SHA256 7a543ea8a85f2c8a7b7374f24fd57df454067858689d8b02ec6c90f24be2b344 SHA512 110f39d0a8ef72bfcb02d8e11000210848da15d7232346277f9755c7918e16af39dce78ba409ddfcb73dd5fa9032cc51843cb658d5ce4a2b32ca401624cc5240 WHIRLPOOL 115a043e332119bc3fe582744ceeeb9a49f4361ded13131162c26fc6988f1c2c5281738e992c96580b96ea2bd966377a49f239ec6204d6072a5dbb09d4b0f22f
diff --git a/x11-libs/gtk+/gtk+-2.24.25-r1.ebuild b/x11-libs/gtk+/gtk+-2.24.26.ebuild
index fcbae00..2f231e1 100644
--- a/x11-libs/gtk+/gtk+-2.24.25-r1.ebuild
+++ b/x11-libs/gtk+/gtk+-2.24.26.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.24.25-r1.ebuild,v 1.2 2015/01/19 10:44:02 jer Exp $
+# $Header: $
EAPI="5"
-GCONF_DEBUG="no"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
inherit autotools eutils flag-o-matic gnome2 multilib virtualx readme.gentoo multilib-minimal
@@ -12,12 +13,12 @@ HOMEPAGE="http://www.gtk.org/"
LICENSE="LGPL-2+"
SLOT="2"
-IUSE="aqua cups debug examples gtk3-only +introspection test vim-syntax xinerama"
+IUSE="aqua cups examples gtk3-only +introspection test vim-syntax xinerama"
REQUIRED_USE="
xinerama? ( !aqua )
"
-KEYWORDS="~alpha ~amd64 ~arm hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
COMMON_DEPEND="
@@ -103,20 +104,21 @@ set_gtk2_confdir() {
src_prepare() {
# Fix building due to moved definition, upstream bug #704766
- epatch "${FILESDIR}"/${PN}-2.24.20-darwin-quartz-pasteboard.patch
+ # Upstream says it was fixed with a different commit
+# epatch "${FILESDIR}"/${PN}-2.24.20-darwin-quartz-pasteboard.patch
- # Fix tests running when building out of sources, bug #510596
+ # Fix tests running when building out of sources, bug #510596, upstream bug #730319
epatch "${FILESDIR}"/${PN}-2.24.24-out-of-source.patch
- # marshalers code was pre-generated with glib-2.31, upstream bug #671763
+ # marshalers code was pre-generated with glib-2.31, upstream bug #662109
rm -v gdk/gdkmarshalers.c gtk/gtkmarshal.c gtk/gtkmarshalers.c \
perf/marshalers.c || die
- # Stop trying to build unmaintained docs, bug #349754
+ # Stop trying to build unmaintained docs, bug #349754, upstream bug #623150
strip_builddir SUBDIRS tutorial docs/Makefile.{am,in}
strip_builddir SUBDIRS faq docs/Makefile.{am,in}
- # -O3 and company cause random crashes in applications. Bug #133469
+ # -O3 and company cause random crashes in applications, bug #133469
replace-flags -O3 -O2
strip-flags
@@ -141,8 +143,8 @@ src_prepare() {
# Skip tests known to fail
# https://bugzilla.gnome.org/show_bug.cgi?id=646609
- sed -e '/g_test_add_func.*test_text_access/s:^://:' \
- -i "${S}/gtk/tests/testing.c" || die
+# sed -e '/g_test_add_func.*test_text_access/s:^://:' \
+# -i "${S}/gtk/tests/testing.c" || die
# https://bugzilla.gnome.org/show_bug.cgi?id=617473
sed -i -e 's:pltcheck.sh:$(NULL):g' \
@@ -172,12 +174,10 @@ src_prepare() {
multilib_src_configure() {
[[ ${ABI} == ppc64 ]] && append-flags -mminimal-toc
- # Passing --disable-debug is not recommended for production use
ECONF_SOURCE=${S} \
gnome2_src_configure \
$(usex aqua --with-gdktarget=quartz --with-gdktarget=x11) \
$(usex aqua "" --with-xinput) \
- $(usex debug --enable-debug=yes "") \
$(use_enable cups cups auto) \
$(multilib_native_use_enable introspection) \
$(use_enable xinerama) \