summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2015-02-14 19:30:30 +0200
committerMart Raudsepp <leio@gentoo.org>2015-02-14 19:41:41 +0200
commit0bcd80b60e54640ec532225190dc1777de7051d8 (patch)
treecd5b2175cfde80680258a18396d438dd6e6aa9b9
parentraspberrypi-userland: Add missing wayland and pkgconfig deps from the wayland... (diff)
downloadleio-0bcd80b60e54640ec532225190dc1777de7051d8.tar.gz
leio-0bcd80b60e54640ec532225190dc1777de7051d8.tar.bz2
leio-0bcd80b60e54640ec532225190dc1777de7051d8.zip
raspberrypi-userland: Bump to latest snapshot for RPi2 ARMv7 support
Also remove useless CMAKE_TOOLCHAIN_FILE defining - eclass supposedly overrides that anyways. Build fails with as-needed, though due to mmal_util linkage issues. Temporarily filter it out.
-rw-r--r--media-libs/raspberrypi-userland/Manifest2
-rw-r--r--media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20150214.ebuild (renamed from media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20140830.ebuild)8
2 files changed, 6 insertions, 4 deletions
diff --git a/media-libs/raspberrypi-userland/Manifest b/media-libs/raspberrypi-userland/Manifest
index fce3d60..de9ea72 100644
--- a/media-libs/raspberrypi-userland/Manifest
+++ b/media-libs/raspberrypi-userland/Manifest
@@ -1 +1 @@
-DIST raspberrypi-userland-0_pre20140830.tar.xz 32066536 SHA256 f9a06d2ca7d41cdc700b83eeb7c3e06d3ea6bd3fd187880a563144a6bf6ee901 SHA512 775005177e760fff611d7ce7e4beb466ea111dfc4652b97593d1061b97b1ded32979f8666a0aada6338791abab988883bbfd902f267eba5734e8aa932ebcf487 WHIRLPOOL 3066272a88b868ef20f27614f6f680aa6eb8a43cd2e281a7a930b99be341b037fa843a1c36bfdc6be619544e5b4b8751e5ab58c853b1baff44894b39284bfa55
+DIST raspberrypi-userland-0_pre20150214.tar.xz 32389924 SHA256 1731d41d392129da67dd7e3d9a77ef2b500b6e99b490a981a5a739261c91fade SHA512 5491150d6ba7b3b008304877bd3e5e32641e89ec7a43334b9d652391b3a73a67381934edfecf06642ffd0b1a488a7da2424c5efc21f3f664516fec6881d548fd WHIRLPOOL a426365d5f530ecb43bad4fba5eb2edd7b932917fe985f2575b578b17018a58cb8af47c56124397cbc2ed6e6920f23a17b09f72a44b42beb5964bb3df02aea7f
diff --git a/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20140830.ebuild b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20150214.ebuild
index 7482032..2e66015 100644
--- a/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20140830.ebuild
+++ b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20150214.ebuild
@@ -51,9 +51,11 @@ src_prepare() {
}
src_configure() {
- # toolchain file not needed, but build fails if it is not specified
- local mycmakeargs=(-DCMAKE_TOOLCHAIN_FILE=/dev/null
- $(cmake-utils_use_build wayland WAYLAND))
+ # FIXME: Fails to link apps using libmmal.so, due to libmmal_util getting filtered out and apps not linking to it
+ append-ldflags $(no-as-needed)
+ local mycmakeargs=(
+ $(cmake-utils_use_build wayland WAYLAND)
+ )
cmake-utils_src_configure
}