summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2016-03-18 01:00:25 +0200
committerMart Raudsepp <leio@gentoo.org>2016-03-18 01:00:25 +0200
commit10bd941351ccb13cb6ed91161c47a2595d43d9a2 (patch)
tree0aed7aeab304075ef3b52a3610d5375f93d9a476
parentgtk+:2 - bump and sync with main tree (diff)
downloadleio-10bd941351ccb13cb6ed91161c47a2595d43d9a2.tar.gz
leio-10bd941351ccb13cb6ed91161c47a2595d43d9a2.tar.bz2
leio-10bd941351ccb13cb6ed91161c47a2595d43d9a2.zip
cogl/clutter: Remove until sync with main tree is done
Old versions are inheriting old clutter.eclass from main tree, which has since been deprecated and deleted. These modification might be unnecessary anyways in a VC4 mesa driver world future. Gentoo-Bug: 574524
-rw-r--r--media-libs/clutter/Manifest1
-rw-r--r--media-libs/clutter/clutter-1.18.2.ebuild105
-rw-r--r--media-libs/clutter/metadata.xml8
-rw-r--r--media-libs/cogl/Manifest1
-rw-r--r--media-libs/cogl/cogl-1.18.2.ebuild119
-rw-r--r--media-libs/cogl/metadata.xml10
6 files changed, 0 insertions, 244 deletions
diff --git a/media-libs/clutter/Manifest b/media-libs/clutter/Manifest
deleted file mode 100644
index a213031..0000000
--- a/media-libs/clutter/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST clutter-1.18.2.tar.xz 5215180 SHA256 f9fe12e6148426063c90e67dfaeb56013bf1aea224ef502223d13eab6c1add63 SHA512 d7cf0d523dfd95f62910376d3958d50b9fd0debee0fd2e0c7c284500c78b5899fb0bb30dd279c638b4bc1cefaf63af376328f5e1c476d38c34ce4a79bd772b18 WHIRLPOOL e52c97e7c429b2a428e3749e8a6cafb2c9e5174a8437cd1f427b5c24c9df91f911a7ce76614d5131f6e6028504d5b23bf70ccf8b3e9b63a90af5a87329366f19
diff --git a/media-libs/clutter/clutter-1.18.2.ebuild b/media-libs/clutter/clutter-1.18.2.ebuild
deleted file mode 100644
index 4a15fb0..0000000
--- a/media-libs/clutter/clutter-1.18.2.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-CLUTTER_LA_PUNT="yes"
-
-# Inherit gnome2 after clutter to download sources from gnome.org
-# since clutter-project.org doesn't provide .xz tarballs
-inherit clutter gnome2 virtualx
-
-DESCRIPTION="Clutter is a library for creating graphical user interfaces"
-
-LICENSE="LGPL-2.1+ FDL-1.1+"
-SLOT="1.0"
-IUSE="debug doc egl gtk +introspection test X" # evdev tslib
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-
-# NOTE: glx flavour uses libdrm + >=mesa-7.3
-# XXX: uprof needed for profiling
-# >=libX11-1.3.1 needed for X Generic Event support
-# XXX: evdev input requires libinput and gudev >= 136
-# XXX: Probably require one of USE=X or USE=egl
-RDEPEND="
- >=dev-libs/glib-2.37.3:2
- >=dev-libs/atk-2.5.3[introspection?]
- >=dev-libs/json-glib-0.12[introspection?]
- >=media-libs/cogl-1.17.5:1.0=[introspection?,pango]
- media-libs/fontconfig
- >=x11-libs/cairo-1.12:=[glib]
- >=x11-libs/pango-1.30[introspection?]
-
- X? (
- virtual/opengl
- x11-libs/libdrm:=
- >=x11-libs/libX11-1.3.1
- x11-libs/libXext
- x11-libs/libXdamage
- x11-proto/inputproto
- >=x11-libs/libXi-1.3
- >=x11-libs/libXcomposite-0.4
- )
-
- gtk? ( >=x11-libs/gtk+-3.3.18:3 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.20
- virtual/pkgconfig
- >=sys-devel/gettext-0.17
- doc? (
- >=dev-util/gtk-doc-1.20
- >=app-text/docbook-sgml-utils-0.6.14[jadetex]
- dev-libs/libxslt )
- test? ( x11-libs/gdk-pixbuf )"
-
-# Tests fail with both swrast and llvmpipe
-# They pass under r600g or i965, so the bug is in mesa
-#RESTRICT="test"
-
-src_prepare() {
- # We only need conformance tests, the rest are useless for us
- sed -e 's/^\(SUBDIRS =\).*/\1 accessibility conform/g' \
- -i tests/Makefile.am || die "am tests sed failed"
- sed -e 's/^\(SUBDIRS =\)[^\]*/\1 accessibility conform/g' \
- -i tests/Makefile.in || die "in tests sed failed"
-
- gnome2_src_prepare
-}
-
-src_configure() {
- DOCS="README NEWS ChangeLog*"
-
- # XXX: Conformance test suite (and clutter itself) does not work under Xvfb
- # (GLX error blabla)
- # XXX: Profiling, coverage disabled for now
- # XXX: What about cex100/egl/osx/wayland/win32 backends?
- # XXX: evdev/tslib input seem to be experimental?
- gnome2_src_configure \
- $(usex X --enable-xinput) \
- $(usex X --enable-x11-backend=yes) \
- --disable-profile \
- --disable-maintainer-flags \
- --disable-gcov \
- --disable-cex100-backend \
- $(usex egl --enable-egl-backend --disable-egl-backend) \
- --disable-quartz-backend \
- --disable-wayland-backend \
- --disable-win32-backend \
- --disable-tslib-input \
- --disable-evdev-input \
- $(usex debug --enable-debug=yes --enable-debug=minimum) \
- $(use_enable doc docs) \
- $(use_enable gtk gdk-backend) \
- $(use_enable introspection) \
- $(use_enable test gdk-pixbuf)
-}
-
-src_test() {
- Xemake check -C tests/conform
-}
-
-src_install() {
- clutter_src_install
-}
diff --git a/media-libs/clutter/metadata.xml b/media-libs/clutter/metadata.xml
deleted file mode 100644
index 0291170..0000000
--- a/media-libs/clutter/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>gnome</herd>
- <use>
- <flag name="gtk">Use gdk-pixbuf from <pkg>x11-libs/gtk+</pkg> as image rendering backend</flag>
- </use>
-</pkgmetadata>
diff --git a/media-libs/cogl/Manifest b/media-libs/cogl/Manifest
deleted file mode 100644
index 5e289d7..0000000
--- a/media-libs/cogl/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST cogl-1.18.2.tar.xz 1635384 SHA256 9278e519d5480eb0379efd48db024e8fdbf93f01dff48a7e756b85b508a863aa SHA512 c8903a10c476850c77f71eba584854bccf26adae6f62a9232adf8baf728fe2b69273bd5cd5418e7cd72801a2c0e4c85ef8afc08e28ebd5016b81693aef2ecab8 WHIRLPOOL e7538b92af2efe2f3845fde5c97ba9744d53ddb7a05eadb3cf310c43a3536a41001e4a0596a593ae3cfede4a02115a1d9be8aa423e9c814675059f0f777ec4a5
diff --git a/media-libs/cogl/cogl-1.18.2.ebuild b/media-libs/cogl/cogl-1.18.2.ebuild
deleted file mode 100644
index 4e5fe81..0000000
--- a/media-libs/cogl/cogl-1.18.2.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-CLUTTER_LA_PUNT="yes"
-
-# Inherit gnome2 after clutter to download sources from gnome.org
-inherit clutter gnome2 multilib virtualx
-
-DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
-HOMEPAGE="http://www.cogl3d.org/"
-
-LICENSE="MIT BSD"
-SLOT="1.0/20" # subslot = .so version
-# doc and profile disable for now due bugs #484750 and #483332
-IUSE="examples gles2 gstreamer +introspection +opengl +pango rpi test" # doc profile
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.32:2
- x11-libs/cairo:=
- >=x11-libs/gdk-pixbuf-2:2
- x11-libs/libdrm:=
- x11-libs/libX11
- >=x11-libs/libXcomposite-0.4
- x11-libs/libXdamage
- x11-libs/libXext
- >=x11-libs/libXfixes-3
- >=x11-libs/libXrandr-1.2
- opengl? ( virtual/opengl )
- gles2? ( || ( rpi? ( media-libs/raspberrypi-userland ) media-libs/mesa[gles2] ) )
- gstreamer? (
- media-libs/gstreamer:1.0
- media-libs/gst-plugins-base:1.0 )
-
- introspection? ( >=dev-libs/gobject-introspection-1.34.2 )
- pango? ( >=x11-libs/pango-1.20.0[introspection?] )
-"
-# before clutter-1.7, cogl was part of clutter
-RDEPEND="${COMMON_DEPEND}
- !<media-libs/clutter-1.7"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/gtk-doc-am-1.13
- sys-devel/gettext
- virtual/pkgconfig
- test? (
- app-admin/eselect-opengl
- media-libs/mesa[classic] )
-"
-
-# Need classic mesa swrast for tests, llvmpipe causes a test failure
-# Fox some reason GL3 conformance test all fails again...
-RESTRICT="test"
-
-src_prepare() {
- # Do not build examples
- sed -e "s/^\(SUBDIRS +=.*\)examples\(.*\)$/\1\2/" \
- -i Makefile.am Makefile.in || die
-
- if ! use test ; then
- # For some reason the configure switch will not completely disable
- # tests being built
- sed -e "s/^\(SUBDIRS =.*\)test-fixtures\(.*\)$/\1\2/" \
- -e "s/^\(SUBDIRS +=.*\)tests\(.*\)$/\1\2/" \
- -e "s/^\(.*am__append.* \)tests\(.*\)$/\1\2/" \
- -i Makefile.am Makefile.in || die
- fi
-
- gnome2_src_prepare
-}
-
-src_configure() {
- # TODO: think about kms-egl, quartz, sdl, wayland
- # Prefer gl over gles2 if both are selected
- # Profiling needs uprof, which is not available in portage yet, bug #484750
- # FIXME: Doesn't provide prebuilt docs, but they can neither be rebuilt, bug #483332
- gnome2_src_configure \
- --disable-examples-install \
- --disable-maintainer-flags \
- --enable-cairo \
- --enable-deprecated \
- --enable-gdk-pixbuf \
- --enable-glib \
- $(use_enable opengl glx) \
- $(use_enable opengl gl) \
- $(use_enable gles2) \
- $(use_enable gles2 cogl-gles2) \
- $(use_enable gles2 xlib-egl-platform) \
- $(usex gles2 --with-default-driver=$(usex opengl gl gles2)) \
- $(use_enable gstreamer cogl-gst) \
- $(use_enable introspection) \
- $(use_enable pango cogl-pango) \
- $(use_enable test unit-tests) \
- --disable-profile
-# $(use_enable profile)
-}
-
-src_test() {
- # Use swrast for tests, llvmpipe is incomplete and "test_sub_texture" fails
- # NOTE: recheck if this is needed after every mesa bump
- if [[ "$(eselect opengl show)" != "xorg-x11" ]]; then
- ewarn "Skipping tests because a binary OpenGL library is enabled. To"
- ewarn "run tests for ${PN}, you need to enable the Mesa library:"
- ewarn "# eselect opengl set xorg-x11"
- return
- fi
- LIBGL_DRIVERS_PATH="${EROOT}/usr/$(get_libdir)/mesa" Xemake check
-}
-
-src_install() {
- DOCS="NEWS README"
- EXAMPLES="examples/{*.c,*.jpg}"
-
- clutter_src_install
-
- # Remove silly examples-data directory
- rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
-}
diff --git a/media-libs/cogl/metadata.xml b/media-libs/cogl/metadata.xml
deleted file mode 100644
index 8ba9687..0000000
--- a/media-libs/cogl/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>gnome</herd>
-<use>
- <flag name="gles2">Enable OpenGL ES 2.0 support</flag>
- <flag name="pango">Build cogl-pango library for <pkg>x11-libs/pango</pkg>
- integration</flag>
-</use>
-</pkgmetadata>