summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2014-11-25 15:58:49 +0200
committerMart Raudsepp <leio@gentoo.org>2014-11-25 15:58:49 +0200
commit62bbc5c406962a53e4530aff9327e0f26bdf5600 (patch)
treee810fbaea7c14827c7b351992daadf14ee75eb3f
parentraspberrypi-userland: Update to 20140830 snapshot as found p.masked in portage (diff)
downloadleio-62bbc5c406962a53e4530aff9327e0f26bdf5600.tar.gz
leio-62bbc5c406962a53e4530aff9327e0f26bdf5600.tar.bz2
leio-62bbc5c406962a53e4530aff9327e0f26bdf5600.zip
Bump to gtk+-3.14.5 for xdg-shell protocol version compat with weston-1.6
This also adds glib and gdbus-codegen, together with gtk+ from gnome overlay (gtk+ having the usual RPi/gtk3-only mods on top). gtk+-3.12 is xdg-shell protocol version 3, but weston-1.6 is version 4, so they can't talk to eachother. gtk+-3.14 talks the same language.
-rw-r--r--dev-libs/glib/Manifest12
-rw-r--r--dev-libs/glib/files/glib-2.12.12-fbsd.patch35
-rw-r--r--dev-libs/glib/files/glib-2.34.0-testsuite-skip-thread4.patch44
-rw-r--r--dev-libs/glib/files/glib-2.40.0-external-gdbus-codegen.patch95
-rw-r--r--dev-libs/glib/glib-2.42.1.ebuild273
-rw-r--r--dev-libs/glib/metadata.xml11
-rw-r--r--dev-util/gdbus-codegen/Manifest11
-rw-r--r--dev-util/gdbus-codegen/files/gdbus-codegen-2.40.0-sitedir.patch31
-rw-r--r--dev-util/gdbus-codegen/files/setup.py-2.32.46
-rw-r--r--dev-util/gdbus-codegen/gdbus-codegen-2.42.1.ebuild49
-rw-r--r--dev-util/gdbus-codegen/metadata.xml5
-rw-r--r--x11-libs/gtk+/files/gtk+-3.12.2-darwin10.6.patch39
-rw-r--r--x11-libs/gtk+/gtk+-3.14.5.ebuild (renamed from x11-libs/gtk+/gtk+-3.12.2-r1.ebuild)19
13 files changed, 578 insertions, 52 deletions
diff --git a/dev-libs/glib/Manifest b/dev-libs/glib/Manifest
new file mode 100644
index 0000000..68bbfcd
--- /dev/null
+++ b/dev-libs/glib/Manifest
@@ -0,0 +1,12 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST glib-2.42.1.tar.xz 6985120 SHA256 8f3f0865280e45b8ce840e176ef83bcfd511148918cc8d39df2ee89b67dcf89a SHA512 0d273e3e24f164f16f6663f88866ae412714eab7d15c1901fdef61f13649a08f9962e49f9d52e8a1683100f9c2dcc468b9a5bf8a9b3d6ca7b0d9488bc58f3f1e WHIRLPOOL 5cf0dbce9890a61210f0c1c0b43a6147bfff107ee8d37de959fc533b56fa9e253d74996ed3ad05b2d756aecf65c1bd8cb1faaaa50096304df2b2f09d05b28804
+DIST pkg-config-0.28.tar.gz 1931203 SHA256 6b6eb31c6ec4421174578652c7e141fdaae2dabad1021f420d8713206ac1f845 SHA512 6eafa5ca77c5d44cd15f48457a5e96fcea2555b66d8e35ada5ab59864a0aa03d441e15f54ab9c6343693867b3b490f392c75b7d9312f024c9b7ec6a0194d8320 WHIRLPOOL db4ddb4ce61724e629931c5ffccb4d7a551b4dc0f4efed5a966822307e4b5a786adee5705dd80ec0a9aa32cb1af9ad9615e307360e131fc34688207216161486
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREKAAYFAlRzhpkACgkQ1fmVwcYIWAbuegCeI73HtrQ6Wii2J36KfkeFLU8I
+1pQAoOKkOmcG0NmUXeF1HmdeUBhunYdv
+=Q8Gw
+-----END PGP SIGNATURE-----
diff --git a/dev-libs/glib/files/glib-2.12.12-fbsd.patch b/dev-libs/glib/files/glib-2.12.12-fbsd.patch
new file mode 100644
index 0000000..5aca695
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.12.12-fbsd.patch
@@ -0,0 +1,35 @@
+From deeb71226d4ab465d48805d899ec88eb836a6966 Mon Sep 17 00:00:00 2001
+From: Daniel Gryniewicz <dang@gentoo.org>
+Date: Sun, 24 Nov 2013 19:46:13 +0100
+Subject: [PATCH 1/4] Fix gmodule issue on FreeBSD
+
+Gentoo bug #184301, Gnome bug #107626.
+---
+ gmodule/gmodule-dl.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/gmodule/gmodule-dl.c b/gmodule/gmodule-dl.c
+index a606f17..57fc41b 100644
+--- a/gmodule/gmodule-dl.c
++++ b/gmodule/gmodule-dl.c
+@@ -107,6 +107,7 @@ _g_module_open (const gchar *file_name,
+ static gpointer
+ _g_module_self (void)
+ {
++#ifndef __FreeBSD__
+ gpointer handle;
+
+ /* to query symbols from the program itself, special link options
+@@ -122,6 +123,9 @@ _g_module_self (void)
+ g_module_set_error (fetch_dlerror (TRUE));
+
+ return handle;
++#else
++ return RTLD_DEFAULT;
++#endif
+ }
+
+ static void
+--
+1.8.3.2
+
diff --git a/dev-libs/glib/files/glib-2.34.0-testsuite-skip-thread4.patch b/dev-libs/glib/files/glib-2.34.0-testsuite-skip-thread4.patch
new file mode 100644
index 0000000..584b56f
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.34.0-testsuite-skip-thread4.patch
@@ -0,0 +1,44 @@
+From 4881b5d303512208b55f5bf78b91cd6a85e5034c Mon Sep 17 00:00:00 2001
+From: Priit Laes <plaes@plaes.org>
+Date: Tue, 3 Jul 2012 11:21:56 +0300
+Subject: [PATCH 2/4] Gentoo: skip over thread/thread4 test failure
+
+https://bugzilla.gnome.org/show_bug.cgi?id=679306
+---
+ glib/tests/thread.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/glib/tests/thread.c b/glib/tests/thread.c
+index 539782e..179ec06 100644
+--- a/glib/tests/thread.c
++++ b/glib/tests/thread.c
+@@ -124,6 +124,8 @@ test_thread3 (void)
+ g_assert_cmpint (GPOINTER_TO_INT(result), ==, 9);
+ }
+
++#if 0
++// https://bugzilla.gnome.org/show_bug.cgi?id=679306
+ /* test that thread creation fails as expected,
+ * by setting RLIMIT_NPROC ridiculously low
+ */
+@@ -158,6 +160,7 @@ test_thread4 (void)
+ g_error ("resetting RLIMIT_NPROC failed: %s\n", g_strerror (ret));
+ #endif
+ }
++#endif
+
+ static void
+ test_thread5 (void)
+@@ -203,7 +206,9 @@ main (int argc, char *argv[])
+ g_test_add_func ("/thread/thread1", test_thread1);
+ g_test_add_func ("/thread/thread2", test_thread2);
+ g_test_add_func ("/thread/thread3", test_thread3);
++#if 0
+ g_test_add_func ("/thread/thread4", test_thread4);
++#endif
+ g_test_add_func ("/thread/thread5", test_thread5);
+ g_test_add_func ("/thread/thread6", test_thread6);
+
+--
+1.8.3.2
+
diff --git a/dev-libs/glib/files/glib-2.40.0-external-gdbus-codegen.patch b/dev-libs/glib/files/glib-2.40.0-external-gdbus-codegen.patch
new file mode 100644
index 0000000..50a9370
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.40.0-external-gdbus-codegen.patch
@@ -0,0 +1,95 @@
+diff --git a/configure.ac b/configure.ac
+index a01e58d..59d4527 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -367,14 +367,14 @@ AC_SUBST(PERL_PATH)
+ # option to specify python interpreter to use; this just sets $PYTHON, so that
+ # we will fallback to reading $PYTHON if --with-python is not given, and
+ # python.m4 will get the expected input
+-AC_ARG_WITH(python,
+- AS_HELP_STRING([--with-python=PATH],
+- [Path to Python interpreter; searches $PATH if only a program name is given; if not given, searches for a few standard names such as "python3" or "python2"]),
+- [PYTHON="$withval"], [])
+-if test x"$PYTHON" = xyes; then
+- AC_MSG_ERROR([--with-python option requires a path or program argument])
+-fi
+-AM_PATH_PYTHON(2.5,,PYTHON="/usr/bin/env python2.5")
++# AC_ARG_WITH(python,
++# AS_HELP_STRING([--with-python=PATH],
++# [Path to Python interpreter; searches $PATH if only a program name is given; if not given, searches for a few standard names such as "python3" or "python2"]),
++# [PYTHON="$withval"], [])
++# if test x"$PYTHON" = xyes; then
++# AC_MSG_ERROR([--with-python option requires a path or program argument])
++# fi
++# AM_PATH_PYTHON(2.5,,PYTHON="/usr/bin/env python2.5")
+
+
+ dnl ***********************
+@@ -3580,7 +3580,6 @@ gobject/glib-mkenums
+ gobject/tests/Makefile
+ gthread/Makefile
+ gio/Makefile
+-gio/gdbus-2.0/codegen/Makefile
+ gio/gdbus-2.0/codegen/config.py
+ gio/gnetworking.h
+ gio/xdgmime/Makefile
+diff --git a/docs/reference/gio/Makefile.am b/docs/reference/gio/Makefile.am
+index 47fdd38..c7eb136 100644
+--- a/docs/reference/gio/Makefile.am
++++ b/docs/reference/gio/Makefile.am
+@@ -157,8 +157,7 @@ man_MANS += \
+ glib-compile-resources.1 \
+ gsettings.1 \
+ gresource.1 \
+- gdbus.1 \
+- gdbus-codegen.1
++ gdbus.1
+
+ XSLTPROC_FLAGS = \
+ --nonet \
+diff --git a/gio/Makefile.am b/gio/Makefile.am
+index e993e2f..025ad94 100644
+--- a/gio/Makefile.am
++++ b/gio/Makefile.am
+@@ -1,6 +1,6 @@
+ include $(top_srcdir)/glib.mk
+
+-SUBDIRS = gdbus-2.0/codegen
++SUBDIRS =
+
+ if OS_UNIX
+ SUBDIRS += xdgmime
+diff --git a/gio/tests/Makefile.am b/gio/tests/Makefile.am
+index 2c54e59..3cd3c5a 100644
+--- a/gio/tests/Makefile.am
++++ b/gio/tests/Makefile.am
+@@ -437,10 +437,8 @@ gnotification_SOURCES = $(gdbus_sessionbus_sources) gnotifica
+
+ BUILT_SOURCES += gdbus-test-codegen-generated.c gdbus-test-codegen-generated.h
+ gdbus-test-codegen.o: gdbus-test-codegen-generated.h
+-gdbus-test-codegen-generated.h: test-codegen.xml Makefile $(top_builddir)/gio/gdbus-2.0/codegen/gdbus-codegen
+- $(AM_V_GEN) UNINSTALLED_GLIB_SRCDIR=$(top_srcdir) \
+- UNINSTALLED_GLIB_BUILDDIR=$(top_builddir) \
+- $(PYTHON) $(top_builddir)/gio/gdbus-2.0/codegen/gdbus-codegen \
++gdbus-test-codegen-generated.h: test-codegen.xml Makefile
++ $(AM_V_GEN) gdbus-codegen \
+ --interface-prefix org.project. \
+ --generate-c-code gdbus-test-codegen-generated \
+ --c-generate-object-manager \
+diff --git a/gio/tests/gdbus-object-manager-example/Makefile.am b/gio/tests/gdbus-object-manager-example/Makefile.am
+index d6d1412..62ef706 100644
+--- a/gio/tests/gdbus-object-manager-example/Makefile.am
++++ b/gio/tests/gdbus-object-manager-example/Makefile.am
+@@ -11,10 +11,8 @@ GDBUS_GENERATED = \
+ gdbus-example-objectmanager-generated-org.gtk.GDBus.Example.ObjectManager.Cat.xml \
+ $(NULL)
+
+-$(GDBUS_GENERATED) : gdbus-example-objectmanager.xml Makefile $(top_builddir)/gio/gdbus-2.0/codegen/gdbus-codegen
+- $(AM_V_GEN) UNINSTALLED_GLIB_SRCDIR=$(top_srcdir) \
+- UNINSTALLED_GLIB_BUILDDIR=$(top_builddir) \
+- $(PYTHON) $(top_builddir)/gio/gdbus-2.0/codegen/gdbus-codegen \
++$(GDBUS_GENERATED) : gdbus-example-objectmanager.xml Makefile
++ $(AM_V_GEN) gdbus-codegen \
+ --interface-prefix org.gtk.GDBus.Example.ObjectManager. \
+ --c-namespace Example \
+ --c-generate-object-manager \
diff --git a/dev-libs/glib/glib-2.42.1.ebuild b/dev-libs/glib/glib-2.42.1.ebuild
new file mode 100644
index 0000000..fbaa8d3
--- /dev/null
+++ b/dev-libs/glib/glib-2.42.1.ebuild
@@ -0,0 +1,273 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_{6,7} )
+# Building with --disable-debug highly unrecommended. It will build glib in
+# an unusable form as it disables some commonly used API. Please do not
+# convert this to the use_enable form, as it results in a broken build.
+GCONF_DEBUG="yes"
+# Completely useless with or without USE static-libs, people need to use
+# pkg-config
+GNOME2_LA_PUNT="yes"
+
+inherit autotools bash-completion-r1 gnome2 libtool eutils flag-o-matic multilib \
+ pax-utils python-r1 toolchain-funcs versionator virtualx linux-info multilib-minimal
+
+DESCRIPTION="The GLib library of C routines"
+HOMEPAGE="http://www.gtk.org/"
+SRC_URI="${SRC_URI}
+ http://pkgconfig.freedesktop.org/releases/pkg-config-0.28.tar.gz" # pkg.m4 for eautoreconf
+
+LICENSE="LGPL-2+"
+SLOT="2"
+IUSE="fam kernel_linux +mime selinux static-libs systemtap test utils xattr"
+REQUIRED_USE="
+ utils? ( ${PYTHON_REQUIRED_USE} )
+ test? ( ${PYTHON_REQUIRED_USE} )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+
+RDEPEND="
+ !<dev-util/gdbus-codegen-${PV}
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ >=virtual/libffi-3.0.13-r1[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ || (
+ >=dev-libs/elfutils-0.142
+ >=dev-libs/libelf-0.8.12
+ >=sys-freebsd/freebsd-lib-9.2_rc1
+ )
+ selinux? ( >=sys-libs/libselinux-2.2.2-r5[${MULTILIB_USEDEP}] )
+ xattr? ( >=sys-apps/attr-2.4.47-r1[${MULTILIB_USEDEP}] )
+ fam? ( >=virtual/fam-0-r1[${MULTILIB_USEDEP}] )
+ utils? (
+ ${PYTHON_DEPS}
+ >=dev-util/gdbus-codegen-${PV}[${PYTHON_USEDEP}] )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20130224-r9
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-libs/libxslt-1.0
+ >=sys-devel/gettext-0.11
+ >=dev-util/gtk-doc-am-1.20
+ systemtap? ( >=dev-util/systemtap-1.3 )
+ test? (
+ sys-devel/gdb
+ ${PYTHON_DEPS}
+ >=dev-util/gdbus-codegen-${PV}[${PYTHON_USEDEP}]
+ >=sys-apps/dbus-1.2.14 )
+ !<dev-util/gtk-doc-1.15-r2
+"
+# gobject-introspection blocker to ensure people don't mix
+# different g-i and glib major versions
+
+PDEPEND="!<gnome-base/gvfs-1.6.4-r990
+ mime? ( x11-misc/shared-mime-info )
+"
+# shared-mime-info needed for gio/xdgmime, bug #409481
+# Earlier versions of gvfs do not work with glib
+
+pkg_setup() {
+ if use kernel_linux ; then
+ CONFIG_CHECK="~INOTIFY_USER"
+ if use test; then
+ CONFIG_CHECK="~IPV6"
+ WARNING_IPV6="Your kernel needs IPV6 support for running some tests, skipping them."
+ export IPV6_DISABLED="yes"
+ fi
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Prevent build failure in stage3 where pkgconfig is not available, bug #481056
+ mv -f "${WORKDIR}"/pkg-config-*/pkg.m4 "${S}"/m4macros/ || die
+
+ # Fix gmodule issues on fbsd; bug #184301, upstream bug #107626
+ # Upstream doesn't even know if this is needed, looks like openBSD
+ # people is not needing it
+ #epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
+
+ if use test; then
+ # Do not try to remove files on live filesystem, upstream bug #619274
+ sed 's:^\(.*"/desktop-app-info/delete".*\):/*\1*/:' \
+ -i "${S}"/gio/tests/desktop-app-info.c || die "sed failed"
+
+ # Disable tests requiring dev-util/desktop-file-utils when not installed, bug #286629, upstream bug #629163
+ if ! has_version dev-util/desktop-file-utils ; then
+ ewarn "Some tests will be skipped due dev-util/desktop-file-utils not being present on your system,"
+ ewarn "think on installing it to get these tests run."
+ sed -i -e "/appinfo\/associations/d" gio/tests/appinfo.c || die
+ sed -i -e "/desktop-app-info\/default/d" gio/tests/desktop-app-info.c || die
+ sed -i -e "/desktop-app-info\/fallback/d" gio/tests/desktop-app-info.c || die
+ sed -i -e "/desktop-app-info\/lastused/d" gio/tests/desktop-app-info.c || die
+ fi
+
+ # gdesktopappinfo requires existing terminal (gnome-terminal or any
+ # other), falling back to xterm if one doesn't exist
+ if ! has_version x11-terms/xterm && ! has_version x11-terms/gnome-terminal ; then
+ ewarn "Some tests will be skipped due to missing terminal program"
+ sed -i -e "/appinfo\/launch/d" gio/tests/appinfo.c || die
+ fi
+
+ # Disable tests requiring dbus-python and pygobject; bugs #349236, #377549, #384853
+ if ! has_version dev-python/dbus-python || ! has_version 'dev-python/pygobject:3' ; then
+ ewarn "Some tests will be skipped due to dev-python/dbus-python or dev-python/pygobject:3"
+ ewarn "not being present on your system, think on installing them to get these tests run."
+ sed -i -e "/connection\/filter/d" gio/tests/gdbus-connection.c || die
+ sed -i -e "/connection\/large_message/d" gio/tests/gdbus-connection-slow.c || die
+ sed -i -e "/gdbus\/proxy/d" gio/tests/gdbus-proxy.c || die
+ sed -i -e "/gdbus\/proxy-well-known-name/d" gio/tests/gdbus-proxy-well-known-name.c || die
+ sed -i -e "/gdbus\/introspection-parser/d" gio/tests/gdbus-introspection.c || die
+ sed -i -e "/g_test_add_func/d" gio/tests/gdbus-threading.c || die
+ sed -i -e "/gdbus\/method-calls-in-thread/d" gio/tests/gdbus-threading.c || die
+ # needed to prevent gdbus-threading from asserting
+ ln -sfn $(type -P true) gio/tests/gdbus-testserver.py
+ fi
+
+ # Some tests need ipv6, upstream bug #667468
+ if [[ -n "${IPV6_DISABLED}" ]]; then
+ sed -i -e "/socket\/ipv6_sync/d" gio/tests/socket.c || die
+ sed -i -e "/socket\/ipv6_async/d" gio/tests/socket.c || die
+ sed -i -e "/socket\/ipv6_v4mapped/d" gio/tests/socket.c || die
+ fi
+
+ # Test relies on /usr/bin/true, but we have /bin/true, upstream bug #698655
+ sed -i -e "s:/usr/bin/true:/bin/true:" gio/tests/desktop-app-info.c || die
+
+ # thread test fails, upstream bug #679306
+ epatch "${FILESDIR}/${PN}-2.34.0-testsuite-skip-thread4.patch"
+
+ # This test is prone to fail, bug #504024, upstream bug #723719
+ sed -i -e '/gdbus-close-pending/d' gio/tests/Makefile.am || die
+ else
+ # Don't build tests, also prevents extra deps, bug #512022
+ sed -i -e 's/ tests//' {.,gio,glib}/Makefile.am || die
+ fi
+
+ # gdbus-codegen is a separate package
+ epatch "${FILESDIR}/${PN}-2.40.0-external-gdbus-codegen.patch"
+
+ # leave python shebang alone
+ sed -e '/${PYTHON}/d' \
+ -i glib/Makefile.{am,in} || die
+
+ # Gentoo handles completions in a different directory
+ sed -i "s|^completiondir =.*|completiondir = $(get_bashcompdir)|" \
+ gio/Makefile.am || die
+
+ epatch_user
+
+ # Also needed to prevent cross-compile failures, see bug #267603
+ eautoreconf
+
+ gnome2_src_prepare
+
+ epunt_cxx
+}
+
+multilib_src_configure() {
+ # Avoid circular depend with dev-util/pkgconfig and
+ # native builds (cross-compiles won't need pkg-config
+ # in the target ROOT to work here)
+ if ! tc-is-cross-compiler && ! $(tc-getPKG_CONFIG) --version >& /dev/null; then
+ if has_version sys-apps/dbus; then
+ export DBUS1_CFLAGS="-I/usr/include/dbus-1.0 -I/usr/$(get_libdir)/dbus-1.0/include"
+ export DBUS1_LIBS="-ldbus-1"
+ fi
+ export LIBFFI_CFLAGS="-I$(echo /usr/$(get_libdir)/libffi-*/include)"
+ export LIBFFI_LIBS="-lffi"
+ fi
+
+ local myconf
+
+ case "${CHOST}" in
+ *-mingw*) myconf="${myconf} --with-threads=win32" ;;
+ *) myconf="${myconf} --with-threads=posix" ;;
+ esac
+
+ # Only used by the gresource bin
+ multilib_is_native_abi || myconf="${myconf} --disable-libelf"
+
+ # Always use internal libpcre, bug #254659
+ ECONF_SOURCE="${S}" gnome2_src_configure ${myconf} \
+ $(use_enable xattr) \
+ $(use_enable fam) \
+ $(use_enable selinux) \
+ $(use_enable static-libs static) \
+ $(use_enable systemtap dtrace) \
+ $(use_enable systemtap systemtap) \
+ --disable-compile-warnings \
+ --enable-man \
+ --with-pcre=internal \
+ --with-xml-catalog="${EPREFIX}/etc/xml/catalog"
+
+ if multilib_is_native_abi; then
+ local d
+ for d in glib gio gobject; do
+ ln -s "${S}"/docs/reference/${d}/html docs/reference/${d}/html || die
+ done
+ fi
+}
+
+multilib_src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ export XDG_CONFIG_DIRS=/etc/xdg
+ export XDG_DATA_DIRS=/usr/local/share:/usr/share
+ export G_DBUS_COOKIE_SHA1_KEYRING_DIR="${T}/temp"
+ unset GSETTINGS_BACKEND # bug 352451
+ export LC_TIME=C # bug #411967
+ python_export_best
+
+ # Related test is a bit nitpicking
+ mkdir "$G_DBUS_COOKIE_SHA1_KEYRING_DIR"
+ chmod 0700 "$G_DBUS_COOKIE_SHA1_KEYRING_DIR"
+
+ # Hardened: gdb needs this, bug #338891
+ if host-is-pax ; then
+ pax-mark -mr "${BUILD_DIR}"/tests/.libs/assert-msg-test \
+ || die "Hardened adjustment failed"
+ fi
+
+ # Need X for dbus-launch session X11 initialization
+ Xemake check
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog* NEWS* README"
+ einstalldocs
+
+ if use utils ; then
+ python_replicate_script "${ED}"/usr/bin/gtester-report
+ else
+ rm "${ED}usr/bin/gtester-report"
+ rm "${ED}usr/share/man/man1/gtester-report.1"
+ fi
+
+ # Do not install charset.alias even if generated, leave it to libiconv
+ rm -f "${ED}/usr/lib/charset.alias"
+
+ # Don't install gdb python macros, bug 291328
+ rm -rf "${ED}/usr/share/gdb/" "${ED}/usr/share/glib-2.0/gdb/"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if has_version '<x11-libs/gtk+-3.0.12:3'; then
+ # To have a clear upgrade path for gtk+-3.0.x users, have to resort to
+ # a warning instead of a blocker
+ ewarn
+ ewarn "Using <gtk+-3.0.12:3 with ${P} results in frequent crashes."
+ ewarn "You should upgrade to a newer version of gtk+:3 immediately."
+ fi
+}
diff --git a/dev-libs/glib/metadata.xml b/dev-libs/glib/metadata.xml
new file mode 100644
index 0000000..7224311
--- /dev/null
+++ b/dev-libs/glib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <use>
+ <flag name="systemtap">Build support for profiling and tracing using
+ <pkg>dev-util/systemtap</pkg></flag>
+ <flag name="utils">Install gtester-report utility to generate test
+ report files for your software.</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-util/gdbus-codegen/Manifest b/dev-util/gdbus-codegen/Manifest
new file mode 100644
index 0000000..9a86030
--- /dev/null
+++ b/dev-util/gdbus-codegen/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST glib-2.42.1.tar.xz 6985120 SHA256 8f3f0865280e45b8ce840e176ef83bcfd511148918cc8d39df2ee89b67dcf89a SHA512 0d273e3e24f164f16f6663f88866ae412714eab7d15c1901fdef61f13649a08f9962e49f9d52e8a1683100f9c2dcc468b9a5bf8a9b3d6ca7b0d9488bc58f3f1e WHIRLPOOL 5cf0dbce9890a61210f0c1c0b43a6147bfff107ee8d37de959fc533b56fa9e253d74996ed3ad05b2d756aecf65c1bd8cb1faaaa50096304df2b2f09d05b28804
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREKAAYFAlRzh7IACgkQ1fmVwcYIWAbpVACfV8nHc7lmZC98pfM0LIL7FeJA
+MtkAn1uRdz+8k3q/03taXC6oTEpAV3Mj
+=tTxb
+-----END PGP SIGNATURE-----
diff --git a/dev-util/gdbus-codegen/files/gdbus-codegen-2.40.0-sitedir.patch b/dev-util/gdbus-codegen/files/gdbus-codegen-2.40.0-sitedir.patch
new file mode 100644
index 0000000..ffeb17b
--- /dev/null
+++ b/dev-util/gdbus-codegen/files/gdbus-codegen-2.40.0-sitedir.patch
@@ -0,0 +1,31 @@
+From 626f79dcfb1f26997f2807829c6fa19f6c3303f5 Mon Sep 17 00:00:00 2001
+From: Sobhan Mohammadpour <sobhanmohammadpour1@yahoo.fr>
+Date: Sun, 20 Jan 2013 20:25:13 +0330
+Subject: [PATCH] glib-2.35.4-external-gdbus-codegen
+
+---
+ gio/gdbus-2.0/codegen/gdbus-codegen.in | 8 +-------
+ 1 file changed, 1 insertion(+), 7 deletions(-)
+
+diff --git a/gio/gdbus-2.0/codegen/gdbus-codegen.in b/gio/gdbus-2.0/codegen/gdbus-codegen.in
+index 253d151..2295481 100644
+--- a/gio/gdbus-2.0/codegen/gdbus-codegen.in
++++ b/gio/gdbus-2.0/codegen/gdbus-codegen.in
+@@ -29,13 +29,7 @@ srcdir = os.getenv('UNINSTALLED_GLIB_SRCDIR', None)
+
+ if srcdir is not None:
+ path = os.path.join(srcdir, 'gio', 'gdbus-2.0')
+-elif os.name == 'nt':
+- # Makes gdbus-codegen 'relocatable' at runtime on Windows.
+- path = os.path.join(os.path.dirname(__file__), '..', 'share', 'glib-2.0')
+ else:
+- path = os.path.join('@datadir@', 'glib-2.0')
+-
+-sys.path.insert(0, os.path.abspath(path))
+-from codegen import codegen_main
++ from gdbus_codegen import codegen_main
+
+ sys.exit(codegen_main.codegen_main())
+--
+1.8.1
+
diff --git a/dev-util/gdbus-codegen/files/setup.py-2.32.4 b/dev-util/gdbus-codegen/files/setup.py-2.32.4
new file mode 100644
index 0000000..c5318e3
--- /dev/null
+++ b/dev-util/gdbus-codegen/files/setup.py-2.32.4
@@ -0,0 +1,6 @@
+from distutils.core import setup
+setup(name="gdbus_codegen",
+ version="@PV@",
+ packages=["gdbus_codegen"],
+ package_dir={"gdbus_codegen" : ""},
+ scripts=["gdbus-codegen"])
diff --git a/dev-util/gdbus-codegen/gdbus-codegen-2.42.1.ebuild b/dev-util/gdbus-codegen/gdbus-codegen-2.42.1.ebuild
new file mode 100644
index 0000000..a5b8798
--- /dev/null
+++ b/dev-util/gdbus-codegen/gdbus-codegen-2.42.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GNOME_ORG_MODULE="glib"
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+PYTHON_REQ_USE="xml"
+
+inherit eutils gnome.org distutils-r1
+
+DESCRIPTION="GDBus code and documentation generator"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+# To prevent circular dependencies with glib[test]
+PDEPEND=">=dev-libs/glib-${PV}:2"
+
+S="${WORKDIR}/glib-${PV}/gio/gdbus-2.0/codegen"
+
+python_prepare_all() {
+ PATCHES=(
+ "${FILESDIR}/${PN}-2.40.0-sitedir.patch"
+ )
+ distutils-r1_python_prepare_all
+ sed -e "s:\"/usr/local\":\"${EPREFIX}/usr\":" \
+ -i config.py || die "sed config.py failed"
+
+ sed -e 's:#!@PYTHON@:#!/usr/bin/env python:' gdbus-codegen.in > gdbus-codegen || die
+ cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed"
+ sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed"
+}
+
+src_test() {
+ einfo "Skipping tests. This package is tested by dev-libs/glib"
+ einfo "when merged with FEATURES=test"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all # no-op, but prevents QA warning
+ doman "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1"
+}
diff --git a/dev-util/gdbus-codegen/metadata.xml b/dev-util/gdbus-codegen/metadata.xml
new file mode 100644
index 0000000..6e0e2ec
--- /dev/null
+++ b/dev-util/gdbus-codegen/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+</pkgmetadata>
diff --git a/x11-libs/gtk+/files/gtk+-3.12.2-darwin10.6.patch b/x11-libs/gtk+/files/gtk+-3.12.2-darwin10.6.patch
deleted file mode 100644
index 3955677..0000000
--- a/x11-libs/gtk+/files/gtk+-3.12.2-darwin10.6.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Fix for Mac Os 10.7
-
-src_compile:
-gtkapplication-quartz-menu.c:265: error: incompatible type for argument 1 of 'roundf'
-make[4]: *** [libgtk_3_la-gtkapplication-quartz-menu.lo] Error 1
-
-More info:
-https://trac.macports.org/ticket/43283
-https://bugzilla.gnome.org/show_bug.cgi?id=727366
-https://bugs.gentoo.org/show_bug.cgi?id=519058
-
---- gtk/gtkapplication-quartz-menu.c.orig 2014-05-08 01:40:39.000000000 +0200
-+++ gtk/gtkapplication-quartz-menu.c 2014-05-15 11:16:09.000000000 +0200
-@@ -30,6 +30,16 @@
-
- #import <Cocoa/Cocoa.h>
-
-+#if !defined(MAC_OS_X_VERSION_10_7) || \
-+MAC_OS_X_VERSION_MAX_ALLOWED < MAC_OS_X_VERSION_10_7
-+
-+@interface NSScreen (LionAPI)
-+- (CGFloat)backingScaleFactor;
-+- (NSRect)convertRectToBacking:(NSRect)aRect;
-+@end
-+
-+#endif // 10.7
-+
- #define ICON_SIZE 16
-
- #define BLACK "#000000"
-@@ -262,7 +272,7 @@
- }
-
- theme = gtk_icon_theme_get_default ();
-- scale = roundf ([[NSScreen mainScreen] backingScaleFactor]);
-+ scale = [[NSScreen mainScreen] respondsToSelector:@selector(backingScaleFactor)] ? roundf ([[NSScreen mainScreen] backingScaleFactor]) : 1.;
- info = gtk_icon_theme_lookup_by_gicon_for_scale (theme, icon, ICON_SIZE, scale, GTK_ICON_LOOKUP_USE_BUILTIN);
-
- if (info != NULL)
diff --git a/x11-libs/gtk+/gtk+-3.12.2-r1.ebuild b/x11-libs/gtk+/gtk+-3.14.5.ebuild
index 253acda..074a076 100644
--- a/x11-libs/gtk+/gtk+-3.12.2-r1.ebuild
+++ b/x11-libs/gtk+/gtk+-3.14.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-3.12.2-r1.ebuild,v 1.2 2014/11/24 01:41:45 tetromino Exp $
+# $Header: $
EAPI="5"
GCONF_DEBUG="no"
@@ -30,14 +30,14 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
# Use gtk+:2 for gtk-update-icon-cache unless USE=gtk3-only
COMMON_DEPEND="
- >=dev-libs/atk-2.7.5[introspection?,${MULTILIB_USEDEP}]
- >=dev-libs/glib-2.39.5:2[${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.12[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.41.2:2[${MULTILIB_USEDEP}]
media-libs/fontconfig[${MULTILIB_USEDEP}]
>=x11-libs/cairo-1.12[aqua?,glib,svg,X?,${MULTILIB_USEDEP}]
- >=x11-libs/gdk-pixbuf-2.27.1:2[introspection?,X?,${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.30:2[introspection?,X?,${MULTILIB_USEDEP}]
gtk3-only? ( !x11-libs/gtk+:2 )
!gtk3-only? ( >=x11-libs/gtk+-2.24:2[${MULTILIB_USEDEP}] )
- >=x11-libs/pango-1.32.4[introspection?,${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.36.7[introspection?,${MULTILIB_USEDEP}]
x11-misc/shared-mime-info
cloudprint? (
@@ -47,7 +47,7 @@ COMMON_DEPEND="
cups? ( >=net-print/cups-1.2[${MULTILIB_USEDEP}] )
introspection? ( >=dev-libs/gobject-introspection-1.39 )
wayland? (
- >=dev-libs/wayland-1.3.90[${MULTILIB_USEDEP}]
+ >=dev-libs/wayland-1.5.91[${MULTILIB_USEDEP}]
|| ( media-libs/mesa[wayland,${MULTILIB_USEDEP}] media-libs/raspberrypi-userland[wayland] )
>=x11-libs/libxkbcommon-0.2[${MULTILIB_USEDEP}]
)
@@ -92,10 +92,6 @@ RDEPEND="${COMMON_DEPEND}
!<gnome-base/gail-1000
!<x11-libs/vte-0.31.0:2.90
X? ( !<x11-base/xorg-server-1.11.4 )
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
- !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
- )
"
PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
@@ -117,9 +113,6 @@ src_prepare() {
replace-flags -O3 -O2
strip-flags
- # Build fix on Darwin 10.6; bug #519058
- epatch "${FILESDIR}/${P}-darwin10.6.patch"
-
if ! use test ; then
# don't waste time building tests
strip_builddir SRC_SUBDIRS testsuite Makefile.am