summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2014-07-14 16:38:59 +0300
committerMart Raudsepp <leio@gentoo.org>2014-07-14 16:41:26 +0300
commite1a3dbc17a846637632bf81b4c1b937473e57454 (patch)
treee68188aa31ac0fb7c71190ed1f4b49f85268dcf4
parentAdd media-libs/cogl tweaked to be buildable without mesa on RPi (diff)
downloadleio-e1a3dbc17a846637632bf81b4c1b937473e57454.tar.gz
leio-e1a3dbc17a846637632bf81b4c1b937473e57454.tar.bz2
leio-e1a3dbc17a846637632bf81b4c1b937473e57454.zip
Add media-libs/clutter with EGL support and optional X
-rw-r--r--media-libs/clutter/Manifest1
-rw-r--r--media-libs/clutter/clutter-1.18.2.ebuild105
-rw-r--r--media-libs/clutter/metadata.xml8
3 files changed, 114 insertions, 0 deletions
diff --git a/media-libs/clutter/Manifest b/media-libs/clutter/Manifest
new file mode 100644
index 0000000..a213031
--- /dev/null
+++ b/media-libs/clutter/Manifest
@@ -0,0 +1 @@
+DIST clutter-1.18.2.tar.xz 5215180 SHA256 f9fe12e6148426063c90e67dfaeb56013bf1aea224ef502223d13eab6c1add63 SHA512 d7cf0d523dfd95f62910376d3958d50b9fd0debee0fd2e0c7c284500c78b5899fb0bb30dd279c638b4bc1cefaf63af376328f5e1c476d38c34ce4a79bd772b18 WHIRLPOOL e52c97e7c429b2a428e3749e8a6cafb2c9e5174a8437cd1f427b5c24c9df91f911a7ce76614d5131f6e6028504d5b23bf70ccf8b3e9b63a90af5a87329366f19
diff --git a/media-libs/clutter/clutter-1.18.2.ebuild b/media-libs/clutter/clutter-1.18.2.ebuild
new file mode 100644
index 0000000..4a15fb0
--- /dev/null
+++ b/media-libs/clutter/clutter-1.18.2.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+CLUTTER_LA_PUNT="yes"
+
+# Inherit gnome2 after clutter to download sources from gnome.org
+# since clutter-project.org doesn't provide .xz tarballs
+inherit clutter gnome2 virtualx
+
+DESCRIPTION="Clutter is a library for creating graphical user interfaces"
+
+LICENSE="LGPL-2.1+ FDL-1.1+"
+SLOT="1.0"
+IUSE="debug doc egl gtk +introspection test X" # evdev tslib
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+# NOTE: glx flavour uses libdrm + >=mesa-7.3
+# XXX: uprof needed for profiling
+# >=libX11-1.3.1 needed for X Generic Event support
+# XXX: evdev input requires libinput and gudev >= 136
+# XXX: Probably require one of USE=X or USE=egl
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=dev-libs/atk-2.5.3[introspection?]
+ >=dev-libs/json-glib-0.12[introspection?]
+ >=media-libs/cogl-1.17.5:1.0=[introspection?,pango]
+ media-libs/fontconfig
+ >=x11-libs/cairo-1.12:=[glib]
+ >=x11-libs/pango-1.30[introspection?]
+
+ X? (
+ virtual/opengl
+ x11-libs/libdrm:=
+ >=x11-libs/libX11-1.3.1
+ x11-libs/libXext
+ x11-libs/libXdamage
+ x11-proto/inputproto
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXcomposite-0.4
+ )
+
+ gtk? ( >=x11-libs/gtk+-3.3.18:3 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.20
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17
+ doc? (
+ >=dev-util/gtk-doc-1.20
+ >=app-text/docbook-sgml-utils-0.6.14[jadetex]
+ dev-libs/libxslt )
+ test? ( x11-libs/gdk-pixbuf )"
+
+# Tests fail with both swrast and llvmpipe
+# They pass under r600g or i965, so the bug is in mesa
+#RESTRICT="test"
+
+src_prepare() {
+ # We only need conformance tests, the rest are useless for us
+ sed -e 's/^\(SUBDIRS =\).*/\1 accessibility conform/g' \
+ -i tests/Makefile.am || die "am tests sed failed"
+ sed -e 's/^\(SUBDIRS =\)[^\]*/\1 accessibility conform/g' \
+ -i tests/Makefile.in || die "in tests sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="README NEWS ChangeLog*"
+
+ # XXX: Conformance test suite (and clutter itself) does not work under Xvfb
+ # (GLX error blabla)
+ # XXX: Profiling, coverage disabled for now
+ # XXX: What about cex100/egl/osx/wayland/win32 backends?
+ # XXX: evdev/tslib input seem to be experimental?
+ gnome2_src_configure \
+ $(usex X --enable-xinput) \
+ $(usex X --enable-x11-backend=yes) \
+ --disable-profile \
+ --disable-maintainer-flags \
+ --disable-gcov \
+ --disable-cex100-backend \
+ $(usex egl --enable-egl-backend --disable-egl-backend) \
+ --disable-quartz-backend \
+ --disable-wayland-backend \
+ --disable-win32-backend \
+ --disable-tslib-input \
+ --disable-evdev-input \
+ $(usex debug --enable-debug=yes --enable-debug=minimum) \
+ $(use_enable doc docs) \
+ $(use_enable gtk gdk-backend) \
+ $(use_enable introspection) \
+ $(use_enable test gdk-pixbuf)
+}
+
+src_test() {
+ Xemake check -C tests/conform
+}
+
+src_install() {
+ clutter_src_install
+}
diff --git a/media-libs/clutter/metadata.xml b/media-libs/clutter/metadata.xml
new file mode 100644
index 0000000..0291170
--- /dev/null
+++ b/media-libs/clutter/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <use>
+ <flag name="gtk">Use gdk-pixbuf from <pkg>x11-libs/gtk+</pkg> as image rendering backend</flag>
+ </use>
+</pkgmetadata>