summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-05-17 00:40:28 +0200
committerPeter Alfredsen <loki_val@gentoo.org>2009-05-17 00:40:28 +0200
commit10e8d5abe022902f442f7dcdd1b8e34ccf4e739a (patch)
tree61c82632e86f932c223497a3020d95b4003be0e4
parentpdfshuffler added (diff)
downloadloki_val-10e8d5abe022902f442f7dcdd1b8e34ccf4e739a.tar.gz
loki_val-10e8d5abe022902f442f7dcdd1b8e34ccf4e739a.tar.bz2
loki_val-10e8d5abe022902f442f7dcdd1b8e34ccf4e739a.zip
Testing libs.
-rw-r--r--x11-drivers/ati-drivers/Manifest5
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-8.602.ebuild439
-rw-r--r--x11-drivers/ati-drivers/files/ati-powermode-opt-path-2.patch42
-rw-r--r--x11-drivers/ati-drivers/files/atieventsd.init20
-rw-r--r--x11-drivers/ati-drivers/files/libGL.la.in32
-rw-r--r--x11-libs/libX11/Manifest2
-rw-r--r--x11-libs/libX11/libX11-1.2.1.ebuild44
-rw-r--r--x11-libs/libxcb/Manifest2
-rw-r--r--x11-libs/libxcb/libxcb-1.2.ebuild37
-rw-r--r--x11-proto/xcb-proto/Manifest2
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.4.ebuild18
-rw-r--r--x11-proto/xproto/Manifest2
-rw-r--r--x11-proto/xproto/xproto-7.0.15.ebuild20
13 files changed, 665 insertions, 0 deletions
diff --git a/x11-drivers/ati-drivers/Manifest b/x11-drivers/ati-drivers/Manifest
new file mode 100644
index 0000000..a9ad876
--- /dev/null
+++ b/x11-drivers/ati-drivers/Manifest
@@ -0,0 +1,5 @@
+AUX ati-powermode-opt-path-2.patch 1634 RMD160 a9c4ecc90a748f94282521a555ad7b64db242249 SHA1 3f61d804710bd88ee45cd3a9e3672b356359dd73 SHA256 e7749e04a3aa24132b13d0c694563a45c0d38e238f7412a75bd89aa9f9e9ead1
+AUX atieventsd.init 533 RMD160 b9b95a8a3f32dcafba3e5fa08d6d1053e831291a SHA1 982ffdb8064785c8b96fb0213ad7892ac918b5d7 SHA256 20010ebc5cb286149f3c4c9c099b6470463ccdb8fd47cea054b783dc2ad1fff3
+AUX libGL.la.in 749 RMD160 b2eb11cd123cb0e789adb1e22dffdbfc03542f69 SHA1 be41cc2eb1754a44134a95475be5f0cb894e24bc SHA256 a7b4b58b1311f8e1caf83222cb020dfbc48e2881a8deef21eddefa23b3992f13
+DIST ati-driver-installer-9-4-x86.x86_64.run 86701799 RMD160 d5382fecc2da11f4628cb4b64e306aef10ddc7f4 SHA1 730e9e78e4bb20994549c8f7eb539fe223bb1a69 SHA256 779287fc6f8656bddd17e1619121000583cbff440ef05e987dae604927baa497
+EBUILD ati-drivers-8.602.ebuild 14709 RMD160 e4f9dfb2ac9e173483cfa0cbf08d2cc04b673b0a SHA1 efa9aad865182014232d5c3001408b3f7c25a051 SHA256 a32997a06a4cad1a9dd87b816b6d2d143139e0000e280329cc8b8bf40f164a70
diff --git a/x11-drivers/ati-drivers/ati-drivers-8.602.ebuild b/x11-drivers/ati-drivers/ati-drivers-8.602.ebuild
new file mode 100644
index 0000000..dd87736
--- /dev/null
+++ b/x11-drivers/ati-drivers/ati-drivers-8.602.ebuild
@@ -0,0 +1,439 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-8.582.ebuild,v 1.3 2009/03/14 23:28:20 mr_bones_ Exp $
+
+IUSE="acpi debug"
+
+inherit eutils multilib linux-mod toolchain-funcs versionator
+
+DESCRIPTION="Ati precompiled drivers for recent chipsets"
+HOMEPAGE="http://www.ati.com"
+ATI_URL="https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/"
+SRC_URI="${ATI_URL}/ati-driver-installer-9-4-x86.x86_64.run"
+
+LICENSE="AMD GPL-2 QPL-1.0 as-is"
+KEYWORDS="~amd64 ~x86"
+
+# The portage dep is for COLON_SEPARATED support in env-update.
+# The eselect dep (>=1.0.9) is for COLON_SEPARATED in eselect env update.
+RDEPEND=">=x11-base/xorg-server-1.5
+ !x11-apps/ati-drivers-extra
+ >=app-admin/eselect-1.0.9
+ app-admin/eselect-opengl
+ sys-libs/libstdc++-v3
+ amd64? ( app-emulation/emul-linux-x86-xlibs )
+ acpi? (
+ x11-apps/xauth
+ sys-power/acpid
+ )
+ x11-libs/libXrandr
+ >=sys-apps/portage-2.1.1-r1"
+
+DEPEND="${RDEPEND}
+ x11-proto/xf86miscproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/inputproto
+ !<x11-drivers/ati-drivers-8.552-r1"
+
+EMULTILIB_PKG="true"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+
+ # Define module dir.
+ MODULE_DIR="${S}/common/lib/modules/fglrx/build_mod"
+
+ #check kernel and sets up KV_OBJ
+ MODULE_NAMES="fglrx(video:${S}/common/lib/modules/fglrx/build_mod/2.6.x)"
+ BUILD_TARGETS="kmod_build"
+ linux-mod_pkg_setup
+ BUILD_PARAMS="GCC_VER_MAJ=$(gcc-major-version) KVER=${KV_FULL} KDIR=${KV_DIR}"
+
+ if ! kernel_is 2 6; then
+ eerror "Need a 2.6 kernel to compile against!"
+ die "Need a 2.6 kernel to compile against!"
+ fi
+
+ if kernel_is ge 2 6 25 && linux_chkconfig_present PREEMPT_RCU; then
+ die "${P} is not compatible with RCU Preemption (bug #223281), please disable it"
+ fi
+
+ if kernel_is ge 2 6 26 && ! linux_chkconfig_present UNUSED_SYMBOLS; then
+ ewarn "You have to Enable unused/obsolete exported symbols in Kernel hacking section of kernel config for fglrx to load"
+ fi
+
+ if kernel_is ge 2 6 24 && ! linux_chkconfig_present PCI_LEGACY; then
+ eerror "${P} requires support for pci_find_slot."
+ die "${P} requires support for pci_find_slot."
+ fi
+
+ if ! linux_chkconfig_present MTRR; then
+ ewarn "You don't have MTRR support enabled, the direct rendering will not work."
+ fi
+
+ if linux_chkconfig_builtin DRM; then
+ ewarn "You have DRM support enabled builtin, the direct rendering will not work."
+ fi
+
+ if ! linux_chkconfig_present AGP && \
+ ! linux_chkconfig_present PCIEPORTBUS; then
+ ewarn "You need AGP and/or PCI Express support for direct rendering to work."
+ fi
+
+ if linux_chkconfig_present PARAVIRT; then
+ eerror "The current ati-drivers don't compile when having"
+ eerror "paravirtualization active due to GPL symbol export"
+ eerror "restrictions."
+ eerror "Please disable it:"
+ eerror " CONFIG_PARAVIRT=n"
+ eerror "in /usr/src/linux/.config or"
+ eerror " Processor type and features -->"
+ eerror " [ ] Paravirtualization support (EXPERIMENTAL)"
+ eerror "in 'menuconfig'"
+ die "CONFIG_PARAVIRT enabled"
+ fi
+
+ if ! linux_chkconfig_present MAGIC_SYSRQ; then
+ eerror "You need MAGIC_SYSRQ enabled in order to build ati-drivers"
+ die "CONFIG_MAGIC_SYSRQ disabled"
+ fi
+
+ # Only support xorg-server >=1.5
+ BASE_DIR="${S}/x740"
+
+ if ! linux_chkconfig_present PCI_MSI; then
+ eerror "You need PCI_MSI enabled in order to build ati-drivers"
+ die "CONFIG_PCI_MSI disabled"
+ fi
+
+ # This is used like $(get_libdir) for paths in ati's package.
+ if use amd64 ; then
+ MY_BASE_DIR="${BASE_DIR}_64a"
+ PKG_LIBDIR=lib64
+ ARCH_DIR="${S}/arch/x86_64"
+ else
+ MY_BASE_DIR="${BASE_DIR}"
+ PKG_LIBDIR=lib
+ ARCH_DIR="${S}/arch/x86"
+ fi
+}
+
+src_unpack() {
+ #Switching to a standard way to extract the files since otherwise no signature file
+ #would be created
+ local src="${DISTDIR}/${A}"
+ sh "${src}" --extract "${S}" 2&>1 /dev/null
+ cd "${S}"
+
+ # These are the userspace utilities that we also have source for.
+ # We rebuild these later.
+ rm \
+ "${ARCH_DIR}"/usr/X11R6/bin/{fgl_glxgears,fglrx_xgamma} \
+ "${ARCH_DIR}"/usr/X11R6/${PKG_LIBDIR}/libfglrx_gamma* \
+ || die "bin rm failed"
+
+ if use debug; then
+ # Enable debug mode in the Source Code.
+ sed -i '/^#define DRM_DEBUG_CODE/s/0/1/' \
+ "${MODULE_DIR}/firegl_public.c" \
+ || die "Failed to enable debug output."
+ fi
+
+ if use acpi; then
+ sed -i \
+ -e "s:/var/lib/xdm/authdir/authfiles/:/var/run/xauth/:" \
+ -e "s:/var/lib/gdm/:/var/gdm/:" \
+ "${S}/common/etc/ati/authatieventsd.sh" \
+ || die "sed failed."
+
+ # Since "who" is in coreutils, we're using that one instead of "finger".
+ sed -i -e 's:finger:who:' \
+ "${S}/common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh" \
+ || die "Replacing 'finger' with 'who' failed."
+ # Adjust paths in the script from /usr/X11R6/bin/ to /opt/bin/ and
+ # add funktion to detect default state.
+ epatch "${FILESDIR}"/ati-powermode-opt-path-2.patch
+ fi
+
+ pushd ${MODULE_DIR} >/dev/null
+ ln -s "${ARCH_DIR}"/lib/modules/fglrx/build_mod/libfglrx_ip.a.GCC$(gcc-major-version) \
+ || die "symlinking precompiled core failed"
+
+ convert_to_m 2.6.x/Makefile || die "convert_to_m failed"
+
+ # When built with ati's make.sh it defines a bunch of macros if
+ # certain .config values are set, falling back to less reliable
+ # detection methods if linux/autoconf.h is not available. We
+ # simply use the linux/autoconf.h settings directly, bypassing the
+ # detection script.
+ sed -i -e 's/__SMP__/CONFIG_SMP/' *.c *h || die "SMP sed failed"
+ sed -i -e 's/ifdef MODVERSIONS/ifdef CONFIG_MODVERSIONS/' *.c *.h \
+ || die "MODVERSIONS sed failed"
+ popd >/dev/null
+
+ mkdir extra || die "mkdir failed"
+ cd extra
+ unpack ./../common/usr/src/ati/fglrx_sample_source.tgz
+ sed -i -e 's:include/extensions/extutil.h:X11/extensions/extutil.h:' \
+ lib/fglrx_gamma/fglrx_gamma.c || die "include fixup failed"
+ # Add a category.
+ mv programs/fglrx_gamma/fglrx_xgamma.{man,1} || die "man mv failed"
+ cd ..
+}
+
+src_compile() {
+ linux-mod_src_compile
+
+ einfo "Building fgl_glxgears"
+ cd "${S}"/extra/fgl_glxgears
+ # These extra libs/utils either have an Imakefile that does not
+ # work very well without tweaking or a Makefile ignoring CFLAGS
+ # and the like. We bypass those.
+
+ # The -DUSE_GLU is needed to compile using nvidia headers
+ # according to a comment in ati-drivers-extra-8.33.6.ebuild.
+ "$(tc-getCC)" -o fgl_glxgears ${CFLAGS} ${LDFLAGS} -DUSE_GLU \
+ -I"${S}"/common/usr/include fgl_glxgears.c \
+ -lGL -lGLU -lX11 -lm || die "fgl_glxgears build failed"
+
+ einfo "Building fglrx_gamma lib"
+ cd "${S}"/extra/lib/fglrx_gamma
+ "$(tc-getCC)" -shared -fpic -o libfglrx_gamma.so.1.0 ${CFLAGS} ${LDFLAGS} \
+ -DXF86MISC -Wl,-soname,libfglrx_gamma.so.1.0 fglrx_gamma.c \
+ -lXext || die "fglrx_gamma lib build failed"
+ ln -s libfglrx_gamma.so.1.0 libfglrx_gamma.so || die "ln failed"
+ ln -s libfglrx_gamma.so.1.0 libfglrx_gamma.so.1 || die "ln failed"
+
+ einfo "Building fglrx_gamma util"
+ cd "${S}"/extra/programs/fglrx_gamma
+ "$(tc-getCC)" -o fglrx_xgamma ${CFLAGS} ${LDFLAGS} \
+ -I../../../common/usr/X11R6/include -L../../lib/fglrx_gamma \
+ fglrx_xgamma.c -lm -lfglrx_gamma -lX11 \
+ || die "fglrx_gamma util build failed"
+
+}
+
+src_install() {
+ linux-mod_src_install
+
+ # We can do two things here, and neither of them is very nice.
+
+ # For direct rendering libGL has to be able to load one or more
+ # dri modules (files ending in _dri.so, like fglrx_dri.so).
+ # Gentoo's mesa looks for these files in the location specified by
+ # LIBGL_DRIVERS_PATH or LIBGL_DRIVERS_DIR, then in the hardcoded
+ # location /usr/$(get_libdir)/dri. Ati's libGL does the same
+ # thing, but the hardcoded location is /usr/X11R6/lib/modules/dri
+ # on x86 and amd64 32bit, /usr/X11R6/lib64/modules/dri on amd64
+ # 64bit. So we can either put the .so files in that (unusual,
+ # compared to "normal" mesa libGL) location or set
+ # LIBGL_DRIVERS_PATH. We currently do the latter. See also bug
+ # 101539.
+
+ # The problem with this approach is that LIBGL_DRIVERS_PATH
+ # *overrides* the default hardcoded location, it does not extend
+ # it. So if ati-drivers is merged but a non-ati libGL is selected
+ # and its hardcoded path does not match our LIBGL_DRIVERS_PATH
+ # (because it changed in a newer mesa or because it was compiled
+ # for a different set of multilib abis than we are) stuff breaks.
+
+ # We create one file per ABI to work with "native" multilib, see
+ # below.
+
+ echo "COLON_SEPARATED=LIBGL_DRIVERS_PATH" > "${T}/03ati-colon-sep"
+ doenvd "${T}/03ati-colon-sep"
+
+ # All libraries that we have a 32 bit and 64 bit version of on
+ # amd64 are installed in src_install-libs. Everything else
+ # (including libraries only available in native 64bit on amd64)
+ # goes in here.
+
+ # There used to be some code here that tried to detect running
+ # under a "native multilib" portage ((precursor of)
+ # http://dev.gentoo.org/~kanaka/auto-multilib/). I removed that, it
+ # should just work (only doing some duplicate work). --marienz
+ if has_multilib_profile; then
+ local OABI=${ABI}
+ for ABI in $(get_install_abis); do
+ src_install-libs
+ done
+ ABI=${OABI}
+ unset OABI
+ else
+ src_install-libs
+ fi
+
+ # This is sorted by the order the files occur in the source tree.
+
+ # X modules.
+ exeinto /usr/$(get_libdir)/xorg/modules/drivers
+ doexe "${MY_BASE_DIR}"/usr/X11R6/${PKG_LIBDIR}/modules/drivers/fglrx_drv.so
+ exeinto /usr/$(get_libdir)/xorg/modules/linux
+ doexe "${MY_BASE_DIR}"/usr/X11R6/${PKG_LIBDIR}/modules/linux/libfglrxdrm.so
+ exeinto /usr/$(get_libdir)/xorg/modules
+ doexe "${MY_BASE_DIR}"/usr/X11R6/${PKG_LIBDIR}/modules/{esut.a,glesx.so,amdxmm.so}
+
+ # Arch-specific files.
+ # (s)bin.
+ into /opt
+ if use acpi; then
+ dosbin "${ARCH_DIR}"/usr/sbin/atieventsd
+ fi
+ # We cleaned out the compilable stuff in src_unpack
+ dobin "${ARCH_DIR}"/usr/X11R6/bin/*
+
+ # lib.
+ exeinto /usr/$(get_libdir)
+ # Everything except for the libGL.so installed in src_install-libs.
+ doexe $(find "${ARCH_DIR}"/usr/X11R6/${PKG_LIBDIR} \
+ -maxdepth 1 -type f -name '*.so*' -not -name 'libGL.so*')
+ insinto /usr/$(get_libdir)
+ doins $(find "${ARCH_DIR}"/usr/X11R6/${PKG_LIBDIR} \
+ -maxdepth 1 -type f -not -name '*.so*')
+
+ # Common files.
+ # etc.
+ insinto /etc/ati
+ # Everything except for the authatieventsd.sh script.
+ doins common/etc/ati/{logo*,control,atiogl.xml,signature,amdpcsdb.default}
+ if use acpi; then
+ insopts -m0755
+ doins common/etc/ati/authatieventsd.sh
+ fi
+
+ # include.
+ insinto /usr
+ doins -r common/usr/include
+ insinto /usr/include/X11/extensions
+ doins common/usr/X11R6/include/X11/extensions/fglrx_gamma.h
+
+ # Just the atigetsysteminfo.sh script.
+ into /usr
+ dosbin common/usr/sbin/*
+
+ # data files for the control panel.
+ insinto /usr/share
+ doins -r common/usr/share/ati
+ insinto /usr/share/pixmaps
+ doins common/usr/share/icons/ccc_{large,small}.xpm
+ make_desktop_entry amdcccle 'ATI Catalyst Control Center' \
+ ccc_large System
+
+ # doc.
+ dohtml -r common/usr/share/doc/fglrx
+
+ if use acpi; then
+ doman common/usr/share/man/man8/atieventsd.8
+
+ pushd common/usr/share/doc/fglrx/examples/etc/acpi >/dev/null
+
+ exeinto /etc/acpi
+ doexe ati-powermode.sh
+ insinto /etc/acpi/events
+ doins events/*
+
+ popd >/dev/null
+ fi
+
+ # Done with the "source" tree. Install tools we rebuilt:
+ dobin extra/fgl_glxgears/fgl_glxgears
+ newdoc extra/fgl_glxgears/README README.fgl_glxgears
+
+ dolib extra/lib/fglrx_gamma/*so*
+ newdoc extra/lib/fglrx_gamma/README README.libfglrx_gamma
+
+ dobin extra/programs/fglrx_gamma/fglrx_xgamma
+ doman extra/programs/fglrx_gamma/fglrx_xgamma.1
+ newdoc extra/programs/fglrx_gamma/README README.fglrx_gamma
+
+ # Gentoo-specific stuff:
+ if use acpi; then
+ newinitd "${FILESDIR}"/atieventsd.init atieventsd \
+ || die "Failed to install atieventsd.init.d"
+ echo 'ATIEVENTSDOPTS=""' > "${T}"/atieventsd.conf
+ newconfd "${T}"/atieventsd.conf atieventsd
+ fi
+}
+
+src_install-libs() {
+ if [[ "${ABI}" == "amd64" ]]; then
+ local EX_BASE_DIR="${BASE_DIR}_64a"
+ local pkglibdir=lib64
+ local MY_ARCH_DIR="${S}/arch/x86_64"
+ else
+ local EX_BASE_DIR="${BASE_DIR}"
+ local pkglibdir=lib
+ local MY_ARCH_DIR="${S}/arch/x86"
+ fi
+ einfo "ati tree '${pkglibdir}' -> '$(get_libdir)' on system"
+
+ local ATI_ROOT=/usr/$(get_libdir)/opengl/ati
+ # To make sure we do not miss a spot when these change.
+ local libmajor=1 libminor=2
+ local libver=${libmajor}.${libminor}
+
+ # The GLX libraries
+ # (yes, this really is "lib" even on amd64/multilib --marienz)
+ exeinto ${ATI_ROOT}/lib
+ doexe "${MY_ARCH_DIR}"/usr/X11R6/${pkglibdir}/libGL.so.${libver}
+ dosym libGL.so.${libver} ${ATI_ROOT}/lib/libGL.so.${libmajor}
+ dosym libGL.so.${libver} ${ATI_ROOT}/lib/libGL.so
+
+ exeinto ${ATI_ROOT}/extensions
+ doexe "${EX_BASE_DIR}"/usr/X11R6/${pkglibdir}/modules/extensions/*
+
+ # DRI modules, installed into the path used by recent versions of mesa.
+ exeinto /usr/$(get_libdir)/dri
+ doexe "${MY_ARCH_DIR}"/usr/X11R6/${pkglibdir}/modules/dri/fglrx_dri.so
+
+ # AMD Cal libraries
+ exeinto /usr/$(get_libdir)
+ doexe "${MY_ARCH_DIR}"/usr/${pkglibdir}/*.so
+
+ # Make up a libGL.la. Ati does not provide one, but mesa does. If
+ # a (libtool-based) libfoo is built with libGL.la present a
+ # reference to it is put into libfoo.la, and compiling
+ # (libtool-based) things that link too libfoo.la will complain if
+ # libGL.la disappears. So if we do not make up a libGL.la
+ # switching between mesa and ati becomes painful.
+ local revision=$(printf '%d%02d%02d' $(get_version_components))
+ sed -e "s:\${libmajor}:${libmajor}:g" \
+ -e "s:\${libminor}:${libminor}:g" \
+ -e "s:\${libdir}:$(get_libdir):g" \
+ -e "s:\${revision}:${revision}:g" \
+ "${FILESDIR}"/libGL.la.in > "${D}"/${ATI_ROOT}/lib/libGL.la \
+ || die "sed failed to make libGL.la"
+
+ local envname="${T}"/04ati-dri-path
+ if [[ -n ${ABI} ]]; then
+ envname="${envname}-${ABI}"
+ fi
+ echo "LIBGL_DRIVERS_PATH=/usr/$(get_libdir)/dri" > "${envname}"
+ doenvd "${envname}"
+}
+
+pkg_postinst() {
+ /usr/bin/eselect opengl set --use-old ati
+
+ elog "To switch to ATI OpenGL, run \"eselect opengl set ati\""
+ elog "To change your xorg.conf you can use the bundled \"aticonfig\""
+ elog
+ elog "If you experience unexplained segmentation faults and kernel crashes"
+ elog "with this driver and multi-threaded applications such as wine,"
+ elog "set UseFastTLS in xorg.conf to either 0 or 1, but not 2."
+ elog
+ elog "You will have to source /etc/profile (or logout and back in) for dri"
+ elog "to work, unless you previously had ati-drivers installed."
+
+ # Workaroud screen corruption
+ ewarn "If you experience screen corruption with this driver, try putting"
+ ewarn ' Option "XAANoOffscreenPixmaps" "true"'
+ ewarn "in the Device Section of /etc/X11/xorg.conf."
+
+ linux-mod_pkg_postinst
+}
+
+pkg_prerm() {
+ /usr/bin/eselect opengl set xorg-x11
+}
diff --git a/x11-drivers/ati-drivers/files/ati-powermode-opt-path-2.patch b/x11-drivers/ati-drivers/files/ati-powermode-opt-path-2.patch
new file mode 100644
index 0000000..f5a35a3
--- /dev/null
+++ b/x11-drivers/ati-drivers/files/ati-powermode-opt-path-2.patch
@@ -0,0 +1,42 @@
+diff -ur common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh
+--- common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-07-28 04:22:36.000000000 +0100
++++ common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-08-04 12:19:42.000000000 +0100
+@@ -4,6 +4,8 @@
+ # Control script for ACPI lid state and AC adapter state
+ #
+
++aticonfig='/opt/bin/aticonfig'
++
+ getXuser() {
+ user=`finger| grep -m1 ":$displaynum " | awk '{print $1}'`
+ if [ x"$user" = x"" ]; then
+@@ -47,7 +49,7 @@
+ done
+
+ #If PPLIB is enabled
+-su $user -c '/usr/bin/aticonfig --pplib-cmd="get version"' | grep PPLIB
++su $user -c '$aticonfig --pplib-cmd="get version"' | grep PPLIB
+ if [ $? = 0 ]; then
+ echo "Has PPLIB"
+ has_pplib=1
+@@ -61,15 +63,15 @@
+ if [ ${lid_closed} -eq 1 -o ${on_dc} -eq 1 ]; then
+ echo "Low power"
+ if [ ${has_pplib} -eq 1 ]; then
+- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc dc"'
++ su $user -c '$aticonfig --pplib-cmd="notify psrc dc"'
+ else
+- su $user -c "/usr/bin/aticonfig --set-powerstate=1 --effective=now"
++ su $user -c "$aticonfig --set-powerstate=1"
+ fi
+ else
+ echo "high power"
+ if [ ${has_pplib} -eq 1 ]; then
+- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc ac"'
++ su $user -c '$aticonfig --pplib-cmd="notify psrc ac"'
+ else
+- su $user -c "/usr/bin/aticonfig --set-powerstate=3 --effective=now"
++ su $user -c "$aticonfig --set-powerstate=$($aticonfig --lsp | grep 'default state' | cut -c 3)"
+ fi
+ fi
+
diff --git a/x11-drivers/ati-drivers/files/atieventsd.init b/x11-drivers/ati-drivers/files/atieventsd.init
new file mode 100644
index 0000000..73139ce
--- /dev/null
+++ b/x11-drivers/ati-drivers/files/atieventsd.init
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/files/atieventsd.init,v 1.3 2007/05/18 23:58:01 marienz Exp $
+
+depend() {
+ need acpid
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --exec /opt/sbin/atieventsd -- ${ATIEVENTSDOPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --quiet --exec /opt/sbin/atieventsd
+ eend $?
+} \ No newline at end of file
diff --git a/x11-drivers/ati-drivers/files/libGL.la.in b/x11-drivers/ati-drivers/files/libGL.la.in
new file mode 100644
index 0000000..7fdc409
--- /dev/null
+++ b/x11-drivers/ati-drivers/files/libGL.la.in
@@ -0,0 +1,32 @@
+# libGL.la - a libtool library file
+# Generated by ltmain.sh - GNU libtool 1.4 (1.920 2001/04/24 23:26:18)
+#
+# Please DO NOT delete this file!
+# It is necessary for linking the library.
+
+# The name that we can dlopen(3).
+dlname='libGL.so.1'
+
+# Names of this library.
+library_names='libGL.so.${libmajor}.${libminor} libGL.so.${libmajor} libGL.so'
+
+# The name of the static archive.
+old_library=''
+
+# Libraries that this one depends upon.
+dependency_libs='-L/usr/${libdir} -lX11 -lXext -ldl'
+
+# Version information for libGL.
+current=1
+age=0
+revision=${revision}
+
+# Is this an already installed library?
+installed=yes
+
+# Files to dlopen/dlpreopen
+dlopen=''
+dlpreopen=''
+
+# Directory that this library needs to be installed in:
+libdir='/usr/${libdir}'
diff --git a/x11-libs/libX11/Manifest b/x11-libs/libX11/Manifest
new file mode 100644
index 0000000..6b24e7b
--- /dev/null
+++ b/x11-libs/libX11/Manifest
@@ -0,0 +1,2 @@
+DIST libX11-1.2.1.tar.bz2 1798407 RMD160 1207c7a9430751e25a758163dd47b07bf18c6ab7 SHA1 8e58c3d9070cd164a960dc89b20cf0e35bade8c8 SHA256 d172e5a401a2607f4ff145db4e8e09c193a1980bbb2c5c7f824e61ee3fdfdff3
+EBUILD libX11-1.2.1.ebuild 1215 RMD160 f1cc6a06c963c57fb0e3fc3605b2c7b6555d9da6 SHA1 5fc5874e2744587bacfca7e5589426e5ee296f6e SHA256 fd313394e1346d408c14e4441abfb7ffc48281b7e14f579c0cef1afafffd6a90
diff --git a/x11-libs/libX11/libX11-1.2.1.ebuild b/x11-libs/libX11/libX11-1.2.1.ebuild
new file mode 100644
index 0000000..c9a04f0
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.5.ebuild,v 1.1 2008/09/06 06:56:34 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+EAPI="1"
+
+inherit x-modular toolchain-funcs flag-o-matic
+
+DESCRIPTION="X.Org X11 library"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 +xcb"
+
+RDEPEND=">=x11-libs/xtrans-1.2.3
+ x11-proto/kbproto
+ >=x11-proto/xproto-7.0.15
+ xcb? ( >=x11-libs/libxcb-1.2 )
+ !xcb? (
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ )"
+DEPEND="${RDEPEND}
+ x11-proto/xf86bigfontproto
+ x11-proto/bigreqsproto
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xcmiscproto
+ >=x11-misc/util-macros-1.2.1"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_with xcb)"
+ # xorg really doesn't like xlocale disabled.
+ # $(use_enable nls xlocale)
+}
+
+src_compile() {
+ x-modular_src_configure
+ # [Cross-Compile Love] Disable {C,LD}FLAGS and redefine CC= for 'makekeys'
+ ( filter-flags -m* ; cd src/util && make CC=$(tc-getBUILD_CC) CFLAGS="${CFLAGS}" LDFLAGS="" clean all)
+ x-modular_src_make
+}
diff --git a/x11-libs/libxcb/Manifest b/x11-libs/libxcb/Manifest
new file mode 100644
index 0000000..6103f8b
--- /dev/null
+++ b/x11-libs/libxcb/Manifest
@@ -0,0 +1,2 @@
+DIST libxcb-1.2.tar.bz2 323667 RMD160 0a1d18c44edf7696a5f4d079dfb6b7a98faf933c SHA1 12be595ce1e26da3b63e6a17a47ab9392259f10f SHA256 4fe14659ed0c5ceacec25ad6067a9521f85852280bc39c0375f5000ab133cb3f
+EBUILD libxcb-1.2.ebuild 971 RMD160 2fa27286a5eafd9e80bd3c3d0dd21905fc8e2b94 SHA1 23086d1b4dd7e7c5f0c29a12237f4cf21088dfcf SHA256 0fc55fb0cfe81bee51a7726505dbe5c907caf2b35fbff6e0518a71a468c6060e
diff --git a/x11-libs/libxcb/libxcb-1.2.ebuild b/x11-libs/libxcb/libxcb-1.2.ebuild
new file mode 100644
index 0000000..1da0f01
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.1.90.1.ebuild,v 1.1 2008/07/30 22:38:05 dberkholz Exp $
+
+EAPI="2"
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular multilib
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="http://xcb.freedesktop.org/"
+SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+LICENSE="X11"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc selinux"
+RDEPEND="x11-libs/libXau
+ x11-libs/libXdmcp
+ dev-libs/libpthread-stubs"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-libs/libxslt
+ >=x11-proto/xcb-proto-1.4
+ >=dev-lang/python-2.5[xml]"
+
+CONFIGURE_OPTIONS="$(use_enable doc build-docs)
+ $(use_enable selinux xselinux)
+ --enable-xinput"
+
+src_install() {
+ x-modular_src_install
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+}
diff --git a/x11-proto/xcb-proto/Manifest b/x11-proto/xcb-proto/Manifest
new file mode 100644
index 0000000..b153453
--- /dev/null
+++ b/x11-proto/xcb-proto/Manifest
@@ -0,0 +1,2 @@
+DIST xcb-proto-1.4.tar.bz2 87093 RMD160 a344ca302a1cbefd98dcd289abf8704667a4b536 SHA1 ab9bb7c875558a3324673bb749e0502046f31083 SHA256 2d50a7b6f5a948ece84549c80872115bc7c2b7e6371f24b4742eb1c51bd259bd
+EBUILD xcb-proto-1.4.ebuild 640 RMD160 9a2a91b7106a49a3b1e28820fed4132a93f20738 SHA1 a6ae1a5c5e32eb82fbea6b4989f3057349559da7 SHA256 05088dcb971bdaaa998e216eaf6c0483b061f9b91c273cc9327c83afe580db87
diff --git a/x11-proto/xcb-proto/xcb-proto-1.4.ebuild b/x11-proto/xcb-proto/xcb-proto-1.4.ebuild
new file mode 100644
index 0000000..5861157
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.4.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/xcb-proto-1.2.ebuild,v 1.2 2008/08/03 08:33:58 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="http://xcb.freedesktop.org/"
+SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+LICENSE="X11"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-libs/libxml2
+ >=dev-lang/python-2.5"
diff --git a/x11-proto/xproto/Manifest b/x11-proto/xproto/Manifest
new file mode 100644
index 0000000..abf89fd
--- /dev/null
+++ b/x11-proto/xproto/Manifest
@@ -0,0 +1,2 @@
+DIST xproto-7.0.15.tar.bz2 159189 RMD160 6c722c6bf29e24706fb7a06aec2585c03e431134 SHA1 891e3f8e2c17128a8fc6930583e42fd3db75839a SHA256 fd8cd0bc3e94d7416e6af9eddfa909b0e64246e0d2bb41c00f4e02bd85c76bee
+EBUILD xproto-7.0.15.ebuild 549 RMD160 e5227d0dad06ecdb6e71f737d8204dc47169f2c6 SHA1 ab97a67fc68f32ce89a62e4bfca675cafea581f8 SHA256 dc9f165ba559d6484ab0c5f3a0a237153fb16dfa5f8835d642da6b96dd03559b
diff --git a/x11-proto/xproto/xproto-7.0.15.ebuild b/x11-proto/xproto/xproto-7.0.15.ebuild
new file mode 100644
index 0000000..7abc801
--- /dev/null
+++ b/x11-proto/xproto/xproto-7.0.15.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xproto/xproto-7.0.14.ebuild,v 1.1 2009/01/13 02:28:18 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xproto protocol headers"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ x-modular_unpack_source
+ x-modular_reconf_source
+}