summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMATSUU Takuto <matsuu@gentoo.org>2010-07-09 08:40:11 +0900
committerMATSUU Takuto <matsuu@gentoo.org>2010-07-09 08:40:11 +0900
commit8cb143c8718c88507cee69ac997430c66e517b34 (patch)
tree106c78174a1a95fa86d9b5823ddb96d15c6fdd36 /sys-auth
parentmoved to gentoo-x86 portage tree. (diff)
downloadmatsuu-8cb143c8718c88507cee69ac997430c66e517b34.tar.gz
matsuu-8cb143c8718c88507cee69ac997430c66e517b34.tar.bz2
matsuu-8cb143c8718c88507cee69ac997430c66e517b34.zip
sys-auth/pam_mobile_otp: Initial import.
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mobile_otp/Manifest2
-rw-r--r--sys-auth/pam_mobile_otp/pam_mobile_otp-0.5.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-auth/pam_mobile_otp/Manifest b/sys-auth/pam_mobile_otp/Manifest
new file mode 100644
index 0000000..806f52b
--- /dev/null
+++ b/sys-auth/pam_mobile_otp/Manifest
@@ -0,0 +1,2 @@
+DIST pam_mobile_otp-0.5.tgz 27703 RMD160 4a956ff1f69be00a8c30c791f743585857f8284a SHA1 982419174c48007cf9e910c6c0180f9b62daeaaf SHA256 0b7d7efb66a14ed8c90997f08a6aff65dea8b2c7bafc8099ed51ab49da99b2e3
+EBUILD pam_mobile_otp-0.5.ebuild 833 RMD160 82d5e521f3c039c2d76e09ad3463324e26404ae2 SHA1 69155e2327c3b31371d63fdcc69403ea61f935df SHA256 5dc68233c6645fc7e7d622cd91dc1853b3b0226d2497b19a13dd16cad0b6be1d
diff --git a/sys-auth/pam_mobile_otp/pam_mobile_otp-0.5.ebuild b/sys-auth/pam_mobile_otp/pam_mobile_otp-0.5.ebuild
new file mode 100644
index 0000000..9ff9ddb
--- /dev/null
+++ b/sys-auth/pam_mobile_otp/pam_mobile_otp-0.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Mobile One Time Passwords"
+HOMEPAGE="http://motp.sourceforge.net/"
+SRC_URI="http://motp.sourceforge.net/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e "s:gcc:$(tc-getCC) ${CFLAGS}:" \
+ -e "s:ld:$(tc-getLD):" \
+ Makefile || die
+}
+
+src_install() {
+ exeinto /$(get_libdir)/security
+ doexe pam_mobile_otp.so || die
+
+ keepdir /var/cache/motp || die
+ fperms 0700 /var/cache/motp || die
+
+ insinto /etc/security || die
+ doins motp.conf || die
+ fperms 0600 /etc/security/motp.conf || die
+
+ dodoc CHANGELOG README || die
+ dohtml MOTP.html || die
+}