summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <none@none>2012-02-26 13:40:18 +0100
committerKrzysztof Pawlik <none@none>2012-02-26 13:40:18 +0100
commita421c7501d13a012a709cf0af85bda59f3195090 (patch)
tree09ad2a5ff68ba12520bb2c53917ab154a75bd900
parentAdd a new Python-distutils eclass for Python, distutils-based packages. (diff)
downloadnelchael-a421c7501d13a012a709cf0af85bda59f3195090.tar.gz
nelchael-a421c7501d13a012a709cf0af85bda59f3195090.tar.bz2
nelchael-a421c7501d13a012a709cf0af85bda59f3195090.zip
Add ebuilds testing python-distutils-ng.eclass.
(Portage version: 2.1.10.49/hg/Linux x86_64, signed Manifest commit with key 0xF6A80E46)
-rw-r--r--dev-python/xlrd/ChangeLog10
-rw-r--r--dev-python/xlrd/Manifest18
-rw-r--r--dev-python/xlrd/metadata.xml7
-rw-r--r--dev-python/xlrd/xlrd-0.7.1-r256.ebuild70
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/xlrd/ChangeLog b/dev-python/xlrd/ChangeLog
new file mode 100644
index 0000000..8fc2164
--- /dev/null
+++ b/dev-python/xlrd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/xlrd
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*xlrd-0.7.1-r256 (26 Feb 2012)
+
+ 26 Feb 2012; Krzysztof Pawlik <nelchael@gentoo.org> +xlrd-0.7.1-r256.ebuild,
+ +metadata.xml:
+ Add ebuilds testing python-distutils-ng.eclass.
+
diff --git a/dev-python/xlrd/Manifest b/dev-python/xlrd/Manifest
new file mode 100644
index 0000000..8e51fd2
--- /dev/null
+++ b/dev-python/xlrd/Manifest
@@ -0,0 +1,18 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST xlrd-0.7.1.tar.gz 118302 RMD160 1dbbde702c515e5af3257fe403975c13c52632fc SHA1 9d06a1ebbf796530a1abb497f633a796606f4ad1 SHA256 ba11be7d2ebe7eeb208a23cc165bb7540451bcbad6da5cbf6947237568d16d14
+EBUILD xlrd-0.7.1-r256.ebuild 1631 RMD160 55dbf21fc3fbfe4c67873d95d84a7e22c2913d62 SHA1 beb0910e8e001637241c97cb90b04bd72a012b43 SHA256 06c6e9496ea03aead5058ec5ed28fadb7dcb28c906bd31a9df744df8ad532190
+MISC ChangeLog 295 RMD160 13b211814c5dac3bb1fdfe84e2371ede11005741 SHA1 86bf509a6c806b914db7cb81271cc13d46b04b29 SHA256 61cd34a1c6f3ddb475f93c3eeff972b91c495973c87acfee70bff902847aa25e
+MISC metadata.xml 205 RMD160 e987371be157660daac092207f697d0131df2861 SHA1 73785dc8ec827ff32d4388ac9824d4ea5fd349d3 SHA256 01b130f2def7aeb83c9977e02bedc8ba2ca4b3b0d2257a4711795ee50acf81d2
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iQEcBAEBCgAGBQJPSigyAAoJEBZyv1r2qA5GMP0H/RMtxcW3AgfjRW9VoSoWCB8p
+/3Ru558OxPMXtO8TUAnwKTtMk+HF835FHN4PhgzGAX5VzePHtpnm2zK6L2j7o6F+
+/Kgzwddff8L4xgI3us72m02degiRlLBniPoWg+0pPd7R5AcnR/cE1DEkIEq3AaiA
+fVGmJs6kAewFG4b8x6RL3C0kHHktyWEQhZVuIYKA/M33xm9eo7JNpSxUOdJFbv0A
+7P1iSbNfouscqoucW2jVQQ72EzZDdiNdB108MoaDLCBilBs0RUX2KnEehWlpruR9
+Q0Zs4IhgEqPYg+CB4c0zlJU6Dfw1QTDprHusE8jGJN8ypW1MKSuHnjAV/X+tGqc=
+=hIXB
+-----END PGP SIGNATURE-----
diff --git a/dev-python/xlrd/metadata.xml b/dev-python/xlrd/metadata.xml
new file mode 100644
index 0000000..bc261ed
--- /dev/null
+++ b/dev-python/xlrd/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>nelchael@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/xlrd/xlrd-0.7.1-r256.ebuild b/dev-python/xlrd/xlrd-0.7.1-r256.ebuild
new file mode 100644
index 0000000..b058ea9
--- /dev/null
+++ b/dev-python/xlrd/xlrd-0.7.1-r256.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+EAPI="4"
+
+#USE_PYTHON="python25 python26 python27"
+PYTHON_OPTIONAL="no"
+
+inherit python-distutils-ng
+
+DESCRIPTION="Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
+HOMEPAGE="http://pypi.python.org/pypi/xlrd"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc-aix ~hppa-hpux ~ia64-hpux ~x86-interix ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+python_unpack_all() {
+ : echo " ### python_unpack_all ### (${@}) PYTHON=${PYTHON}"
+ unpack ${A} # Not needed
+}
+
+python_prepare_all() {
+ : echo " ### python_prepare_all ### (${@}) PYTHON=${PYTHON}"
+ sed -i \
+ -e "s,'doc,# 'doc,g" \
+ -e "s,'exa,# 'exa,g" \
+ setup.py || die
+}
+
+python_prepare() {
+ : echo " ### python_prepare ### (${@}) PYTHON=${PYTHON}"
+}
+
+python_configure() {
+ : echo " ### python_configure ### (${@}) PYTHON=${PYTHON}"
+}
+
+python_compile() {
+ : echo " ### python_compile ### (${@}) PYTHON=${PYTHON}"
+ ${PYTHON} setup.py build || die
+}
+
+python_test() {
+ : echo " ### python_test ### (${@}) PYTHON=${PYTHON}"
+}
+
+python_install() {
+ : echo " ### python_install ### (${@}) PYTHON=${PYTHON}"
+ ${PYTHON} setup.py install --no-compile --root="${D}/" || die
+}
+
+python_install_all() {
+ : echo " ### python_install_all ### (${@}) PYTHON=${PYTHON}"
+ rm -f "${D}/usr/bin"/*.py || die
+
+ python-distutils-ng_doscript scripts/runxlrd.py
+
+ dohtml xlrd/doc/*.html
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ doins -r xlrd/examples
+ fi
+}