summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@shiro-laptop.(none)>2010-05-25 11:27:39 +0530
committerNirbheek Chauhan <nirbheek.chauhan@gmail.com>2010-07-26 03:31:11 +0530
commit7d7f1345a04eff63c4c0a9d15b7e5d1c0428156f (patch)
tree38eb87fc55f34f6ad6aa291246eb8dce55d12d3b
parentAdd net-misc/pino -- a Vala twitter client (diff)
downloadnirbheek-7d7f1345a04eff63c4c0a9d15b7e5d1c0428156f.tar.gz
nirbheek-7d7f1345a04eff63c4c0a9d15b7e5d1c0428156f.tar.bz2
nirbheek-7d7f1345a04eff63c4c0a9d15b7e5d1c0428156f.zip
Add games-fps/penumbra-overture-bin-1.1 + EULA
-rw-r--r--games-fps/penumbra-overture-bin/Manifest2
-rw-r--r--games-fps/penumbra-overture-bin/penumbra-overture-bin-1.1.ebuild101
-rw-r--r--licenses/PENUMBRA-EULA139
-rw-r--r--profiles/license_groups1
4 files changed, 243 insertions, 0 deletions
diff --git a/games-fps/penumbra-overture-bin/Manifest b/games-fps/penumbra-overture-bin/Manifest
new file mode 100644
index 0000000..a6be1b8
--- /dev/null
+++ b/games-fps/penumbra-overture-bin/Manifest
@@ -0,0 +1,2 @@
+DIST penumbra_overture_1.1.sh 300207883 RMD160 8e97f462257652895c5364e77d9baddc2b8de0e5 SHA1 e115f7cfcf9710d7aa5b2a5a9186b3736bb55cf2 SHA256 959aa4e4a277503c01bfc06058d027e784ce6630bb2cea0ea7a006068ecacc77
+EBUILD penumbra-overture-bin-1.1.ebuild 2635 RMD160 96433f1b6b3adea9f414afbb380c2b036cf7f10d SHA1 e6bd9556dbc3ace686977365d6dee6279d2408ea SHA256 f3233e402ce9c14da1197d24808b23027a30ce746909c62b5b33aef77df27fb1
diff --git a/games-fps/penumbra-overture-bin/penumbra-overture-bin-1.1.ebuild b/games-fps/penumbra-overture-bin/penumbra-overture-bin-1.1.ebuild
new file mode 100644
index 0000000..4df64ee
--- /dev/null
+++ b/games-fps/penumbra-overture-bin/penumbra-overture-bin-1.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils games
+
+DESCRIPTION="A first-person survival-horror adventure game"
+HOMEPAGE="http://www.penumbra-overture.com/"
+MY_PN="PenumbraOverture"
+MY_P="${P/-bin/}"
+SRC_URI="${MY_P//-/_}.sh"
+
+LICENSE="PENUMBRA-EULA"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE="alut fltk +ogg +openal +sdl +system-libs"
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="sys-libs/glibc
+ x11-libs/libX11
+
+ system-libs? (
+ media-libs/mesa
+
+ alut? ( >=media-libs/freealut-1.1.0 )
+ fltk? ( x11-libs/fltk:1.1 )
+ openal? ( >=media-libs/openal-1.8.466 )
+ sdl? (
+ >=media-libs/libsdl-1.2.11
+ >=media-libs/sdl-image-1.2.5
+ >=media-libs/sdl-ttf-2.0.8
+ )
+ ogg? (
+ >=media-libs/libvorbis-1.1.0
+ >=media-libs/libogg-1.1.2
+ )
+ )"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ cd "${WORKDIR}"
+
+ # makeself gzip archive
+ local a="${DISTDIR}/${A}"
+ # makeself archive script offset
+ local offset=$(head -n 439 "$a" | wc -c | tr -d " ")
+
+ einfo "The game is a tar.lzma inside a tar.lzma inside a makeself archive."
+ einfo "This will take some time (and RAM) to extract. Go get some coffee."
+
+ ebegin "Extracting ${MY_PN}"
+ dd if=$a ibs=$offset skip=1 obs=1024 2>/dev/null | tar xz ./subarch -O | \
+ lzmadec | tar x instarchive_all -O | lzmadec | tar x || \
+ die "Extracting archive failed!"
+ eend
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${MY_PN}
+
+ if use system-libs; then
+ ebegin "Removing bundled libraries"
+
+ # Use system GLU, aka mesa
+ rm ./lib/libGLU* || die "Removing GLU failed"
+
+ use alut && { rm ./lib/libalut* || die "Removing alut failed"; }
+ use fltk && { rm ./lib/libfltk* || die "Removing fltk failed"; }
+ use ogg && { rm ./lib/lib{ogg,vorbis}* || die "Removing ogg failed"; }
+ use openal && { rm ./lib/libopenal* || die "Removing openal failed"; }
+ use sdl && { rm ./lib/libSDL* || die "Removing SDL failed"; }
+
+ eend
+ fi
+
+ insinto "${GAMES_PREFIX_OPT}"
+ doins -r ${S} || die "doins failed"
+
+ dodoc *.txt README.* Manual.pdf || die "dodoc failed"
+
+ exeinto "${dir}"
+ doexe penumbra || die "doexe failed"
+ doexe penumbra.bin || die "doexe failed"
+
+ games_make_wrapper penumbra-bin ./penumbra "${dir}" "${dir}"
+
+ mv penumbra.png penumbra-bin.png || die "Rename png failed"
+ doicon penumbra-bin.png || die "doicon failed"
+ make_desktop_entry penumbra-bin "Penumbra: Overture" penumbra-bin
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ if use system-libs; then
+ elog "We remove the bundled penumbra libs in favour of system libraries."
+ elog "If you face problems with penumbra, try USE=-system-libs"
+ fi
+}
diff --git a/licenses/PENUMBRA-EULA b/licenses/PENUMBRA-EULA
new file mode 100644
index 0000000..f9a1458
--- /dev/null
+++ b/licenses/PENUMBRA-EULA
@@ -0,0 +1,139 @@
+End User License Agreement
+
+License
+1.Under this End User License Agreement (the "Agreement"), Frictional
+Games (the "Vendor") grants to the user (the "Licensee") a
+non-exclusive and non-transferable license (the "License") to use
+Penumbra: Overture (the "Software").
+
+2."Software" includes the executable computer programs and any related
+printed, electronic and online documentation and any other files that
+may accompany the product.
+
+3.Title, copyright, intellectual property rights and distribution
+rights of the Software remain exclusively with the Vendor. Intellectual
+property rights include the look and feel of the Software. This
+Agreement constitutes a license for use only and is not in any way a
+transfer of ownership rights to the Software.
+
+4.The Software may be loaded onto no more than one computer. A single
+copy may be made for backup purposes only.
+
+5.The rights and obligations of this Agreement are personal rights
+granted to the Licensee only. The Licensee may not transfer or assign
+any of the rights or obligations granted under this Agreement to any
+other person or legal entity. The Licensee may not make available the
+Software for use by one or more third parties.
+
+6.The Software may not be modified, reverse-engineered, or de-compiled
+in any manner through current or future available technologies.
+
+7.Failure to comply with any of the terms under the License section
+will be considered a material breach of this Agreement.
+
+
+License Fee
+8.The original purchase price paid by the Licensee will constitute the
+entire license fee and is the full consideration for this Agreement.
+
+
+Limitation of Liability
+9.The Software is provided by the Vendor and accepted by the Licensee
+"as is". The Vendor will not be liable for any general, special,
+incidental or consequential damages including, but not limited to, loss
+of production, loss of profits, loss of revenue, loss of data, or any
+other business or economic disadvantage suffered by the Licensee
+arising out of the use or failure to use the Software.
+
+10.The Vendor makes no warranty expressed or implied regarding the
+fitness of the Software for a particular purpose or that the Software
+will be suitable or appropriate for the specific requirements of the
+Licensee.
+
+11.The Vendor does not warrant that use of the Software will be
+uninterrupted or error-free. The Licensee accepts that software in
+general is prone to bugs and flaws within an acceptable level as
+determined in the industry.
+
+
+Warrants and Representations
+12.The Vendor warrants and represents that it is the copyright holder
+of the Software. The Vendor warrants and represents that granting the
+license to use this Software is not in violation of any other
+agreement, copyright or applicable statute.
+
+
+Acceptance
+13.All terms, conditions and obligations of this Agreement will be
+deemed to be accepted by the Licensee ("Acceptance") on installation of
+the Software.
+
+
+Term
+14.The term of this Agreement will begin on Acceptance and is perpetual.
+
+
+Termination
+15.This Agreement will be terminated and the License forfeited where
+the Licensee has failed to comply with any of the terms of this
+Agreement or is in breach of this Agreement. On termination of this
+Agreement for any reason, the Licensee will promptly destroy the
+Software or return the Software to the Vendor.
+
+
+Force Majeure
+16.The Vendor will be free of liability to the Licensee where the
+Vendor is prevented from executing its obligations under this Agreement
+in whole or in part due to Force Majeure, such as earthquake, typhoon,
+flood, fire, and war or any other unforeseen and uncontrollable event
+where the Vendor has taken any and all appropriate action to mitigate
+such an event.
+
+
+Governing Law
+17.The Parties to this Agreement submit to the jurisdiction of the
+courts of Sweden for the enforcement of this Agreement or any
+arbitration award or decision arising from this Agreement. This
+Agreement will be enforced or construed according to the laws of Sweden.
+
+
+Miscellaneous
+18.This Agreement can only be modified in writing signed by both the
+Vendor and the Licensee.
+
+19.This Agreement does not create or imply any relationship in agency
+or partnership between the Vendor and the Licensee.
+
+20.Headings are inserted for the convenience of the parties only and
+are not to be considered when interpreting this Agreement. Words in the
+singular mean and include the plural and vice versa. Words in the
+masculine gender include the feminine gender and vice versa. Words in
+the neuter gender include the masculine gender and the feminine gender
+and vice versa.
+
+21.If any term, covenant, condition or provision of this Agreement is
+held by a court of competent jurisdiction to be invalid, void or
+unenforceable, it is the parties' intent that such provision be reduced
+in scope by the court only to the extent deemed necessary by that court
+to render the provision reasonable and enforceable and the remainder of
+the provisions of this Agreement will in no way be affected, impaired
+or invalidated as a result.
+
+22.This Agreement contains the entire agreement between the parties.
+All understandings have been included in this Agreement.
+Representations which may have been made by any party to this Agreement
+may in some way be inconsistent with this final written Agreement. All
+such statements are declared to be of no value in this Agreement. Only
+the written terms of this Agreement will bind the parties.
+
+23.This Agreement and the terms and conditions contained in this
+Agreement apply to and are binding upon the Vendor's successors and
+assigns.
+
+
+Notices
+24.All notices to the Vendor under this Agreement are to be provided at
+the following address:
+ Frictional Games
+ Sodra Tvargatan 6, 252 26 Helsingborg, Sweden
+
diff --git a/profiles/license_groups b/profiles/license_groups
new file mode 100644
index 0000000..7af2940
--- /dev/null
+++ b/profiles/license_groups
@@ -0,0 +1 @@
+EULA PENUMBRA-EULA