summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/xbtt/xbtt-0_p1924.ebuild')
-rw-r--r--net-p2p/xbtt/xbtt-0_p1924.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/net-p2p/xbtt/xbtt-0_p1924.ebuild b/net-p2p/xbtt/xbtt-0_p1924.ebuild
deleted file mode 100644
index f79a614..0000000
--- a/net-p2p/xbtt/xbtt-0_p1924.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit subversion toolchain-funcs cmake-utils
-
-DESCRIPTION="BitTorrent tracker designed to offer high performance while consuming little resources."
-HOMEPAGE="http://xbtt.sourceforge.net/tracker/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE=""
-
-RDEPEND="dev-db/mysql"
-DEPEND="${RDEPEND}
- dev-libs/boost"
-
-src_unpack() {
- if [[ "${PV}" =~ (_p)([0-9]+) ]] ; then
- MTSLPT_REV=${BASH_REMATCH[2]}
- else
- MTSLPT_REV=HEAD
- fi
- subversion_fetch "https://xbtt.svn.sourceforge.net/svnroot/xbtt/trunk/xbt/misc/@${MTSLPT_REV}" misc \
- || die "${ESVN}: unknown problem occurred in subversion_fetch."
- subversion_fetch "https://xbtt.svn.sourceforge.net/svnroot/xbtt/trunk/xbt/Tracker/@${MTSLPT_REV}" Tracker \
- || die "${ESVN}: unknown problem occurred in subversion_fetch."
-}
-
-src_compile() {
- cd Tracker && \
- cmake . || die "Cmake failed"
- emake || die "build failed"
-}
-
-src_install() {
- cd Tracker && \
- dosbin xbt_tracker || die "No binary was built."
- insinto /etc
- newins xbt_tracker.conf.default xbt_tracker.conf || die "Default config absent."
- insinto /usr/share/doc/${PF}
- doins *.sql || die "Failed to install *.sql files."
-}
-
-pkg_preinst() {
- : # Avoid call to subversion_pkg_preinst
-}