summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-09-30 08:25:50 +0000
committerRichard Brown <rbrown@gentoo.org>2007-09-30 08:25:50 +0000
commit3eacc958620847a21fda5d9ceae254fc14f5e5e4 (patch)
tree0914d00f3f606b3e8efad3e4ae42f868bcee7da8
parentAdd || die to an emake (diff)
downloadrbrown-3eacc958620847a21fda5d9ceae254fc14f5e5e4.tar.gz
rbrown-3eacc958620847a21fda5d9ceae254fc14f5e5e4.tar.bz2
rbrown-3eacc958620847a21fda5d9ceae254fc14f5e5e4.zip
Bump 1.8.5 using 1.8.6 ebuild to p114 as p113. Fixes Bug #194236
svn path=/; revision=56
-rw-r--r--dev-lang/ruby/files/ruby-1.8.5_p113-net-http-p114.patch125
-rw-r--r--dev-lang/ruby/ruby-1.8.5_p113.ebuild175
2 files changed, 300 insertions, 0 deletions
diff --git a/dev-lang/ruby/files/ruby-1.8.5_p113-net-http-p114.patch b/dev-lang/ruby/files/ruby-1.8.5_p113-net-http-p114.patch
new file mode 100644
index 0000000..88246a1
--- /dev/null
+++ b/dev-lang/ruby/files/ruby-1.8.5_p113-net-http-p114.patch
@@ -0,0 +1,125 @@
+Index: ext/openssl/lib/openssl/ssl.rb
+===================================================================
+--- ext/openssl/lib/openssl/ssl.rb (revision 13501)
++++ ext/openssl/lib/openssl/ssl.rb (revision 13502)
+@@ -88,7 +88,7 @@
+ end
+ }
+ end
+- raise SSLError, "hostname not match"
++ raise SSLError, "hostname was not match with the server certificate"
+ end
+ end
+
+Index: ChangeLog
+===================================================================
+--- ChangeLog (revision 13501)
++++ ChangeLog (revision 13502)
+@@ -1,3 +1,17 @@
++Sun Sep 23 21:57:25 2007 GOTOU Yuuzou <gotoyuzo@notwork.org>
++
++ * lib/net/http.rb: an SSL verification (the server hostname should
++ be matched with its certificate's commonName) is added.
++ this verification can be skipped by
++ "Net::HTTP#enable_post_connection_check=(false)".
++ suggested by Chris Clark <cclark at isecpartners.com>
++
++ * lib/net/open-uri.rb: use Net::HTTP#enable_post_connection_check to
++ perform SSL post connection check.
++
++ * ext/openssl/lib/openssl/ssl.c
++ (OpenSSL::SSL::SSLSocket#post_connection_check): refine error message.
++
+ Sun Sep 23 06:08:38 2007 Nobuyoshi Nakada <nobu@ruby-lang.org>
+
+ * ext/stringio/stringio.c (strio_init): separate from strio_initialize
+Index: version.h
+===================================================================
+--- version.h (revision 13501)
++++ version.h (revision 13502)
+@@ -1,15 +1,15 @@
+ #define RUBY_VERSION "1.8.5"
+-#define RUBY_RELEASE_DATE "2007-09-23"
++#define RUBY_RELEASE_DATE "2007-09-24"
+ #define RUBY_VERSION_CODE 185
+-#define RUBY_RELEASE_CODE 20070923
+-#define RUBY_PATCHLEVEL 113
++#define RUBY_RELEASE_CODE 20070924
++#define RUBY_PATCHLEVEL 114
+
+ #define RUBY_VERSION_MAJOR 1
+ #define RUBY_VERSION_MINOR 8
+ #define RUBY_VERSION_TEENY 5
+ #define RUBY_RELEASE_YEAR 2007
+ #define RUBY_RELEASE_MONTH 9
+-#define RUBY_RELEASE_DAY 23
++#define RUBY_RELEASE_DAY 24
+
+ #ifdef RUBY_EXTERN
+ RUBY_EXTERN const char ruby_version[];
+Index: lib/open-uri.rb
+===================================================================
+--- lib/open-uri.rb (revision 13501)
++++ lib/open-uri.rb (revision 13502)
+@@ -229,6 +229,7 @@
+ if target.class == URI::HTTPS
+ require 'net/https'
+ http.use_ssl = true
++ http.enable_post_connection_check = true
+ http.verify_mode = OpenSSL::SSL::VERIFY_PEER
+ store = OpenSSL::X509::Store.new
+ store.set_default_paths
+@@ -240,16 +241,6 @@
+
+ resp = nil
+ http.start {
+- if target.class == URI::HTTPS
+- # xxx: information hiding violation
+- sock = http.instance_variable_get(:@socket)
+- if sock.respond_to?(:io)
+- sock = sock.io # 1.9
+- else
+- sock = sock.instance_variable_get(:@socket) # 1.8
+- end
+- sock.post_connection_check(target_host)
+- end
+ req = Net::HTTP::Get.new(request_uri, header)
+ if options.include? :http_basic_authentication
+ user, pass = options[:http_basic_authentication]
+Index: lib/net/http.rb
+===================================================================
+--- lib/net/http.rb (revision 13501)
++++ lib/net/http.rb (revision 13502)
+@@ -470,6 +470,7 @@
+ @debug_output = nil
+ @use_ssl = false
+ @ssl_context = nil
++ @enable_post_connection_check = false
+ end
+
+ def inspect
+@@ -526,6 +527,9 @@
+ false # redefined in net/https
+ end
+
++ # specify enabling SSL server certificate and hostname checking.
++ attr_accessor :enable_post_connection_check
++
+ # Opens TCP connection and HTTP session.
+ #
+ # When this method is called with block, gives a HTTP object
+@@ -584,6 +588,14 @@
+ HTTPResponse.read_new(@socket).value
+ end
+ s.connect
++ if @ssl_context.verify_mode != OpenSSL::SSL::VERIFY_NONE
++ begin
++ s.post_connection_check(@address)
++ rescue OpenSSL::SSL::SSLError => ex
++ raise ex if @enable_post_connection_check
++ warn ex.message
++ end
++ end
+ end
+ on_connect
+ end
diff --git a/dev-lang/ruby/ruby-1.8.5_p113.ebuild b/dev-lang/ruby/ruby-1.8.5_p113.ebuild
new file mode 100644
index 0000000..120701c
--- /dev/null
+++ b/dev-lang/ruby/ruby-1.8.5_p113.ebuild
@@ -0,0 +1,175 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6.ebuild,v 1.2 2007/04/07 16:23:57 pclouds Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+ONIGURUMA="onigd2_5_8"
+
+inherit autotools eutils flag-o-matic multilib versionator
+
+MY_P="${PN}-$(replace_version_separator 3 '-')"
+S=${WORKDIR}/${MY_P}
+
+SLOT=$(get_version_component_range 1-2)
+MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.gz
+ cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
+
+LICENSE="Ruby"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="cjk debug doc elibc_glibc examples ipv6 rubytests socks5 threads tk"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ socks5? ( >=net-proxy/dante-1.1.13 )
+ tk? ( dev-lang/tk )
+ >=dev-ruby/ruby-config-0.3.1
+ !=dev-lang/ruby-cvs-${SLOT}*
+ !dev-ruby/rdoc
+ !dev-ruby/rexml"
+DEPEND="${RDEPEND}"
+PROVIDE="virtual/ruby"
+
+src_unpack() {
+ unpack ${A}
+
+ if use cjk ; then
+ einfo "Applying ${ONIGURUMA}"
+ pushd ${WORKDIR}/oniguruma
+ econf --with-rubydir="${S}" || die "oniguruma econf failed"
+ emake $MY_SUFFIX || die "oniguruma emake failed"
+ popd
+ fi
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-net-http-p114.patch"
+
+ # Fix a hardcoded lib path in configure script
+ sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+ configure.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_compile() {
+ # -fomit-frame-pointer makes ruby segfault, see bug #150413.
+ filter-flags -fomit-frame-pointer
+ # In many places aliasing rules are broken; play it safe
+ # as it's risky with newer compilers to leave it as it is.
+ append-flags -fno-strict-aliasing
+
+ # Socks support via dante
+ if use socks5 ; then
+ # Socks support can't be disabled as long as SOCKS_SERVER is
+ # set and socks library is present, so need to unset
+ # SOCKS_SERVER in that case.
+ unset SOCKS_SERVER
+ fi
+
+ # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+ if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+ append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+ fi
+
+ # Bug #168939
+ # We need to always enable ipv6, use --with-lookup-order-hack=INET
+ # when we don't want ipv6 with glibc
+ if use elibc_glibc; then
+ myconf="--enable-ipv6"
+ if ! use ipv6; then
+ myconf="${myconf} --with-lookup-order-hack=INET"
+ fi
+ else
+ myconf=$(use_enable ipv6)
+ fi
+
+ econf --program-suffix=$MY_SUFFIX --enable-shared \
+ $(use_enable socks5 socks) \
+ $(use_enable doc install-doc) \
+ $(use_enable threads pthread) \
+ $(use_enable debug) \
+ $(use_with tk) \
+ ${myconf} \
+ --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
+ || die "econf failed"
+
+ emake EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_test() {
+ emake -j1 test || die "make test failed"
+
+ elog "Ruby's make test has been run. Ruby also ships with a make check"
+ elog "that cannot be run until after ruby has been installed."
+ elog
+ if use rubytests; then
+ elog "You have enabled rubytests, so they will be installed to"
+ elog "/usr/share/${PN}-${SLOT}/test. To run them you must be a user other"
+ elog "than root, and you must place them into a writeable directory."
+ elog "Then call: "
+ elog
+ elog "ruby -C /location/of/tests runner.rb"
+ else
+ elog "Enable the rubytests USE flag to install the make check tests"
+ fi
+}
+
+src_install() {
+ LD_LIBRARY_PATH="${D}/usr/$(get_libdir)"
+ RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
+ for d in $(find "${S}/ext" -type d) ; do
+ RUBYLIB="${RUBYLIB}:$d"
+ done
+ export LD_LIBRARY_PATH RUBYLIB
+
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
+
+ if use doc; then
+ make DESTDIR="${D}" install-doc || die "make install-doc failed"
+ fi
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}
+ cp -pPR sample "${D}/usr/share/doc/${PF}"
+ fi
+
+ dosym libruby$MY_SUFFIX$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%.*})
+ dosym libruby$MY_SUFFIX$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%_*})
+
+ dodoc ChangeLog NEWS README* ToDo
+
+ if use rubytests; then
+ dodir /usr/share/${PN}-${SLOT}
+ cp -pPR test "${D}/usr/share/${PN}-${SLOT}"
+ fi
+}
+
+pkg_postinst() {
+
+ ewarn "If you upgrade to >=sys-apps/coreutils-6.7-r1,"
+ ewarn "you should re-emerge ruby again."
+ ewarn "See bug #159922 for details"
+ ewarn
+ if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
+ "${ROOT}usr/sbin/ruby-config" ruby$MY_SUFFIX
+ fi
+ elog
+ elog "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
+ elog
+}
+
+pkg_postrm() {
+ if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
+ "${ROOT}usr/sbin/ruby-config" ruby$MY_SUFFIX
+ fi
+}