summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/ruby/ruby-1.8.6-scm.ebuild184
1 files changed, 184 insertions, 0 deletions
diff --git a/dev-lang/ruby/ruby-1.8.6-scm.ebuild b/dev-lang/ruby/ruby-1.8.6-scm.ebuild
new file mode 100644
index 0000000..fa6cef0
--- /dev/null
+++ b/dev-lang/ruby/ruby-1.8.6-scm.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6.ebuild,v 1.2 2007/04/07 16:23:57 pclouds Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+ONIGURUMA="onigd2_5_9"
+
+inherit autotools eutils flag-o-matic multilib subversion versionator
+
+ESVN_REPO_URI="http://svn.ruby-lang.org/repos/ruby/branches/ruby_1_8_6"
+ESVN_PROJECT="ruby"
+
+MAJOR_MINOR=$(get_version_component_range 1-2)
+MAJOR_MINOR_POINT=$(get_version_component_range 1-3)
+
+MY_P="${PN}-${MAJOR_MINOR_POINT}"
+S=${WORKDIR}/${MY_P}
+
+SLOT=$MAJOR_MINOR
+
+MY_SUFFIX=$(delete_version_separator 1 ${MAJOR_MINOR})
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
+
+LICENSE="Ruby"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="cjk debug doc elibc_glibc examples ipv6 rubytests socks5 threads tk"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ socks5? ( >=net-proxy/dante-1.1.13 )
+ tk? ( dev-lang/tk )
+ >=dev-ruby/ruby-config-0.3.1
+ !=dev-lang/ruby-cvs-${MAJOR_MINOR}*
+ !dev-ruby/rdoc
+ !dev-ruby/rexml"
+DEPEND="${RDEPEND}"
+PROVIDE="virtual/ruby"
+
+src_unpack() {
+ subversion_fetch || die "${ESVN}: unknown problem occurred in subversion_fetch."
+ subversion_bootstrap || die "${ESVN}: unknown problem occurred in subversion_bootstrap."
+
+ if use cjk ; then
+ unpack ${A}
+ einfo "Applying ${ONIGURUMA}"
+ pushd ${WORKDIR}/oniguruma
+ econf --with-rubydir="${S}" || die "econf failed"
+ emake $MY_SUFFIX
+ popd
+ fi
+
+ cd "${S}/ext/dl"
+ epatch "${FILESDIR}/${PN}-1.8.6-memory-leak.diff"
+ cd "${S}"
+
+ # Fix a hardcoded lib path in configure script
+ sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+ configure.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_compile() {
+ # -fomit-frame-pointer makes ruby segfault, see bug #150413.
+ filter-flags -fomit-frame-pointer
+ # In many places aliasing rules are broken; play it safe
+ # as it's risky with newer compilers to leave it as it is.
+ append-flags -fno-strict-aliasing
+
+ # Socks support via dante
+ if use socks5 ; then
+ # Socks support can't be disabled as long as SOCKS_SERVER is
+ # set and socks library is present, so need to unset
+ # SOCKS_SERVER in that case.
+ unset SOCKS_SERVER
+ fi
+
+ # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+ if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+ append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+ fi
+
+ # Bug #168939
+ # We need to always enable ipv6, use --with-lookup-order-hack=INET
+ # when we don't want ipv6 with glibc
+ if use elibc_glibc; then
+ myconf="--enable-ipv6"
+ if ! use ipv6; then
+ myconf="${myconf} --with-lookup-order-hack=INET"
+ fi
+ else
+ myconf=$(use_enable ipv6)
+ fi
+
+ econf --program-suffix=$MY_SUFFIX --enable-shared \
+ $(use_enable socks5 socks) \
+ $(use_enable doc install-doc) \
+ $(use_enable threads pthread) \
+ $(use_enable debug) \
+ $(use_with tk) \
+ ${myconf} \
+ --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
+ || die "econf failed"
+
+ emake EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_test() {
+ emake -j1 test || die "make test failed"
+
+ elog "Ruby's make test has been run. Ruby also ships with a make check"
+ elog "that cannot be run until after ruby has been installed."
+ elog
+ if use rubytests; then
+ elog "You have enabled rubytests, so they will be installed to"
+ elog "/usr/share/${PN}-${MAJOR_MINOR}/test. To run them you must be a user other"
+ elog "than root, and you must place them into a writeable directory."
+ elog "Then call: "
+ elog
+ elog "ruby -C /location/of/tests runner.rb"
+ else
+ elog "Enable the rubytests USE flag to install the make check tests"
+ fi
+}
+
+src_install() {
+ LD_LIBRARY_PATH="${D}/usr/$(get_libdir)"
+ RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${MAJOR_MINOR}"
+ for d in $(find "${S}/ext" -type d) ; do
+ RUBYLIB="${RUBYLIB}:$d"
+ done
+ export LD_LIBRARY_PATH RUBYLIB
+
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
+
+ if use doc; then
+ make DESTDIR="${D}" install-doc || die "make install-doc failed"
+ fi
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}
+ cp -pPR sample "${D}/usr/share/doc/${PF}"
+ fi
+
+ dosym libruby$MY_SUFFIX$(get_libname $MAJOR_MINOR_POINT) /usr/$(get_libdir)/libruby$(get_libname $MAJOR_MINOR)
+ dosym libruby$MY_SUFFIX$(get_libname $MAJOR_MINOR_POINT) /usr/$(get_libdir)/libruby$(get_libname $MAJOR_MINOR_POINT)
+
+ dodoc ChangeLog NEWS README* ToDo
+
+ if use rubytests; then
+ dodir /usr/share/${PN}-${MAJOR_MINOR}
+ cp -pPR test "${D}/usr/share/${PN}-${MAJOR_MINOR}"
+ fi
+}
+
+pkg_postinst() {
+
+ ewarn "If you upgrade to >=sys-apps/coreutils-6.7-r1,"
+ ewarn "you should re-emerge ruby again."
+ ewarn "See bug #159922 for details"
+ ewarn
+ if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
+ "${ROOT}usr/sbin/ruby-config" ruby$MY_SUFFIX
+ fi
+ elog
+ elog "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
+ elog
+}
+
+pkg_postrm() {
+ if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
+ "${ROOT}usr/sbin/ruby-config" ruby$MY_SUFFIX
+ fi
+}