summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2007-02-01 18:42:35 +0000
committerSeemant Kulleen <seemant@gentoo.org>2007-02-01 18:42:35 +0000
commit2c0b8308db61372fedeea7eef488f5d1db4149b1 (patch)
treead7de60e9cbfc243f18f0512bf70ab30437e0b71 /dev-python/django-svn/django-svn-0.1.ebuild
parentversion bump iwth bash-completion goodness and testability -- thanks to the p... (diff)
downloadseemant-2c0b8308db61372fedeea7eef488f5d1db4149b1.tar.gz
seemant-2c0b8308db61372fedeea7eef488f5d1db4149b1.tar.bz2
seemant-2c0b8308db61372fedeea7eef488f5d1db4149b1.zip
version bump to add bashcompletion and tests
svn path=/; revision=7
Diffstat (limited to 'dev-python/django-svn/django-svn-0.1.ebuild')
-rw-r--r--dev-python/django-svn/django-svn-0.1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/django-svn/django-svn-0.1.ebuild b/dev-python/django-svn/django-svn-0.1.ebuild
deleted file mode 100644
index 96d9375..0000000
--- a/dev-python/django-svn/django-svn-0.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-0.95.ebuild,v 1.2 2006/08/13 15:40:12 lucass Exp $
-
-inherit subversion distutils
-
-MY_P="${PN/d/D}-${PV}"
-DESCRIPTION="high-level python web framework"
-HOMEPAGE="http://www.djangoproject.com/"
-
-ESVN_REPO_URI="http://code.djangoproject.com/svn/django/trunk"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-IUSE="sqlite postgres mysql"
-
-DEPEND=">=dev-lang/python-2.3
- >=dev-python/setuptools-0.6_rc1"
-
-RDEPEND=">=dev-lang/python-2.3
- sqlite? ( >=dev-python/pysqlite-2.0.3 )
- postgres? ( <dev-python/psycopg-1.99 )
- mysql? ( dev-python/mysql-python )
- dev-python/imaging"
-
-S="${WORKDIR}/${MY_P}"
-DOCS="docs/* AUTHORS INSTALL LICENSE"
-
-src_install()
-{
- distutils_python_version
-
- site_pkgs="/usr/$(get_libdir)/python${PYVER}/site-packages/"
- export PYTHONPATH="${PYTHONPATH}:${D}/${site_pkgs}"
- dodir ${site_pkgs}
-
- find ${S} -name '.svn' | xargs rm -r
-
- distutils_src_install
-
- cp -r examples "${D}/usr/share/doc/${PF}"
-}