summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/udpfloodVLAN/udpfloodVLAN-2.0.ebuild')
-rw-r--r--net-misc/udpfloodVLAN/udpfloodVLAN-2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/udpfloodVLAN/udpfloodVLAN-2.0.ebuild b/net-misc/udpfloodVLAN/udpfloodVLAN-2.0.ebuild
new file mode 100644
index 0000000..111c82c
--- /dev/null
+++ b/net-misc/udpfloodVLAN/udpfloodVLAN-2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+DESCRIPTION="SIP INVITE flooder from the Hacking VoIP Exposed authors"
+HOMEPAGE="http://www.hackingvoip.com/sec_tools.html"
+SRC_URI="http://www.hackingvoip.com/tools/hack_library.tar.gz
+ http://www.hackingvoip.com/tools/${PN}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # Make the library dependency
+ cd ${WORKDIR}/hack_library
+ emake || die "emake failed"
+
+ # Make the package
+ cd ${WORKDIR}/${PN}
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd ${WORKDIR}/${PN}
+ dobin udpfloodVLAN
+ dodoc {LICENSE_DOCUMENTATION,LICENSE_SOFTWARE,Readme.txt}
+}