summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-06-28 08:41:34 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-06-28 08:41:34 +0000
commit2a8549982c652592d0d96d5b5cb38e432b6508bd (patch)
tree8ee78315f3574f74d421f4e8fedf854a9406760f
parentRemoving dev-util/catalyst, since it is in the main tree. (diff)
downloadwolf31o2-2a8549982c652592d0d96d5b5cb38e432b6508bd.tar.gz
wolf31o2-2a8549982c652592d0d96d5b5cb38e432b6508bd.tar.bz2
wolf31o2-2a8549982c652592d0d96d5b5cb38e432b6508bd.zip
Adding a new revision of app-arch/pbzip2 for testing.
svn path=/; revision=208
-rw-r--r--app-arch/pbzip2/Manifest2
-rw-r--r--app-arch/pbzip2/pbzip2-1.0.2-r1.ebuild37
-rw-r--r--profiles/categories1
3 files changed, 40 insertions, 0 deletions
diff --git a/app-arch/pbzip2/Manifest b/app-arch/pbzip2/Manifest
new file mode 100644
index 0000000..beda8af
--- /dev/null
+++ b/app-arch/pbzip2/Manifest
@@ -0,0 +1,2 @@
+DIST pbzip2-1.0.2.tar.gz 22777 RMD160 c8ea882ae9d2739250ae3bea514c14537995ed37 SHA1 8ae0ebcd08761332ade6baa4b1172a3f97f71169 SHA256 41c654b493bfd045f3a625ca9f3fb66e327ad0a4395e515c2bd6c3070b83c0e4
+EBUILD pbzip2-1.0.2-r1.ebuild 972 RMD160 883c30b4cd98bc526bd67ec0910e191baf08627a SHA1 8fa721e9c7729814947a7980ff3ff554964f1e68 SHA256 c7170eae49707554ea3647d91f4a6e2e689378ca841e72d3be1dd83237487140
diff --git a/app-arch/pbzip2/pbzip2-1.0.2-r1.ebuild b/app-arch/pbzip2/pbzip2-1.0.2-r1.ebuild
new file mode 100644
index 0000000..ee04961
--- /dev/null
+++ b/app-arch/pbzip2/pbzip2-1.0.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/pbzip2-1.0.2.ebuild,v 1.9 2007/12/11 08:53:39 vapier Exp $
+
+inherit multilib
+
+DESCRIPTION="A parallel version of BZIP2"
+HOMEPAGE="http://compression.ca/pbzip2/"
+SRC_URI="http://compression.ca/${PN}/${P}.tar.gz"
+
+LICENSE="PBZIP2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+DEPEND="app-arch/bzip2"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's:-O3:${CFLAGS}:g' ${P}/Makefile || die
+}
+
+src_compile() {
+ if use static ; then
+ cp -f /usr/$(get_libdir)/libbz2.a "${S}"
+ emake pbzip2-static || die "Failed to build"
+ else
+ emake pbzip2 || die "Failed to build"
+ fi
+}
+
+src_install() {
+ dobin pbzip2 || die "Failed to install"
+ dodoc AUTHORS ChangeLog README
+ doman pbzip2.1 || die "Failed to install man page"
+ dosym /usr/bin/pbzip2 /usr/bin/pbunzip2
+}
diff --git a/profiles/categories b/profiles/categories
index 6d28b72..4b1c599 100644
--- a/profiles/categories
+++ b/profiles/categories
@@ -1,3 +1,4 @@
+app-arch
app-misc
games-action
games-arcade