aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2016-01-11 11:06:56 +0000
committerNick Clifton <nickc@redhat.com>2016-01-11 11:06:56 +0000
commit4849dfd8f454b9c595e6ee7477f6b7b25c31a499 (patch)
tree4d5110ecdae985a3c259c377a750d4f38fd8180b /configure.ac
parentsim: config: do not try to align settings (diff)
downloadbinutils-gdb-4849dfd8f454b9c595e6ee7477f6b7b25c31a499.tar.gz
binutils-gdb-4849dfd8f454b9c595e6ee7477f6b7b25c31a499.tar.bz2
binutils-gdb-4849dfd8f454b9c595e6ee7477f6b7b25c31a499.zip
Import changes made to files shared with the FSF GCC project.
Import the following changes from the GCC mainline: 2015-11-13 Tsvetkova Alexandra <aleksandra.tsvetkova@intel.com> * configure.ac: Enable libmpx by default. * configure: Regenerated. 2015-11-19 Martin Liska <mliska@suse.cz> * .gitignore: Add .clang-format to ignored files. * Makefile.tpl: Add clang-format. * Makefile.in: Regenerate. 2015-12-01 Andreas Tobler <andreast@gcc.gnu.org> PR libffi/65726 * Makefile.def (lang_env_dependencies): Make libffi depend on cxx. * Makefile.in: Regenerate. 2015-12-02 Ian Lance Taylor <iant@google.com> PR go/66147 * Makefile.tpl (HOST_EXPORTS): Add XGCC_FLAGS_FOR_TARGET. * Makefile.in: Regenerate. 2015-12-17 Nathan Sidwell <nathan@acm.org> * config/isl.m4 (ISL_CHECK_VERSION): Add gmp libs. * configure: Regenerate. 2015-12-17 Sebastian Pop <s.pop@samsung.com> * Makefile.in: Replace ISL with isl. * Makefile.tpl: Same. * config/isl.m4: Same. * configure.ac: Same. * contrib/download_prerequisites: Same. * configure: Regenerate. 2016-01-01 Ben Elliston <bje@gnu.org> * config.guess: Import version 2016-01-01. * config.sub: Likewise. include 2016-01-07 Mike Frysinger <vapier@gentoo.org> * longlong.h: Change !__SHMEDIA__ to (!defined (__SHMEDIA__) || !__SHMEDIA__). Change __SHMEDIA__ to defined (__SHMEDIA__) && __SHMEDIA__.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 8 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 676fbc4886f..0ae53ace2b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -660,7 +660,7 @@ fi
# Enable libmpx on supported systems by request.
if test -d ${srcdir}/libmpx; then
- if test x$enable_libmpx = xyes; then
+ if test x$enable_libmpx = x; then
AC_MSG_CHECKING([for libmpx support])
if (srcdir=${srcdir}/libmpx; \
. ${srcdir}/configure.tgt; \
@@ -671,8 +671,6 @@ if test -d ${srcdir}/libmpx; then
else
AC_MSG_RESULT([yes])
fi
- else
- noconfigdirs="$noconfigdirs target-libmpx"
fi
fi
@@ -1775,31 +1773,31 @@ AC_ARG_WITH(boot-ldflags,
fi])
AC_SUBST(poststage1_ldflags)
-# GCC GRAPHITE dependency ISL.
+# GCC GRAPHITE dependency isl.
# Basic setup is inlined here, actual checks are in config/isl.m4
AC_ARG_WITH(isl,
[AS_HELP_STRING(
[--with-isl=PATH],
- [Specify prefix directory for the installed ISL package.
+ [Specify prefix directory for the installed isl package.
Equivalent to --with-isl-include=PATH/include
plus --with-isl-lib=PATH/lib])])
# Treat --without-isl as a request to disable
# GRAPHITE support and skip all following checks.
if test "x$with_isl" != "xno"; then
- # Check for ISL
+ # Check for isl
dnl Provide configure switches and initialize islinc & isllibs
dnl with user input.
ISL_INIT_FLAGS
- dnl The versions of ISL that work for Graphite
+ dnl The versions of isl that work for Graphite
ISL_CHECK_VERSION()
- dnl Only execute fail-action, if ISL has been requested.
+ dnl Only execute fail-action, if isl has been requested.
ISL_IF_FAILED([
- AC_MSG_ERROR([Unable to find a usable ISL. See config.log for details.])])
+ AC_MSG_ERROR([Unable to find a usable isl. See config.log for details.])])
fi
-# If the ISL check failed, disable builds of in-tree variant of ISL
+# If the isl check failed, disable builds of in-tree variant of isl
if test "x$with_isl" = xno ||
test "x$gcc_cv_isl" = xno; then
noconfigdirs="$noconfigdirs isl"