summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiklas Hambüchen <mail@nh2.me>2019-08-08 22:02:27 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-11-25 23:01:33 +0100
commit4b533b0c03034bfb7ecbf744a17119eac362244c (patch)
treed642382116ca29993768fcf2c2548fd85a01aadb
parentmips: Force RWX stack for hard-float builds that can run on pre-4.8 kernels (diff)
downloadglibc-4b533b0c03034bfb7ecbf744a17119eac362244c.tar.gz
glibc-4b533b0c03034bfb7ecbf744a17119eac362244c.tar.bz2
glibc-4b533b0c03034bfb7ecbf744a17119eac362244c.zip
malloc: Fix missing accounting of top chunk in malloc_info [BZ #24026]
Fixes `<total type="rest" size="..."> incorrectly showing as 0 most of the time. The rest value being wrong is significant because to compute the actual amount of memory handed out via malloc, the user must subtract it from <system type="current" size="...">. That result being wrong makes investigating memory fragmentation issues like <https://bugzilla.redhat.com/show_bug.cgi?id=843478> close to impossible. (cherry picked from commit b6d2c4475d5abc05dd009575b90556bdd3c78ad0) (cherry picked from commit 5f620768fbdae75f71af78852be228ad5577623d)
-rw-r--r--ChangeLog6
-rw-r--r--malloc/malloc.c6
2 files changed, 12 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 43c9a70ed1..e1d8fd3c66 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2019-08-08 Niklas Hambüchen <mail@nh2.me>
+ Carlos O'Donell <carlos@redhat.com>
+
+ [BZ #24026]
+ * malloc/malloc.c (__malloc_info): Account for top chunk.
+
2019-11-01 Dragan Mladjenovic <dmladjenovic@wavecomp.com>
* sysdeps/unix/sysv/linux/mips/Makefile
diff --git a/malloc/malloc.c b/malloc/malloc.c
index 343d89f489..0e65d636cd 100644
--- a/malloc/malloc.c
+++ b/malloc/malloc.c
@@ -5406,6 +5406,12 @@ __malloc_info (int options, FILE *fp)
__libc_lock_lock (ar_ptr->mutex);
+ /* Account for top chunk. The top-most available chunk is
+ treated specially and is never in any bin. See "initial_top"
+ comments. */
+ avail = chunksize (ar_ptr->top);
+ nblocks = 1; /* Top always exists. */
+
for (size_t i = 0; i < NFASTBINS; ++i)
{
mchunkptr p = fastbin (ar_ptr, i);